[Résolu] Les cadres disparaissent au format HTML

Discussions à propos du traitement de textes Writer mais également sur l'éditeur HTML.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

[Résolu] Les cadres disparaissent au format HTML

Messagepar Ant1 » 27 Nov 2012 10:08

Bonjour,
Avec une version précédente de OO j'avais créé un site avec plusieurs pages web pleines d'images devant les unes les autres... bref je m'étais bien amusé !
J'ai depuis ré-installé mon ordinateur et un nouvel OO.
Il me faudrait modifier certaines pages aujourd'hui mais quand j'ouvre l'une de ces pages le "cadre" qui me servait de base de mise en page et dans lequel toutes mes images sont ancrées est absent.
Et quand je sauvegarde et rouvre mon document aucun n'objet n'est à sa place, le cadre à disparu, les ancrage sont liés au paragraphe...
Quelle est l'option que je n'ai pas coché ou l'inverse ? quelle solution ?

Merci
Antoine
Dernière édition par MrPropre le 28 Nov 2012 12:40, édité 2 fois.
Raison: Balise [Résolu] - Coche présente mais a mettre dans le 1er message
OpenOffice 3.4.0 sous Windows Xp pro
Ant1
Fraîchement OOthentifié
 
Message(s) : 8
Inscrit le : 27 Nov 2012 09:51

Re: Enregistrer un fichier en Html

Messagepar jeanmimi » 27 Nov 2012 10:37

Bonjour,
Pour faire ce que tu décris, il me semble qu'un tableau serait plus adapté qu'un cadre.
Tu peux aussi joindre un exemple pour tester.
LibreOffice Version 4.2.3 (16 avril 2014)
Java 1.7.0_xx, Windows XP SP 3, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11304
Inscrit le : 03 Mars 2006 17:02
Localisation : Niort et sa Venise verte

Re: Enregistrer un fichier en Html

Messagepar Ant1 » 27 Nov 2012 10:57

Bon il faut savoir que je suis graphiste print, je n'y connais donc rien en web !
j'ai fais mes pages web en autodidacte en mettant de images parfois trop lourde ou mal adaptée...
Alors voilà la page finale : h**p://www.herosdei.com/boutique/promotions.html

Par ailleurs comme la mise en forme des différentes pages du site se voulait strictement identique si je change pour un tableau je vais avoir du mal à retrouver mes petits...
OpenOffice 3.4.0 sous Windows Xp pro
Ant1
Fraîchement OOthentifié
 
Message(s) : 8
Inscrit le : 27 Nov 2012 09:51

Re: Enregistrer un fichier en Html

Messagepar jeanmimi » 27 Nov 2012 11:14

Voilà ce que je constate à l'écran : le cadre est bien visible
Pièces jointes
Page_html.jpg
LibreOffice Version 4.2.3 (16 avril 2014)
Java 1.7.0_xx, Windows XP SP 3, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11304
Inscrit le : 03 Mars 2006 17:02
Localisation : Niort et sa Venise verte

Re: Enregistrer un fichier en Html

Messagepar Ant1 » 27 Nov 2012 11:49

Tu as là le fichier non encore modifié.
Et Il ne s'agit pas de ce cadre là en fait, bien que celui-ci saute aussi !

mon fichier c'est des poupées russes :
il y a des cadres dans les cadres...

il y a en fait un cadre qui contient tout ça !
et toutes les images sont ancrées à ce cadre
Mais quand j'ouvre ce même fichier avec OO 3 le cadre n'est plus...
Les images sont en bonne place, mais si je sauvegarde, ferme et rouvre, comme le cadre n'est pas là tout mes ancrages sautent !
J'ai vérifié avant de sauvegardé et en fait je n'est pas l'option ancrage au cadre (il est plus là) ni ancrage à la page : il ne me reste que paragraphe, caractère...
OpenOffice 3.4.0 sous Windows Xp pro
Ant1
Fraîchement OOthentifié
 
Message(s) : 8
Inscrit le : 27 Nov 2012 09:51

Re: Enregistrer un fichier en Html

Messagepar jeanmimi » 27 Nov 2012 11:53

J'ai bien l'ancrage à la page
Page_html_ancrage.jpg
Page_html_ancrage.jpg (34.49 Kio) Consulté 790 fois

et l'ancrage dans le cadre, si je clique sur la bordure
Page_html_ancrage_cadre.jpg
LibreOffice Version 4.2.3 (16 avril 2014)
Java 1.7.0_xx, Windows XP SP 3, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11304
Inscrit le : 03 Mars 2006 17:02
Localisation : Niort et sa Venise verte

Re: Enregistrer un fichier en Html

Messagepar Dude » 27 Nov 2012 11:59

Salut,

Ant1 a écrit:Mais quand j'ouvre ce même fichier avec OO 3 le cadre n'est plus...

Les questions passent et repassent sur ce forum : viewtopic.php?f=3&t=29439&hilit=html+cadre

OpenOffice 3 sous Windows Xp pro

3 quoi ? On en est à la 3.4.1.
La précision permet aux bénévoles de ne pas répondre sur des versions obsolètes.
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 16273
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Enregistrer un fichier en Html

Messagepar Ant1 » 27 Nov 2012 12:17

@jeanmimi : oui les images sont à ce moment ancrées à la page, mais si je regarde dans le détail : clic droit, l'ancrage à la page n'est pas dispo, donc un save, une fermeture plus tard hop tout cassé !
de plus j'ai des fichiers .gif qui sont créés et que je n'ai pas demandés...
avant save.jpg
avant

reouverture.jpg
après

dossier.jpg
magie


@dude : donc pas de cadre en html, mais alors comment avais-je réussi à faire des cadres dans mes précédentes pages ?
OpenOffice 3.4.0 sous Windows Xp pro
Ant1
Fraîchement OOthentifié
 
Message(s) : 8
Inscrit le : 27 Nov 2012 09:51

Re: Enregistrer un fichier en Html

Messagepar jeanmimi » 27 Nov 2012 12:29

Je ne reproduis pas cette apparence avec LibO 3.6.3.2.
Pièces jointes
après.jpg
Dernière édition par jeanmimi le 27 Nov 2012 13:31, édité 1 fois.
LibreOffice Version 4.2.3 (16 avril 2014)
Java 1.7.0_xx, Windows XP SP 3, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11304
Inscrit le : 03 Mars 2006 17:02
Localisation : Niort et sa Venise verte

Re: Enregistrer un fichier en Html

Messagepar Ant1 » 27 Nov 2012 12:34

@dude : OpenOffice 3.4.0
OpenOffice 3.4.0 sous Windows Xp pro
Ant1
Fraîchement OOthentifié
 
Message(s) : 8
Inscrit le : 27 Nov 2012 09:51

Re: Enregistrer un fichier en Html

Messagepar Dude » 27 Nov 2012 15:10

Ant1 a écrit:mais alors comment avais-je réussi à faire des cadres dans mes précédentes pages ?

A toi de nous le dire... :?
Le document a été créé à l'origine sous OpenOffice 3.1 (c'est inscrit dans les <meta>).
Tu as certainement utilisé un autre éditeur HTML pour faire des modifications.

Merci d'ajouter [Résolu] au début du titre de ton 1er message et de cocher la case de l'icône de sujet (le V vert).
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 16273
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Enregistrer un fichier en Html

Messagepar Ant1 » 27 Nov 2012 15:20

non non non
je n'ai pas utilisé d'autre logiciel... comme je le disais je suis une bille en web, je me suis pas compliqué la vie !
version 3.1 ? ok je savais pas où chercher...
je vais peut être revenir à la version 3.1 !
OpenOffice 3.4.0 sous Windows Xp pro
Ant1
Fraîchement OOthentifié
 
Message(s) : 8
Inscrit le : 27 Nov 2012 09:51

Re: Enregistrer un fichier en Html

Messagepar Dude » 27 Nov 2012 15:40

Ant1 a écrit:je vais peut être revenir à la version 3.1 !

3.1, 3.2, 3.3 ou 3.4... peu importe : aucune ne sait gérer les balises <div> qui apparaissent dans ton fichier.
L'éditeur ne sait faire que du <span> pour placer les cadres.

Bis repetitae :
Dude a écrit:Merci d'ajouter [Résolu] au début du titre de ton 1er message et de cocher la case de l'icône de sujet (le V vert).

Profite en pour modifier ton titre afin qu'il reflète le problème exposé : Les cadres disparaissent au format HTML
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 16273
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Enregistrer un fichier en Html

Messagepar Ant1 » 27 Nov 2012 16:25

Résolu ? ah bon ?
Tu ne saurais pas parler le "débutant" ?
Ant1 a écrit:je n'ai pas utilisé d'autre logiciel... comme je le disais je suis une bille en web, je me suis pas compliqué la vie !

<div> <span> ? chinois ! comprend pas !

Je change le titre OK
mais ce que tu me proposes ne correspond pas à mon problème !
Que penses tu de : "enregistrer en html des balises <span>"
puisque c'est, d'après toi, le problème !
Je ne sais pas pour "l'éditeur" mais comme je l'ai déjà fait il doit bien y avoir une solution...

Bis Repetita :
Ant1 a écrit:Avec une version précédente de OO j'avais créé un site avec plusieurs pages web pleines d'images devant les unes les autres...
[...]
Il me faudrait modifier certaines pages aujourd'hui mais [...]
OpenOffice 3.4.0 sous Windows Xp pro
Ant1
Fraîchement OOthentifié
 
Message(s) : 8
Inscrit le : 27 Nov 2012 09:51

Re: Enregistrer un fichier en Html

Messagepar Dude » 27 Nov 2012 16:52

Ant1 a écrit:<div> <span> ? chinois ! comprend pas !

http://lmgtfy.com/?q=balises+%3Cdiv%3E+et+%3Cspan%3E :D

Ant1 a écrit:puisque c'est, d'après toi, le problème !

Non, le problème est celui que tu décris :
Ant1 a écrit:Mais quand j'ouvre ce même fichier avec OO 3 le cadre n'est plus

Tu dis bien avoir un problème de cadre qui disparait non ?

Et la solution est donnée dans le fil précité : il faut utiliser des tableaux sans bordure pour placer tes images.
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 16273
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Enregistrer un fichier en Html

Messagepar yclik » 28 Nov 2012 10:28

Bonjour
A priori, les fichiers html ouvert en faisant :
Clik droit>ouvrir avec> Writer ne s'enregistre pas toujours convenablement.
Il faut plutôt ouvrir en faisant :
Fichier>ouvrir>sélectionner le fichier à ouvrir ayant l'extension html ou htm.

Pour les "fichiers .gif" qui sont créés il faut refaire l'insertion de l'image en cochant "lier" dans la boite de dialogue sous réserve d'avoir la même arborescence de fichier en local et sur le serveur.
OpenOffice 4.0.1 sous Windows 7
Avatar de l’utilisateur
yclik
PassiOOnné
PassiOOnné
 
Message(s) : 515
Inscrit le : 15 Déc 2010 09:33

problème de cadre en html

Messagepar Ant1 » 28 Nov 2012 11:19

Yclic : merci pour cette idée alternative mais j'ai essayé et ça n'a pas eu l'air de changer quoi que ce soit à mon problème !
Dude : merci de m'avoir parlé des balises ça m'a permis de comprendre mon problème et de le résoudre !
A mon sens ce fil est résolu mais si c'est grâce à toi, tu ne l'as pas fais exprès !
Je me permettrais un conseil : fais attention tu donnes un peu l'impression de prendre les gens pour des c.n !

Dans le menu "outils" de OO il y a "options" !
Là on trouve un chapitre "chargement et enregistrement" !
au bout duquel il y a "compatibilité HTML" avec plein d'option dont je ne connais pas l'usage de la première...
Mais il y a notamment "importer les balises inconnues comme champs" !
Cette option n'était pas cochée chez moi : hop je la coche et ça marche !
Mes cadres et images restent en place ! cool !
ma solution.jpg
clic


Merci de votre aide
Antoine
OpenOffice 3.4.0 sous Windows Xp pro
Ant1
Fraîchement OOthentifié
 
Message(s) : 8
Inscrit le : 27 Nov 2012 09:51

Re: problème de cadre en html

Messagepar Dude » 28 Nov 2012 14:32

Ant1 a écrit:Mais il y a notamment "importer les balises inconnues comme champs" !
Cette option n'était pas cochée chez moi : hop je la coche et ça marche !

Ca marche mais tu ne pourras plus modifier ces cadres puisqu'ils ne sont plus reconnus.
Ta solution est donc un pis-aller.
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 16273
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1


Retour vers Traitement de textes

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 9 invité(s)