[Base] Erreur sur l'envoi d'un courriel

Discussions et questions sur tout ce qui concerne la programmation tous langages et tous modules confondus.

Modérateur: Vilains modOOs

Règles du forum
:alerte: Balisage obligatoire dans cette section !
Aidez-nous à vous aider au mieux en balisant correctement votre question : reportez-vous sur les règles de cette section avant de poster !

[Base] Erreur sur l'envoi d'un courriel

Messagepar boudebois » 17 Juin 2019 11:20

Bonjour à tous
Je sollicite une nouvelle fois votre aide.
J'aimerai, à partir d'un formulaire, envoyer un mail prédéfini.( sujet et adresse)
J'ai essayer de retravailler une macro prise sur le forum, je n'ai très surement pas tout compris car j'ai un message d'erreur.

Capture erreur macro courriel.JPG


Archives Vers 2.odb
Ma base
(38.36 Kio) Téléchargé 10 fois


Si vous pouvez m’expliquè ce que je ne fais pas correctement ce serai génial.
Bien amicalement
Version: 5.4.5.1.M2 (x64) (version imposée ) sur Win7 64
boudebois
Membre lOOyal
Membre lOOyal
 
Message(s) : 27
Inscrit le : 22 Mars 2014 20:04

Re: [Base] Erreur sur l'envoi d'un courriel

Messagepar DLE » 17 Juin 2019 12:28

Bonjour,

Une erreur de syntaxe, la commande s'écrit comme ceci :
Code : Tout sélectionner   AgrandirRéduire
Client = Messagerie.queryMailClient("C:\Program Files (x86)\Mozilla Thunderbird\thunderbird.exe")


Comme on peut envoyer à plusieurs adresses en copie et/ou copie cachée, il faut les déclarer en tableau, il en est de même pour les pièces attachées.
Code : Tout sélectionner   AgrandirRéduire
         Courrier.CcRecipient = array()   ' **** Copie A
         Courrier.BccRecipient = array()   ' **** Copie Caché
         Courrier.Attachement = array()   ' **** Piece Jointe()


Cdlt.
Pièces jointes
Archives Vers 2.odb
Correction des paramètres du courriel.
(38.36 Kio) Téléchargé 10 fois
AOO 4.1.6 sous Windows 10 64 bits, FireFox, Thunderbird, ORB 1.2.1
Avatar de l’utilisateur
DLE
SuppOOrter
SuppOOrter
 
Message(s) : 1213
Inscrit le : 30 Déc 2007 19:56
Localisation : Lille

Re: [Base] Erreur sur l'envoi d'un courriel

Messagepar Piaf » 17 Juin 2019 12:41

Bonjour
Code : Tout sélectionner   AgrandirRéduire
Messagerie = CreateUnoService("com.sun.star.system.SystemMailProvider")
Tu es certain que ce service existe sous LibO ?
A+
Libre Office Version: 6.1.6 et Apache OpenOffice 4.1.6 Sur Xubuntu 18.04 AMD64
Piaf
GourOOu
GourOOu
 
Message(s) : 5622
Inscrit le : 25 Nov 2011 19:07
Localisation : Guyane

Re: [Base] Erreur sur l'envoi d'un courriel

Messagepar boudebois » 17 Juin 2019 14:04

Merci DLE mais malgré la modif j'ai toujours une erreur, y a t'il une autre solution ?

Erreur macro courriel.JPG
RE erreur


Cordialement
Version: 5.4.5.1.M2 (x64) (version imposée ) sur Win7 64
boudebois
Membre lOOyal
Membre lOOyal
 
Message(s) : 27
Inscrit le : 22 Mars 2014 20:04

Re: [Base] Erreur sur l'envoi d'un courriel

Messagepar micmac » 17 Juin 2019 14:11

Bonjour,
Dans votre signature il y a écrit:Libreoffice Version: 4.1.5.3 sur Win7 64 Bits
Soit votre version de LibreOffice est complètement dépassée (la dernière version stable est LibO 6.1.6), soit vous avez fait erreur et il s'agit de OpenOffice (la dernière version est AOO 4.1.6).
Afin de profiter des dernières améliorations, il est fortement recommandé d'être à jour de la dernière version
Accès direct à votre signature pour la corriger.

Cordialement
Dans votre signature vous devez préciser la ou les versions exactes d'OpenOffice ou de LibreOffice et du ou des systèmes utilisés.
Exemple : AOO 4.1.6 (version imposée selon le cas) sous Win7 SP1, Win 8.1, Win 10, macOS 10.14.5, Ubuntu 18.10...
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 5970
Inscrit le : 28 Août 2010 09:45

Re: [Base] Erreur sur l'envoi d'un courriel

Messagepar boudebois » 17 Juin 2019 14:34

Correction apporté à ma signature :wink:

La modération a écrit:En indiquant LibreOffice ce serait mieux
Version: 5.4.5.1.M2 (x64) (version imposée ) sur Win7 64
boudebois
Membre lOOyal
Membre lOOyal
 
Message(s) : 27
Inscrit le : 22 Mars 2014 20:04

Re: [Base] Erreur sur l'envoi d'un courriel

Messagepar Dude » 17 Juin 2019 15:05

boudebois a écrit: y a t'il une autre solution ?

Oui, lire ce que te dit Piaf :
Piaf a écrit:Tu es certain que ce service existe sous LibO ?


Et relire le suprême de code concerné.
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 20794
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: [Base] Erreur sur l'envoi d'un courriel

Messagepar boudebois » 17 Juin 2019 15:47

Bien sur que j'ai lu la réponse de Piaf qui été en faite une question.
Je ne sais pas si cela est possible, d’où ma question "y a t'il une autre solution ?"
Tant qu'au suprême de code j'ai beau le lire et le relire je ne comprend pas tout.
J'ai beau essaye de faire de mon mieux, quand je ne comprend pas j’appelle à l'aide , c’est comme ça que je progresse.
Bien cordialement :cry:
Version: 5.4.5.1.M2 (x64) (version imposée ) sur Win7 64
boudebois
Membre lOOyal
Membre lOOyal
 
Message(s) : 27
Inscrit le : 22 Mars 2014 20:04

Re: [Base] Erreur sur l'envoi d'un courriel

Messagepar Dude » 17 Juin 2019 15:54

boudebois a écrit:Tant qu'au suprême de code j'ai beau le lire et le relire je ne comprend pas tout.

Qu'est ce que tu ne comprends pas dans cette phrase ?
no_problemo.PNG
Bien sûr, AOO = Apache OpenOffice

La solution est donc de prendre le code dédié à LibO.
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 20794
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: [Base] Erreur sur l'envoi d'un courriel

Messagepar boudebois » 17 Juin 2019 16:09

Merci Dude de m'avoir éclairé.
Je n'avais pas percuté.
Je vais approfondir la question.
Cordialement
Version: 5.4.5.1.M2 (x64) (version imposée ) sur Win7 64
boudebois
Membre lOOyal
Membre lOOyal
 
Message(s) : 27
Inscrit le : 22 Mars 2014 20:04

Re: [Base] Erreur sur l'envoi d'un courriel

Messagepar Piaf » 17 Juin 2019 18:36

Re
En complément de la réponse de Dude, comme tu travailles avec Thunderbird, tu peux éventuellement consulter les arguments de ligne de commande du courrielleur "Compose" [url]h**p://kb.mozillazine.org/Command_line_arguments_%28Thunderbird%29[/url] à utiliser avec shell.
A+
Libre Office Version: 6.1.6 et Apache OpenOffice 4.1.6 Sur Xubuntu 18.04 AMD64
Piaf
GourOOu
GourOOu
 
Message(s) : 5622
Inscrit le : 25 Nov 2011 19:07
Localisation : Guyane


Retour vers Macros et API

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot], Roby68 et 6 invité(s)