Copier coller ne fonctionne pas

Discussion à propos de l'éditeur de formule mathématique et d'équation Math

Modérateur: Vilains modOOs

Règles du forum
Attention : cette section n'est pas consacrée au tableur Calc mais à l'éditeur de formule mathématique et d'équation.

Copier coller ne fonctionne pas

Messagepar alcidi » 18 Déc 2019 16:27

Bonjour,
Lorsque j'écris une phrase mathématique dans le cadre consacré à cela dans maths et que je veux copier tout ou partie de cette écriture pour la coller dans le même cadre, cela ne fonctionne pas.
Avez-vous la même chose ?
Je précise que j'ai installé LibreOffice en purgeant mon profil.
LibreOffice 6.4.2 des dépôts sur Ubuntu 20.04
Avatar de l’utilisateur
alcidi
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 283
Inscrit le : 10 Nov 2005 06:38
Localisation : Saône et Loire (71)

Re: Copier coller ne fonctionne pas

Messagepar jeanmimi » 18 Déc 2019 17:08

Bonjour,
alcidi a écrit:une phrase mathématique dans le cadre consacré à cela

Peux-tu donner un exemple ?
Car je ne comprends pas trop : les formules ou les algorithmes s'écrivent dans la partie inférieure de la fenêtre et apparaissent dans la partie supérieure où ils sont insérés dans un cadre.
LibreOffice Version : Version : 7.0.0.3 (x64)(6 aout 2020)
Adoptopen JRE ou Oracle JRE (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 15403
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Copier coller ne fonctionne pas

Messagepar alcidi » 18 Déc 2019 17:15

Oui, pas de souci, lorsque j'écris dans la partie inférieure, et que copie un bout de phrase de cette partie inférieure pour la coller toujours dans cette même partie.

Par ex :

J'écris
nitalic{ {%PHI}_{spire}`=`vec B . vec S`=`B.S.cos{"("vec S . vec B")" }}

puis je veux coller la dernière partie après l'avoir sélectionnée pour ne pas avoir à la retaper , par ex pour modifier juste un truc sans avoir tout à reécrire :
nitalic{ {%PHI}_{spire}`=`vec B . vec S`=`B.S.cos{"("vec S . vec B")"`=`B.S.cos{"("vec S . vec B")" }}

pour écrire ensuite par ex
nitalic{ {%PHI}_{spire}`=`vec B . vec S`=`B.S.cos{"("vec S . vec B")"`=`B.S.cos{"("vec B . vec S")" }}

et bien le copier coller ne fonctionne pas.
LibreOffice 6.4.2 des dépôts sur Ubuntu 20.04
Avatar de l’utilisateur
alcidi
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 283
Inscrit le : 10 Nov 2005 06:38
Localisation : Saône et Loire (71)

Re: Copier coller ne fonctionne pas

Messagepar Jean-Louis Cadeillan » 18 Déc 2019 17:34

Bonjour,
Je ne reproduis pas sous LibO 6.2.8 Win 7.
Est-ce ce dysfonctionnement se produit quel que soit le mode de copier coller (à la souris, au clavier) ?
Est-ce que le document contient de très nombreuses formules ?
Est-ce que ça se produit avec n'importe quel document ?
Est-ce que ça se produit dans un document Math, comme dans une formule embarquée dans Writer ?
Est-ce que ça se produit avec un nouveau document ?
Cordialement,
Jean-Louis
LibO 6.3.6.2 (x64 avec Java 1.8.0_241) et AOO 4.1.7 (avec Java x32 1.8.0_261), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5017
Inscrit le : 03 Jan 2009 00:56

Re: Copier coller ne fonctionne pas

Messagepar alcidi » 18 Déc 2019 17:41

Je suis sur ubuntu 19.10 et LibO 6.2.8.

Jean-Louis Cadeillan a écrit:Est-ce ce dysfonctionnement se produit quel que soit le mode de copier coller (à la souris, au clavier) ?

Oui
Jean-Louis Cadeillan a écrit:Est-ce que le document contient de très nombreuses formules ?

Oui
Jean-Louis Cadeillan a écrit:Est-ce que ça se produit avec n'importe quel document ?

Oui
Jean-Louis Cadeillan a écrit:Est-ce que ça se produit dans un document Math, comme dans une formule embarquée dans Writer ?

Oui
Jean-Louis Cadeillan a écrit:Est-ce que ça se produit avec un nouveau document ?

Oui

:(
LibreOffice 6.4.2 des dépôts sur Ubuntu 20.04
Avatar de l’utilisateur
alcidi
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 283
Inscrit le : 10 Nov 2005 06:38
Localisation : Saône et Loire (71)

Re: Copier coller ne fonctionne pas

Messagepar Jean-Louis Cadeillan » 18 Déc 2019 17:49

Est-ce que ça se produit, si tu fermes LibO complètement et si tu ouvres avec un nouveau document Math vierge ?
 Ajout : Est-ce que ça se produit dès que le nombre de caractères dépasse 100 ? 


Cordialement,
Jean-Louis
LibO 6.3.6.2 (x64 avec Java 1.8.0_241) et AOO 4.1.7 (avec Java x32 1.8.0_261), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5017
Inscrit le : 03 Jan 2009 00:56

Re: Copier coller ne fonctionne pas

Messagepar alcidi » 18 Déc 2019 18:18

Jean-Louis Cadeillan a écrit:Est-ce que ça se produit, si tu fermes LibO complètement et si tu ouvres avec un nouveau document Math vierge ?

Mais je me rends compte que finalement ça marche très bien pour un premier copier coller mais je n'ai pas le droit d'en faire d'autres.
Jean-Louis Cadeillan a écrit: Ajout : Est-ce que ça se produit dès que le nombre de caractères dépasse 100 ? 

Peu importe le nombre de caractères.
LibreOffice 6.4.2 des dépôts sur Ubuntu 20.04
Avatar de l’utilisateur
alcidi
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 283
Inscrit le : 10 Nov 2005 06:38
Localisation : Saône et Loire (71)

Re: Copier coller ne fonctionne pas

Messagepar Dude » 19 Déc 2019 08:44

Pour moi, ce fil est un doublon.
Même source que : https://forum.openoffice.org/fr/forum/viewtopic.php?f=3&t=61568
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 21734
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Copier coller ne fonctionne pas

Messagepar jeanmimi » 20 Déc 2019 15:43

Bonjour,
alcidi a écrit:puis je veux coller la dernière partie après l'avoir sélectionnée pour ne pas avoir à la retaper , par ex pour modifier juste un truc sans avoir tout à reécrire :
nitalic{ {%PHI}_{spire}`=`vec B . vec S`=`B.S.cos{"("vec S . vec B")"`=`B.S.cos{"("vec S . vec B")" }}
... et bien le copier coller ne fonctionne pas.

Je ne reproduis pas, je note simplement qu'il faut ajouter une troisième accolade à la fin :
Code : Tout sélectionner   AgrandirRéduire
nitalic{ {%PHI}_{spire}`=`vec B . vec S`=`B.S.cos{"("vec S . vec B")" =`B.S.cos{"("vec S . vec B")"}}}
Pièces jointes
Formule.jpg
Formule.jpg (6.79 Kio) Consulté 1325 fois
LibreOffice Version : Version : 7.0.0.3 (x64)(6 aout 2020)
Adoptopen JRE ou Oracle JRE (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 15403
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: Copier coller ne fonctionne pas

Messagepar alcidi » 04 Jan 2020 15:08

Oui pour l'accolade. Sans doute j'avais oublié de la copier.
Oui et non pour le doublon, le copier coller aléatoire n'est peut-être pas dû à la même cause dans Maths et dans Writer , d'où ce pseudo doublon.
LibreOffice 6.4.2 des dépôts sur Ubuntu 20.04
Avatar de l’utilisateur
alcidi
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 283
Inscrit le : 10 Nov 2005 06:38
Localisation : Saône et Loire (71)

Re: Copier coller ne fonctionne pas

Messagepar Dude » 04 Jan 2020 16:21

alcidi a écrit:Oui et non pour le doublon

Ah bon ? En mode sans échec, le problème persiste ?
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 21734
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Copier coller ne fonctionne pas

Messagepar alcidi » 04 Jan 2020 21:38

Oui même en mode sans échec je rencontre ce problème qu'apparemment je suis le seul à expérimenter.
LibreOffice 6.4.2 des dépôts sur Ubuntu 20.04
Avatar de l’utilisateur
alcidi
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 283
Inscrit le : 10 Nov 2005 06:38
Localisation : Saône et Loire (71)

Re: Copier coller ne fonctionne pas

Messagepar troumad » 05 Juil 2020 06:38

Tu as toujours ce problème ?
C'est bien la première fois que je le vois. J'ai beaucoup manipulé d'équations et je continue toujours de la faire. Je n'ai jamais eu ce problème.
LibreOffice sous Mageia Linux Cauldron des dépôts de Mageia Cauldron (derrière version, voire version de test)
LibreOffice sous Mageia Linux Stable pour tests
Au travail : LibreOffice sous Windows (version qui peut varier d'un ordinateur à l'autre)
Avatar de l’utilisateur
troumad
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 50
Inscrit le : 15 Août 2019 13:52
Localisation : Genas (F-69)


Retour vers Math

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité