[Résolu] Les images dans La Gallery, Mon Thème, sont floues

Discussions sur le module de dessin de Draw.

Modérateur: Vilains modOOs

[Résolu] Les images dans La Gallery, Mon Thème, sont floues

Messagepar Egon » 25 Fév 2014 10:20

Bonjour à tous,
Malgré mes recherches, je n'ai pas su trouver la solution au problème suivant :
Depuis peu, les éléments de dessin que je glisse dans Mon Thème de La Gallery pour en faire des symboles réutilisables, apparaissent flous dans la Gallery, mais sont tout à fait normaux à l'insertion dans une page de dessin. Dans des versions précédentes de OpenOffice, ce problème n'existait pas...
Merci si vous pouvez m'aider sur ce problème,
Pierre
Sur l'image ci-dessous, à gauche les symboles insérés dans la page de dessin, à droite, la Gallery :
Drawgallery.jpg
Dernière édition par Egon le 28 Fév 2015 19:18, édité 1 fois.
Apache OpenOffice 4.1.1 sous Windows 7 Édition Familiale Prémium
Egon
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 07 Oct 2011 20:29

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar londoners » 25 Fév 2014 12:06

Bonjour,

Egon a écrit:Depuis peu...

Profil corrompu ?
Purge ton profil et vois ce que cela donne.
Sinon as-tu fait une instal en tant qu'admin par un clic droit sur le fichier .exe ?
ClicDroit AdministrateurAOO401.png

Si ce n'est pas le cas il faut réinstaller après avoir purgé le profil.
==>
A+
ApacheOpenOffice 4.1.4. téléchargé sur le site officiel
Extension de sauvegarde incrémentée incrSav 1.0.8
Lubuntu The Wily Werewolf 15.10 &
W10 Pro / 7 Pro SP1
KCCO
Avatar de l’utilisateur
londoners
SuppOOrter
SuppOOrter
 
Message(s) : 1487
Inscrit le : 19 Fév 2009 09:25
Localisation : Du pays où habite la pluie

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar Egon » 25 Fév 2014 14:29

Merci pour tes conseils londoners, mais la purge complète du profil n'a pas résolu le problème. Aussi, comme ce n'est pas bloquant, je vais remettre la réinstallation complète à la prochaine version.
Un autre indice : si je récupère d'une sauvegarde les fichiers du thème (SDV, SDG, THM) tout rentre dans l'ordre, mais évidemment sans les symboles créés ou modifiés depuis.
Cordialement,
Pierre
Apache OpenOffice 4.1.1 sous Windows 7 Édition Familiale Prémium
Egon
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 07 Oct 2011 20:29

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar Ravioli » 25 Fév 2014 15:18

Bonjour,

  1. Pourriez-vous préciser la manière dont vous avez procédé pour placer vos images modifiées dans votre gallery ?

    Est-ce à partir d'un document Draw > ajouter l'image dans le thème comme pour une image vectorielle :
    • ajustez le zoom et les ascenseurs pour visualiser l'ensemble de l'image à insérer
    • cliquez de façon prolongée sans bouger sur l'image. Au bout de quelques secondes, l'image a été mise en mémoire par AOO : une légère modification de la bordure s'est opérée
    • sans relâcher, faites glisser dans le thème.

  2. Par un clic droit sur une image floue dans la gallery > Aperçu. Cet aperçu est-il également flou ?

Il serait intéressant afin de reproduire ce flou à l'affichage que vous joignez un fichier
avec une série de vos images transformées pour que l'on puisse tester.
Image
Comment joindre un fichier au format ODF
A+
AOO 4.1.1 LibO 4.4.5
Vista SP2, Win7 SP1, Win7 SP1 Pro, Win 8.1.1 Pro, Mac Intel OS X 10.10.5, Ubuntu 12.04 LTS 32 bits, OpenSuse 13.2, Debian 7
& LibO 4.0.6 pour Mac PPC 10.5.8
Avatar de l’utilisateur
Ravioli
GourOOu
GourOOu
 
Message(s) : 7610
Inscrit le : 18 Oct 2007 17:28

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar Egon » 25 Fév 2014 21:54

Merci de vous intéresser à ce problème.

A. Je pratique comme vous l'indiquez, à partir d'un document Draw ; mais ce ne sont pas des images, ce sont des éléments graphiques groupés + des points de collage.

B. L'aperçu dans la Gallery n'est pas flou.

Dans le zip joint, un document Draw utilisant le "Thème test" également joint et une image de ce que je vois à l'écran
Pièces jointes
pb gallery flou.zip
(49.08 Kio) Téléchargé 83 fois
Apache OpenOffice 4.1.1 sous Windows 7 Édition Familiale Prémium
Egon
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 07 Oct 2011 20:29

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar Ravioli » 26 Fév 2014 08:06

Bonjour,

je ne reproduis pas le flou (et le crénelage) dans la gallery
qu'elle soit ouverte dans le Bandeau latéral ou en Haut de page
avec vos objets (j'avais employé le terme général "image").
Procédures réalisées :
  • menu : Insertion > Image > A partir d'un fichier
    Votre fichier ThemeTest.jpg
    Puis Glisser-déposer dans Mon thème

  • Glisser-déposer dans Mon thème l'objet groupé
    puis les objets séparément.

  • Création d'un nouveau thème A Thème
    mêmes insertions par glisser-déposer.

  • Clic droit sur A thèmes > Propriétés... > Onglet Fichiers >
    Import du fichier ThemeTest.jpg

  • Modification des réglages Menu : Outils > Options... > OpenOffice < Affichage > Sortie graphique
    Utiliser le lissage cochée ou non.

Il est vrai que l'affichage des vignettes d'objets complexes dans la gallery a une résolution bien faible
mais je n'ai pas le flou de votre copie d'écran.
WIN 8, MacOsX 10.9.2 avec AOO 4.0.1
AOO 4.1.1 LibO 4.4.5
Vista SP2, Win7 SP1, Win7 SP1 Pro, Win 8.1.1 Pro, Mac Intel OS X 10.10.5, Ubuntu 12.04 LTS 32 bits, OpenSuse 13.2, Debian 7
& LibO 4.0.6 pour Mac PPC 10.5.8
Avatar de l’utilisateur
Ravioli
GourOOu
GourOOu
 
Message(s) : 7610
Inscrit le : 18 Oct 2007 17:28

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar Egon » 26 Fév 2014 11:30

Bonjour,

Je viens de faire quelques essais en suivant les procédures que vous décrivez , et même en changeant de compte ("Super" Administrateur), le flou persiste, et la réinstallation de AOO ne change rien.
Sauf astuce très novatrice, je vais donc laisser le sujet en suspend jusqu'à la prochaine version de AOO...

Encore merci pour tout,
Pierre
Apache OpenOffice 4.1.1 sous Windows 7 Édition Familiale Prémium
Egon
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 07 Oct 2011 20:29

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar Dude » 26 Fév 2014 11:48

Salut,

Egon a écrit:je vais donc laisser le sujet en suspend jusqu'à la prochaine version de AOO

C'est inutile car ce forum est uniquement composé d'utilisateurs bénévoles comme toi.
Donc si tu ne fais pas remonter le problème aux développeurs, tu peux toujours attendre.

De ce que je constate, tu es le seul à avoir cet affichage flou.
Peux-tu mettre une image de l'intégralité de ton écran et pas seulement une partie ?
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 20865
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar Egon » 26 Fév 2014 13:18

Bonjour Dude,

Ci-joint une copie de l'intégralité de l'écran. Au passage, on constate que plus le symbole est petit, plus il est flou dans la Gallery (par exemple le texte R2).

Que conclure de cela ?
Pièces jointes
EcranDraw.jpg
Apache OpenOffice 4.1.1 sous Windows 7 Édition Familiale Prémium
Egon
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 07 Oct 2011 20:29

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar Ravioli » 26 Fév 2014 14:02

Bonjour,
Egon a écrit:on constate que plus le symbole est petit, plus il est flou dans la Gallery

j'ai enfin reproduit !
il ne faut glisser-déposer qu'un élément partiel, assez petit de votre fichier .odg
Votre objet.png
Votre objet.png (433 octet(s)) Consulté 3970 fois

mais je ne suis pas sûr qu'un tel objet isolé soit non seulement du vectoriel
et encore qu'il soit affiché en vectoriel dans la gallery !

Voici ce que j'obtiens avec une gallery importée :
http://extensions.services.openoffice.org/project/oxygenoffice-gallery

Schemasponts.png
Cliquez pour agrandir l’image dans un nouvel onglet ou une nouvelle fenêtre
vos objets sont crénelés
ceux de la galerie Electronics parts 1 ne le sont pas.


Cela va être très difficile de créer un signalement sans être sûr de la source du glisser-déposer.
Si c'est en fait un objet bitmap, ce n'est pas un bogue mais un affichage normal des pixels !

A+
AOO 4.1.1 LibO 4.4.5
Vista SP2, Win7 SP1, Win7 SP1 Pro, Win 8.1.1 Pro, Mac Intel OS X 10.10.5, Ubuntu 12.04 LTS 32 bits, OpenSuse 13.2, Debian 7
& LibO 4.0.6 pour Mac PPC 10.5.8
Avatar de l’utilisateur
Ravioli
GourOOu
GourOOu
 
Message(s) : 7610
Inscrit le : 18 Oct 2007 17:28

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar Egon » 26 Fév 2014 17:54

Les objets que j’insère par glisser-déposer dans le thème qui me pose problème sont tous composés d'éléments vectoriels de Draw groupés, auxquels j'ajoute des points de collage. Or, à la lumière de ce qui vient d'être testé et écrit, j'en conclu que le AOO nouveau (récent) attribue à l'affichage des objets dans la Gallery une définition qui ne dépend pas de leur taille ; si bien que les petits objets apparaissent crénelés, qu'ils soient vectoriels ou non.

À votre avis, viens-je d'écrire une bêtise ?

Bonne soirée,
Pierre
Apache OpenOffice 4.1.1 sous Windows 7 Édition Familiale Prémium
Egon
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 07 Oct 2011 20:29

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar Dude » 26 Fév 2014 18:47

Egon a écrit:Les objets que j’insère par glisser-déposer dans le thème qui me pose problème sont tous composés d'éléments vectoriels

Ca c'est toi qui le dit.
Nous ne savons pas quelle extension a été ajoutée à Gallery.

Fais l'essai en installant celle d'OxygeneOffice (voir lien fourni par Ravioli).
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 20865
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Les images dans La Gallery, Mon Thème, sont floues

Messagepar Egon » 28 Fév 2015 19:18

Pour moi, c'est résolu, je n'envisage pas d'explorer plus loin le sujet. Mes objets apparaissent toujours crénelés / flous dans la Gallery, mais ça n’empêche pas de les utiliser.
Merci pour vos réponses,
Pierre
Apache OpenOffice 4.1.1 sous Windows 7 Édition Familiale Prémium
Egon
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 13
Inscrit le : 07 Oct 2011 20:29


Retour vers Dessin

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 6 invité(s)