[Résolu] Perte aléatoire de certaines images

Discussions sur le module de PréAO pour la réalisation de diaporamas sous Impress.

Modérateur: Vilains modOOs

[Résolu] Perte aléatoire de certaines images

Messagepar NADAL » 08 Oct 2019 13:49

Bonjour ? (Règle du forum n°10)
Inserer image--> à partir d'un fichier=> image dans la diapositive . Si plusieurs images dans la même diapositive , disparition à la création d'une nouvelle diapositive seulement le lien est affiché , obligé de remettre l'image.
De même après enregistrement : toutes les images visibles ( document de 25 diapositives) , mais à la réouverture , perte aléatoire de certaines images.
Parfois , sur une diapositive où des images n'apparaissent pas , si je fais " dupliquer la diapositive" , le images réapparaissent dans la nouvelle diapositive dupliquée , mais alors d'autres images disparaissent dans d'autres diapositives au cours de l'opération.
J'ai augmenté la taille de la mémoire allouée , le document Impress est dans le même répertoire que les images …
Que dois-je faire?
Merci
Dernière édition par micmac le 01 Nov 2019 13:20, édité 1 fois.
Raison: Balisage
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39

Re: images dans Impress

Messagepar Jean-Louis Cadeillan » 08 Oct 2019 14:13

Bonjour à toi aussi,
Des conseils pour optimiser les images dans un document :
Insertion d'images, § C
Compression d'images
Insertion de nombreuses images
Oracle Presentation Minimizer
Cordialement,
Jean-Louis
LibO 6.2.8.2 (x64 avec Java 1.8.0_231) et AOO 4.1.6 (avec Java x32 1.8.0_201), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
ManitOOu
ManitOOu
 
Message(s) : 4557
Inscrit le : 03 Jan 2009 00:56

Re: Perte aléatoire de certaines images

Messagepar Saturnin » 08 Oct 2019 19:16

Bonjour,

Même problème ici : https://forum.openoffice.org/fr/forum/viewtopic.php?f=5&t=59941
Regarde si tu as les mêmes réglages.
Libreoffice 6.2.7 sous Mac OSX 10.14.6 Mojave
Avatar de l’utilisateur
Saturnin
Fraîchement OOthentifié
 
Message(s) : 4
Inscrit le : 08 Oct 2019 15:07

Re: Perte aléatoire de certaines images

Messagepar NADAL » 09 Oct 2019 21:33

Merci pour vos réponses.
J ai téléchargé l utilitaire de réduction d image mais je n ai pas réussi à le mettre en oeuvre.
Par contre j ai essayé "réduire la présentation " et bon résultat avec le fichier ".pot".
Encore du travail mais bon espoir.
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39

Re: Perte aléatoire de certaines images

Messagepar micmac » 09 Oct 2019 21:45

Bonjour,

Problème résolu ?

Il est d'usage d'ajouter manuellement au début du titre de votre premier message la balise [Résolu] (avec un R majuscule et sans oublier le e accentué, le tout entre crochets) et de cocher l'icône Image

Image

Cordialement
Les formats ouverts assurent la pérennité de vos documents.
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 6239
Inscrit le : 28 Août 2010 09:45

Re: Perte aléatoire de certaines images

Messagepar NADAL » 10 Oct 2019 16:20

Bonjour

Le problème n'est pas encore résolu , pour moi, car avant d'utiliser " Réduire la présentation" , il m'a fallu finir mon diaporama , en ré-insérant ( parfois plusieurs fois) les images qui disparaissent lors de l'élaboration..
Je vais essayer la sauvegarde en cours de réalisation , mais n'y a t-il pas risque de perte de qualité des images si elles sont re-traitées par "réduire la présentation" à chaque sauvegarde ?
e' n'ai pas pu me remettre à mon travail tout de suite, mais bien sûr je n'oublierai pas de signaler le problème comme résolu quand ce sera le cas.
Merci pour votre aide

Cordialement
Pierre-Luc
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39

Re: Perte aléatoire de certaines images

Messagepar Dude » 11 Oct 2019 15:01

NADAL a écrit: et bon résultat avec le fichier ".pot".

POT kezako ? Ce format appartient à Microsoft pour enregistrer des modèles Powerpoint.

Quel est ton intérêt de l'utiliser ?
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 21056
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Perte aléatoire de certaines images

Messagepar NADAL » 11 Oct 2019 18:36

Bonjour
En fait , quand j'effectue l'opération "Réduire la présentation" , OpenOffice4.1.7 me transforme AUTOMATIQUEMENT mon fichier ".odp"" en fichier ".pot" .
Je suis donc obligé ensuite de demander l'ouverture de ce fichier ".pot" avec OpenOffice Présentation car je n'ai pas souscrit au pack Microsoft Office.
Mais cela fonctionne plutôt bien.
par ailleurs , pour anecdote , je me suis aperçu que si au cours de l'élaboration la fenêtre dédiée à OpenOffice Présentation sur l'écran de l'ordinateur est réduite ( 1/3 de l'écran environ) je n'ai pratiquement plus le problème de perte d'images , car à chaque opération effectuée ( Insertion -> diapo , ou insertion->image , ou autre) , ce ne sont que quelques diapos visible sur l'écran réduit qui s'ouvrent , alors qu'avec un affichage sur tout l'écran de l'ordinateur , une dizaine de diapos s'ouvraient , avec les problèmes de perte.
De même, pour présenter mes diaporamas de 25 diapos , j'ai ouvert OpenOffice sur fenêtre réduite , mais quand j'ai lancé le diaporama , celui ci s'est affiché en plein écran , et cela va mieux ainsi.
Seule chose qu'il me reste à comprendre : pour toutes mes images , j'ai prévu une interaction avec clic de souris qui est :" Aller au document" et ainsi même si l'image sur la diapo est en résolution affaiblie , si je " vais au document" l'image agrandie est en résolution maximum , mais ceci fonctionne à 80%. De temps en temps l'image agrandie n'est plus en premier plan et ne se voit pas . Il faut que je vérifie si je n'ai pas par mégarde mis l'image sur la diapo en premier plan en l'insérant.

Je dois encore créer un nouveau diaporama de 25 diapos. Si mes problèmes de perte ne se produisent plus , avec les solutions proposées , je ne manquerai pas de préciser que le problème semble résolu.
A bientôt
Cordialement
Pierre-Luc
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39

Re: Perte aléatoire de certaines images

Messagepar Dude » 11 Oct 2019 18:54

NADAL a écrit:OpenOffice4.1.7 me transforme AUTOMATIQUEMENT mon fichier ".odp"" en fichier ".pot" .

Non, le format peut/doit être changé :
capture.png
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 21056
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Perte aléatoire de certaines images

Messagepar NADAL » 16 Oct 2019 22:20

Bonjour
En effet , le format peut/doit être changé , je n'avais pas fait attention , car surpris de voir que l'on me proposait par défaut le format .pot .
Le changement de format est ,il est vrai, facile à réaliser !
Merci pour l'information , je vais choisir le format " .odp " dorénavant .
Je commence ma nouvelle présentation . Je vais essayer de créer 5 diapos , puis les "réduire" , créer 5 nouvelles diapos , les "réduire" à leur tour puis les " coller " aux précédentes , et ainsi de suite jusqu'à avoir 25 diapos successives , qui n'auront été "réduites" qu'une seule fois chacune.

A bientôt
Cordialement
Pierre-Luc
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39

Re: Perte aléatoire de certaines images

Messagepar Dude » 17 Oct 2019 14:18

Tu devrais lire le post-it épinglé en haut de la section.
Image
Notamment la partie 6 qui traite de ce processus.
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 21056
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Perte aléatoire de certaines images

Messagepar NADAL » 19 Oct 2019 12:57

Bonjour

Merci du conseil . J'avais déjà lu certaines de ces recommandations , et j'avais augmenté la taille de mémoire allouée.
Dans l'opération " insertion --> image , j'ai également coché la case " lien" . Mais les images apparaissent quand même dans les diapositives lors de l'élaboration. Ce n'est que lorsque le nombre de diapositives devient important que parfois elles disparaissent et que seulement le lien apparaît en haut d'un rectangle blanc.
Je ne pensais pas que les images apparaitraient dans le diaporama.
Je vais relire le post-it attentivement.
A bientôt
Cordialement
Pierre-Luc
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39

Re: Perte aléatoire de certaines images

Messagepar NADAL » 29 Oct 2019 14:07

Bonjour
Pour la "perte aléatoire d'images" le problème semble PRESQUE résolu , moyennant un mode opératoire qui peut être sujet à critiques , et que je vais exposer.
mais auparavant , je voudrais savoir comment utiliser l'extension "PixCompress" que j'ai téléchargée suivant les conseils , et qui apparait bien comme activée lorsque j'ouvre : Outils --> gestionnaire des extensions.
Je croyais que l'outil " réduire la présentation" provenait de cette extension avant de m'apercevoir que cet outil existait déjà sur la version précédente 4.1.2 d'OpenOffice sur l'ordinateur de mon épouse ( j'utilise pour ma part la version 4.1.7).
Je n'ai pas trouvé de commande permettant de réduire la taille des images par cette extension.
Sinon , voici la méthode que j'ai employée :

Réalisation de diaporama de 25 diapos en créant les diapos 5 par 5 , en utilisant une fenêtre de travail réduite (1/2 écran) .
Insertion des images en laissant décochée la case "lien" ( sinon problème de perte à chaque modification) et en appliquant : "interaction--> aller au document" par clic de souris sur l'image.
Mise en œuvre de " réduire la présentation" sur le bloc de 5 diapos" en choisissant de réduire la qualité à 65% .
Faire copier /coller pour mettre à la suite les 5 groupes de 5 diapos.

Avec cette méthode , le fichier s'ouvre correctement ( même s'il est encore un peu "lourd" ) sur fenêtre réduite , et le diaporama s'affiche en plein écran.
Pour profiter pleinement des plus belles images ( qui apparaissent de qualité un peu réduite) , il suffit de cliquer dessus avec la souris et elles apparaissent en plein écran en haute qualité.

Merci pour les conseils passés ( et à venir…) .
Cordialement
Pierre-Luc
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39

Re: Perte aléatoire de certaines images

Messagepar Dude » 29 Oct 2019 16:55

NADAL a écrit: comment utiliser l'extension "PixCompress"

En as-tu lu le descriptif ?
https://forum.openoffice.org/fr/forum/viewtopic.php?f=18&t=37042

NADAL a écrit:Insertion des images en laissant décochée la case "lien" ( sinon problème de perte à chaque modification)

Je ne reproduis pas ce phénomène. Et ta description ne dit pas quel poids font chacune de tes images.
Mais il est quasi certain que tes problèmes viennent de la faiblesse de ta configuration.
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 21056
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Perte aléatoire de certaines images

Messagepar NADAL » 30 Oct 2019 12:14

Bonjour

Voici la configuration.
les images ont un poids de 3,5 MO avant traitement.
J'ai téléchargé PixCompress mais dans "outils" , je n'ai pas l'utilitaire de compression dans la liste.

Cordialement
Pierre-luc
Pièces jointes
Openoffice2.JPG
configuration2
Openoffice1.JPG
Configuration1
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39

Re: Perte aléatoire de certaines images

Messagepar Dude » 30 Oct 2019 15:52

NADAL a écrit:J'ai téléchargé PixCompress mais dans "outils" , je n'ai pas l'utilitaire de compression dans la liste.

De quelle liste parles-tu ? Fais-nous une copie écran.
J'espère que tu as bien lu le lien que je t'ai donné et visualisé dans quel module se plaçait PixCompress.
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 21056
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Re: Perte aléatoire de certaines images

Messagepar NADAL » 31 Oct 2019 11:06

Bonjour
la liste dont je parle est la liste qui s'affiche dans " Outils" : voir image
J'ai bien lu le lien que tu m'as donné et appliqué la méthode indiquée.
Mais si on compare les images jointes à nos messages respectifs , il y a une différence :
Dans les extensions , j'ai bien PixCompress dans un bandeau bleu , mais moi , je n'ai pas en dessous le bandeau indiquant "QR code JS...etc" .
Peut être un problème avec java script? Que dois-je faire?

Cordialement
Pierre-luc
Pièces jointes
CaptureOO.JPG
capture écran
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39

Re: Perte aléatoire de certaines images

Messagepar tintin » 31 Oct 2019 11:15

Bonjour,

La liste dont vous parlez est un menu contextuel.

Dans [Writer] Compression des images, Dude a écrit:dans un document OpenOffice Writer.
[...] PixCompress permet de faire l'opération sans détériorer la qualité des images.
Cette extension ne fonctionne qu'avec le traitement de texte. Du reste, c'est indiqué par la balise [Writer]

Capture d’écran 2019-10-31 à 11.09.07.png
Menu contextuel dans Writer

Capture d’écran 2019-10-31 à 11.09.34.png
Menu contextuel dans Impress
AOO 4.1.7 et LibO 6.2.8 / macOS 10.15.1 Catalina
adoptopenjdk.jre 1.8.0_232 / Firefox / Safari / Thunderbird / Time Machine
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6344
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Perte aléatoire de certaines images

Messagepar NADAL » 31 Oct 2019 14:12

Re-bonjour
J'aurais du immédiatement voir si j'avais une réponse avant de me lancer dans des opérations compliquées!
J'ai désinstallé OpenOffice , puis je l'ai réinstallé ,j'ai réinstallé Pixcompress , puis j'ai téléchargé l'environnement Java de Oracle , que j'ai validé dans les options d'OpenOffice.
Et je me suis aperçu ( tout seul!) que PixCompress ne fonctionnait que sous "texte". Que de temps perdu ! je ne sais pas bien lire et utiliser les balises…….
mais ne pourrait-on pas utiliser PixCompress dans "Présentation"? C'est bien là que l'on met souvent des images!
Enfin , un nouveau problème : En voulant ajouter PixCompress, la première fois , j'avais malencontreusement cliqué une ligne trop bas sur la liste présente à l'écran du micro et validé "wetransfer.zip".
Dans la gestion des extensions , impossible de supprimer cet indésirable , même après avoir supprimé de l'ordinateur ce fichier ( et après avoir vidé la corbeille ) .
Pire : après avoir désinstallé OpenOffice puis l'avoir réinstallé , ce "wetransfer.zip" apparait dans les extensions de la nouvelle version installée alors qu'en principe ce fichier n'existe plus sur l'ordinateur !!!
Les mystères de l'informatique ( ou la mémoire cachée des registres…)
Cordialement
Pierre-Luc
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39

Re: Perte aléatoire de certaines images

Messagepar micmac » 31 Oct 2019 14:38

Bonjour,
NADAL a écrit:Enfin , un nouveau problème
Sans rapport avec le sujet initial.
Nous vous rappelons que la règle n° 7 stipule qu'il ne faut mettre qu'une question par fil.

Poser plusieurs questions complique la compréhension et n'encourage pas les réponses : il vaut donc mieux découper votre problème. Le titre de votre question ne peut pas refléter l'ensemble des problèmes exposés.

Afin que nous puissions avoir une base de connaissance efficace lors d'une recherche sur un seul de vos problèmes, nous vous prions de créer autant de fils que de questions.

Deuxième chose, lorsqu'on suppose un dysfonctionnement, désinstaller et réinstaller OpenOffice n'a pas de sens si on ne purge pas le profil utilisateur.

Merci de votre collaboration.
Les formats ouverts assurent la pérennité de vos documents.
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 6239
Inscrit le : 28 Août 2010 09:45

Re: Perte aléatoire de certaines images

Messagepar tintin » 31 Oct 2019 14:54

Il me semble que Jean-Louis Cadeillan (que je salue) vous a donné immédiatement toutes les pistes pour obtenir ce que vous cherchez.
C'est ici : viewtopic.php?p=331480#p331480 dans le présent sujet.
AOO 4.1.7 et LibO 6.2.8 / macOS 10.15.1 Catalina
adoptopenjdk.jre 1.8.0_232 / Firefox / Safari / Thunderbird / Time Machine
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6344
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: Perte aléatoire de certaines images

Messagepar NADAL » 01 Nov 2019 12:25

Bonjour
Un grand merci à tous pour vos réponses et vos conseils.
Je présente mes excuses pour mon utilisation " en amateur" de ce forum , avec quelques erreurs d'usage.
Une remarque toutefois : Certaines pistes fournies ( compression d'images, insertion de plusieurs images ….) sont en rapport avec l'outil "Texte" alors que ma demande concerne l'outil " Présentation".
Ainsi par exemple l'extension PixCompress n'est pas opérationnelle dans "Présentation".
Il me reste à adapter les solutions fournies à mon problème particulier, grâce à vos conseils.
J'apprécie l'existence et la vie de ce forum.

Cordialement
Pierre-Luc
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39

Re: Perte aléatoire de certaines images

Messagepar tintin » 01 Nov 2019 13:18

Ce que vous lisez ici pour les images liées
est applicable à tous les modules.
AOO 4.1.7 et LibO 6.2.8 / macOS 10.15.1 Catalina
adoptopenjdk.jre 1.8.0_232 / Firefox / Safari / Thunderbird / Time Machine
Pour préserver vos documents, faites régulièrement des sauvegardes.
Avatar de l’utilisateur
tintin
GourOOu
GourOOu
 
Message(s) : 6344
Inscrit le : 18 Juil 2008 16:29
Localisation : F-Oise + F-Savoie

Re: [Résolu] Perte aléatoire de certaines images

Messagepar NADAL » 02 Nov 2019 09:59

Bonjour
Comme je l'ai dit dans un courrier précédent , j'avais essayé d'insérer des images en cochant la case "lien" comme conseillé dans la rubrique "insertion de nombreuses images" à laquelle vous me renvoyez , et que j'avais consultée.
Mais pour ma part, curieusement ,cette méthode aggravait le problème de disparition des images au lieu d'y remédier.
Je pense que dorénavant , pour les prochains diaporamas ,je vais faire une compression d'image avec un outil de traitement photographique , et ensuite , en suivant le conseil de la rubrique "insertion d'images" ,regrouper les images comprimées dans un dossier spécial où je rangerai aussi le fichier ".odp" du diaporama.
J'ai quand même pu réaliser sans souci un nouveau diaporama de 25 diapos sans souci majeur , grâce à vos conseils ( extension de mémoire , utilisation de " réduire la présentation" , enregistrement du fichier ".odp" dans le même dossier que celui des images) , et en utilisant la méthode que j'ai précédemment exposée ( création de diapos par groupes de 5 sur fenêtre réduite,puis mise bout à bout des 5 modules ) c'est pourquoi je considère que le problème est résolu.
Encore merci à tous pour votre réactivité et votre disponibilité.
Pierre-Luc
OpenOffice 4.1.7 sous Windows10
NADAL
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 08 Oct 2019 13:39


Retour vers Présentation

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 3 invité(s)