[Résolu] Débogage Extension Album Photos pour LibO

Discussions sur le module de PréAO pour la réalisation de diaporamas sous Impress.

Modérateur: Vilains modOOs

[Résolu] Débogage Extension Album Photos pour LibO

Messagepar Scrat » 23 Mai 2016 18:31

Bonjour.

Je poste ici une humble demande aux gourous de la programmation des extensions pour tenter de déboguer l'extension de Création d'Album photos pour Impress proposée par Dude. :mrgreen:

Cette extension trouvée sur un site espagnol est très intéressante, mais la version 1.1.0 plante sur LibO si on demande une transition entre les photos. Tout fonctionne si on désactive les transitions en décochant la case correspondante dans le menu. Ce problème a également été rencontré par un utilisateur anglophone qui a laissé un commentaire sur le site espagnol.

A première vue, le code Basic semble identique pour les deux versions 1.1.0 et 1.1.1, cette dernière étant réservée à AOO 4.x.x. L'origine du problème est donc ailleurs et pourrait être l'absence de fichiers de traduction des noms des transitions pour les langues autres que l'espagnol, comme le suggère le commentaire anglophone, encore que la version 1.1.1 fonctionne très bien sur AOO sans ces fichiers français (ou alors je ne les ai pas vus).

J'ai bien essayé de bricoler des fichiers de traduction en français pour la 1.1.0 sans trop savoir quels noms leur donner, mais je n'ai réussi qu'à corrompre mon profil utilisateur au point de devoir réinstaller toutes mes extensions. :aie:

Évidemment, on peut toujours faire une demande sur le site de l'auteur, mais moi pas hablar español, et le commentaire anglophone posté le 20 mars n'a pas encore reçu de réponse. Donc, si des téméraires pouvaient se pencher sur la question, j'irais leur bruler un cierge... ou deux. :mrgreen:

A+
Dernière édition par Scrat le 24 Mai 2016 12:03, édité 1 fois.
LibO 5.2.7.2 Vista 32 bits SP2
Utilisez l'extension de Sauvegarde incrémentale pour ne pas perdre de document !
Avatar de l’utilisateur
Scrat
SuppOOrter
SuppOOrter
 
Message(s) : 1256
Inscrit le : 06 Juin 2014 12:39
Localisation : Île d'Oléron

Re: Débogage Extension Album Photos pour LibO

Messagepar Hubert Lambert » 24 Mai 2016 10:18

Bonjour Scrat,

C'est en effet un problème lié à la localisation : si les fichiers de traduction pour les combos couleurs et transitions sont manquants dans la langue de l'environnement, l'extension ne récupère pas la langue par défaut. Pour être plus précis, si le programme trouve le fichier "lang.lng" (pour la traduction de la boîte de dialogue), il présume que les fichiers "lang.color" et "lang.libreoffice.tran" existent également, et ne gère donc pas leur éventuelle absence. Si "lang.lng" n'existe pas en revanche, le programme récupère correctement l'espagnol comme langue par défaut.

J'ai créé (très rapidement) les deux fichiers en français. Ils mériteraient d'être contrôlés.
Cordialement.

 Ajout : Ajouté également la traduction des éléments de menu et de la barre d'outils. 
Pièces jointes
photoalbumes-1.1.0.oxt
Pour LibreOffice
(51.89 Kio) Téléchargé 62 fois
AOOo 4.1.2 sur Win7 | LibreOffice 5.x sur divers systèmes Linux
--
| « Nos défauts devraient nous donner une qualité : l'indulgence pour les défauts des autres » (Rivarol)
Avatar de l’utilisateur
Hubert Lambert
PassiOOnné
PassiOOnné
 
Message(s) : 598
Inscrit le : 06 Avr 2016 09:26

Re: Débogage Extension Album Photos pour LibO

Messagepar Scrat » 24 Mai 2016 12:01

Bonjour Hubert.

Votre version fonctionne parfaitement avec Libre Office en laissant les transitions activées. Merci beaucoup ! :super:

J'avais moi-même essayé de créer les fichiers français manquant en recopiant les fichiers anglais ou espagnols et en changeant le préfixe en "fr", mais ça ne fonctionnait pas car j'ai dû mélanger les fichiers ou en oublier un. Je vais décortiquer votre version pour essayer de comprendre où était mon erreur.

Je balise ce fil en "Résolu" et je vais le mettre en lien dans mon dernier message sur la section "Extensions".

A+
LibO 5.2.7.2 Vista 32 bits SP2
Utilisez l'extension de Sauvegarde incrémentale pour ne pas perdre de document !
Avatar de l’utilisateur
Scrat
SuppOOrter
SuppOOrter
 
Message(s) : 1256
Inscrit le : 06 Juin 2014 12:39
Localisation : Île d'Oléron

Re: [Résolu] Débogage Extension Album Photos pour LibO

Messagepar Hubert Lambert » 24 Mai 2016 12:15

Avec plaisir :wink: .
Si tu as l'occasion de vérifier les fichiers, on pourrait alors proposer la nouvelle traduction à l'auteur de l'extension et lui signaler la cause du bogue.
AOOo 4.1.2 sur Win7 | LibreOffice 5.x sur divers systèmes Linux
--
| « Nos défauts devraient nous donner une qualité : l'indulgence pour les défauts des autres » (Rivarol)
Avatar de l’utilisateur
Hubert Lambert
PassiOOnné
PassiOOnné
 
Message(s) : 598
Inscrit le : 06 Avr 2016 09:26

Re: [Résolu] Débogage Extension Album Photos pour LibO

Messagepar Scrat » 24 Mai 2016 12:43

D'accord, je vais vérifier les traductions et je signalerai le lien vers ta version à l'auteur... mais en anglais. :lol:

 Ajout : J'ai contrôlé les fichiers "fr.color" et "fr.libreoffice.tran" et ça ma parait correct. Je note que trois transitions apparaissent dans un ordre différent de celui affiché par Libre Office, mais la traduction correspond bien à l'ordre donné dans le fichier "es.libreoffice.tran":

ordre dans le fichier fr.libreoffice.tran
Damier vertical
En forme de plus
Damier horizontal


Ordre de l'affichage dans Libre Office:
Damier horizontal
Damier vertical
En forme de plus


Le choix de la transition en forme de plus dans l'extension correspond bien au choix de la transition en forme de plus dans Libre Office. Seuls le damier horizontal et le damier vertical semble inversés, mais en sélectionnant les translations directement dans Libre Office et en les visualisant, il me semble bien que c'est l'affichage de Libre Office qui est inversé!

Je considère donc que la traduction est OK et j'ai laissé un commentaire (en attente de modération) sur le site de l'auteur avec le lien vers ton message. 


A+
LibO 5.2.7.2 Vista 32 bits SP2
Utilisez l'extension de Sauvegarde incrémentale pour ne pas perdre de document !
Avatar de l’utilisateur
Scrat
SuppOOrter
SuppOOrter
 
Message(s) : 1256
Inscrit le : 06 Juin 2014 12:39
Localisation : Île d'Oléron


Retour vers Présentation

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 11 invité(s)