rectangles de meme hauteur ?

Discussions sur le module de PréAO pour la réalisation de diaporamas sous Impress.

Modérateur: Vilains modOOs

rectangles de meme hauteur ?

Messagepar kerinel » 12 Mai 2006 19:15

Bonjour,
Je fait une figure en alignant des rectangles de differentes couleurs les uns a coté des autres.
Ces rectangles sont tous paramétrés pour avoir une hauteur de 1.5 cm.
certains sont en couleur unis, d'autres en dégradé axial angle 90°. Les contours sont invisibles.
A la conception, les rectangles en dégradés apparaissent un peu plus haut que les rectangles unis.
A fort grossisement (> 100) , ils apparaissent de hauteur identique aux autre lorsque je parametre une hauteur de 1.49 cm...
A 100% il faut parametrer 1.47 cm mais ils apparaissent trop petit a plus fort grossissement.

Pour le diaporama, il faut que je parametre 1.49 pour voir une hateur identique.

Ou cela devient pire,
c'est quand je fais un pdf :

a la conception, ils sont tous parfaitement alignés en haut (Y=24 cm).
Donc la c'est bon . Pareil pour le diaporama

mais pour le pdf, plus aucune regle : la postion change en fonction du zoom, quand a la hauteur il semble que cela soit pareil...
les rectangles en degradés sont positionnés plus haut que les autres,mais pas toujours... et quand je zoome, les positions relatives changent.

Et il semblerait que a l'impression du pdf ce soientt les parametres normaux ( meme hauteur, meme alignement) qui donnent le bon resultat...

Un peu a s'aracher les cheuveux non ?

Aucun probleme pour aligner 2 rectangles unis.


Je ne sais pas si c'est un probleme deja reporté ou pas, donc je voulais le signaler (je suis pas tres doué pour fouiller dans les issues, j'ai pas tout compris le principe ) ...

bonne soiree
kerinel
Avatar de l’utilisateur
kerinel
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 108
Inscrit le : 04 Avr 2006 16:00

Messagepar Dude » 23 Mai 2006 09:09

Rien compris au problème. Envoie un exemple.
Poser une question, c'est bien. Répondre aux autres, c'est encore mieux.
Améliorez AOO et votez pour les issues
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 21843
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Messagepar Ayana » 23 Mai 2006 11:13

Tu dis que certains rectangles sont remplis d'une couleur en dégradé, et que du coup tu ne les vois pas de la même taille que ceux en couleur unie.
Si j'ai bien compris, tu essaies de pallier à ce problème en faisant des zooms, ce qui bien évidemment pose des problèmes quand tu mets au format pdf, pour lequel il n'y a pas de zoom.

Moi je crois que le problème est d'ordre physique :mrgreen:

Au départ les rectangles ne te paraissent pas de la même taille, mais c'est probablement dû à un effet d'optique, étant donné qu'ils sont en dégradé.
D'ailleurs tu le dis toi-même, quand tu regardes les propriétés, ils ont la même taille.
Si tu veux vraiment qu'ils apparaissent de la même taille, je te conseille de bannir le dégradé, ou alors de mettre le même pour TOUS les rectangles.

Enfin c'est ce que j'ai cru comprendre du moins.

:wink:
--= Ayana =--

OOo 2.0.1
XP Pro 2002 SP2
Ayana
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 71
Inscrit le : 27 Avr 2006 09:25

Messagepar kerinel » 23 Mai 2006 11:23

Oui, c'est bien un probleme d'affichage, pas de proprietedes rectangles. Le probleme change en zoomant, et je l'ai aussi rencontrer sur 2 rectangles unis cote a cote. Je pense que le ait d'ajouter du texte par exemple change aussi. Bon en fait a l'impression (sur une imprimante) il n'y a plus de difference. donc la question : Pourquoi je vois des rectangles qui semblent de taille differente alors qu'ils sont identiques ? Probleme du a OO ? A Windows (Pour info j'avais un probleme similaire avec Lower Point mais en pire...) ? a la carte graphique ? les 3 ensembles?

je poste des vues d'ecran des que j'ai 5 minutes pour les faire.

Quand a banir le dégradé c'est dommage car c'est tres pratique pour certaines infos (type changement d'echelle). Et pis j'aime bien les degradés :P
merci
kerinel

OO 2.0.2 Windows XP-Pro SP2
Avatar de l’utilisateur
kerinel
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 108
Inscrit le : 04 Avr 2006 16:00

Messagepar Dude » 23 Mai 2006 11:41

kerinel a écrit:je poste des vues d'ecran des que j'ai 5 minutes pour les faire.

Et merci de ne pas dépasser 800 pixels en largeur.
Poser une question, c'est bien. Répondre aux autres, c'est encore mieux.
Améliorez AOO et votez pour les issues
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 21843
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Messagepar Ayana » 23 Mai 2006 12:50

Si tu as le même problème avec des rectangles unis côte à côte, ont-ils la même couleur dedans ou pas ???

S'ils ont la même couleur, dans ce cas ce n'est pas dû au dégradé, mais peut-être à une des propriétés des rectangles (3D, plat ....).

Enfin je vois que ça à chaud, peut-être qu'après réflexion et quelques images ... :P
--= Ayana =--

OOo 2.0.1
XP Pro 2002 SP2
Ayana
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 71
Inscrit le : 27 Avr 2006 09:25


Retour vers Présentation

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité