[AOO]4.1.1 Installer les dictionnaires sur Mac OsX

Tutoriels d'installation sur MacIntosh

Modérateur: Vilains modOOs

[AOO]4.1.1 Installer les dictionnaires sur Mac OsX

Messagepar Papayes » 12 Avr 2014 17:19

Installation411réduit_surMavericks.png
Installation _411_sur_Yosemite_réduit.png

 Ajout : Édition du 8 août 2015 

Bonjour,
D'après : "Extensions & Dictionnaires" des Tutoriel d'installation de AOO 411 sur MacOsX

Dans ce message :
  1. Installation de l'extension : Sauvegarde incrémentée automatique comme exemple important ;
  2. Les Dictionnaires français installés par défaut ;
  3. Installer des Dictionnaires d'autres langues ;
Dans les 2 messages suivants
  1. Le dictionnaire grammatical Grammalecte qui met à jour les dictionnaires français ;
  2. L'autre dictionnaire grammatical : Language Tool

L'accès aux Extensions dont font partie les Dictionnaires se fait par
Menu : Outils > Gestionnaire des extensions...>
    Gde menu réduit Accueil0.png
Une seule extension est installée par défaut : le dictionnaire français 5.1,
    SeuleextensionDico51.png
l'extension Presentation Minimizer est désormais intégrée dans le programme.

Les extensions proposées dans ce tutoriel ont toutes été vérifiées.
:arrow: Attention : Si vous désirez installer d'autres extensions que celles signalées sur le forum, il ne faut installer que des extensions mises à jour pour AOO si elles font appel à des boites d'outils.
Procédez à leur installation une à une et la tester immédiatement. Si elle ne fonctionne pas supprimez-la.

A. Installation de l'extension : Sauvegarde avec incrémentation automatique

  1. Téléchargez sur le forum l'extension mise à jour pour AOO 4 d'Alain de la Chaume : Sauvegarde incrémentée automatique

    Pour AOO 4, lien direct de téléchargement : acIncrSav-A-2.1.oxt,

    indispensable pour tout travail important dans AOO.
  2. Installez par le Gestionnaire des extensions
    Dans la fenêtre Gestionnaire des extensions
    1. Cliquez sur le Bouton Ajouter... (1) >
      S'ouvre la boite de dialogue Ajouter des extensions >
      AjouterAlain21AOO.png
    2. Sélectionner le fichier téléchargé > acIncrSav-A-2.1.oxt
      Valider par le bouton Ouvrir
    3. Dans la boite de dialogue superposée OpenOffice 4.1.1
      MacPourTousAlainsur51.png
      choisir l'installation que vous préférez
      par exemple Bouton Pour tous les utilisateurs (2)
    4. L'extension se pré-installe en une seconde.
      AlainInstallé_sur51.png
    Ne fermez pas le Gestionnaire des extensions.


B. Les dictionnaires français installés par défaut

    Dico51installé_parDéfaut Ajouter.png
L'extension installée Dictionnaires français 5.1 comprend :
  • un vérificateur orthographique (morphologique) qui ne signale donc que les erreurs d'écritures des mots sans tenir copte du moindre accord,
  • un dictionnaire des coupures des mots (césures)
  • un dictionnaire des synonymes.
Information sur le Dico 5.1 a écrit:Par le Menu de AOO > Outils > Langue > Dictionnaires orthographiques français >
    MenuDico11.png
vous pouvez opter pour les différentes versions de correction orthographique
dans la boite de dialogue Orthographe française
    Dico411_Orthographe_Française.png
Tout changement d'option nécessite la fermeture de AOO pour être pris en compte.

Ce Dictionnaire français 5.1 n'est pas la dernière édition mais peut être conservé sauf
si vous désirez installer Grammalecte 4.4.1, le dernier dictionnaire grammatical qui le mettra à jour en même temps en 5.1.3.
Remarque sur les mises à jour des extensions proposées par AOO a écrit:Si une icône apparaît dans le menu Pomme, ne pas en tenir compte et continuer à installer vos extensions...
Mise_à_jour_disponible.png



C. Dictionnaires d'autres langues
Facultatif, vous pourrez les installer ultérieurement si nécessaire
et passer de suite à l'installation du dictionnaire grammatical
Allez au message suivant : Installation du Dictionnaire grammatical Grammalecte.

Si vous désirez d'autres dictionnaires pour d'autres langues, ceux-ci s'installent par le Gestionnaire des extensions.

  1. Téléchargez-les à partir du site officiel : http://extensions.openoffice.org/

    Pour l'Anglais : http://extensions.openoffice.org/en/pro ... openoffice
    exemple pris pour les copies d'écran

    Lien direct de la version du 1er août 2015

    pour télécharger le fichier dict-en.oxt (5,8 Mo)
    OuvertureDicoUSmai.png

    La dernière version du Dictionnaire anglais pour AOO 4 comprend :
    - en_AU (Australien)
    - en_CA (Canadien) (mis à jour du 18 mai 2015)
    - en_GB (Britannique) (mis à jour du 1er août 2015)
    - en_US (Américain) (mis à jour du 18 mai 2015)
    - en_ZA (Sud-Africain)

    Pour l'Espagnol Spanish (Spain), Español (España) pour la version Espagne
    http://extensions.openoffice.org/fr/project/Spanish[/quote]

    Pour l'Italien, Italian dictionaries (spell checker, thesaurus and hyphenation)
    http://extensions.openoffice.org/fr/project/dict-it ,

    ➫ etc.

  2. Installation par le Gestionnaire des extensions
    Menu : Outils > Gestionnaire des extensions...>
    1. Bouton Ajouter...
    2. Dans la boite de dialogue Ajouter des extensions,
      MacAjouterDicoUS.png
      Sélectionnez le fichier téléchargé dico-en.oxt ;
    3. Cliquez sur le bouton Ouvrir
    4. Dans la boite de dialogue superposée OpenOffice 4.1.1
      MacSeulementpourDicoUS.png
      choisir l'installation que vous préférez par exemple Bouton Pour tous les utilisateurs (2) ou bien Seulement pour moi.
    5. Le dictionnaire se pré-installe
      GDEUSaout.png
      et ne sera pris en compte qu'après redémarrage de l'application.


Remarque : Compatibilité avec le dictionnaire installé sous MacOsX
    Pour vérifier, j'ai décoché suivant les conseils d'Olivier, pour désactiver le dictionnaire MacOX,
    Menu Pomme > OpenOffice > Préférences... > Paramètres linguistiques > Linguistique >
    Linguistique1.png
    Décochez la case Mac OS X Spell Checker
    Par curiosité, vous pouvez éditer cette rubrique : bouton Éditer >
    et validez dans la fenêtre principale votre choix.
    Pas de confusion à priori.
    Notez au passage l'emplacement des propriétés et le nom des Dictionnaires personnels.


Suite ➫
Avatar de l’utilisateur
Papayes
Membre fOOndateur
Membre fOOndateur
 
Message(s) : 4154
Inscrit le : 07 Déc 2005 14:55
Localisation : Vic-Fezensac dans le Gers

AOO ➫ VII. Dictionnaire grammatical Grammalecte

Messagepar Papayes » 12 Avr 2014 17:19

VII. Dictionnaire grammatical : Grammalecte

 Ajout : Mise à jour au 8 août 2015 


Le Dictionnaire français 5.1 installé par défaut
    Dico51installé_parDéfaut Ajouter.png
n'est ni la dernière édition ni un dictionnaire grammatical.
Si vous désirez installer Grammalecte 0.4.10.2, le dictionnaire grammatical le mettra à jour en même temps en 5.4

Il existe deux Dictionnaires grammaticaux au choix
    A. Grammalecte ou bien
    B. Language Tool
:!: Il est nécessaire de n'installer que l'une des deux extensions LanguageTool ou Grammalecte, car il ne peut y avoir deux correcteurs grammaticaux se disputant le contrôle d’une langue.

➫ Si vous désirez mettre à jour seulement le dictionnaire et/ou installer Language Tools au lieu de Grammalecte, passez directement au message suivant III. Autre dictionnaire grammatical Language Tool

Installation de Grammalecte 0.4.10.2 Python27 comprenant la dernière version des Dictionnaires français
Désormais, en installant Grammalecte, la dernière version du dictionnaire orthographique s'installe automatiquement.

  1. Supprimez le dictionnaire Dictionnaire 5.1
    Il est préférable de supprimer les dictionnaires anciens plutôt que de les écraser,
      même si les dernières versions de Grammalecte s'installent par-dessus, cela évite de risquer de traîner de vieilles versions obsolètes.
    Il suffit de le sélectionner dans le Gestionnaire des extensions, de cliquer sur son Bouton Supprimer.
    Supprimer2015Dico51.png
    et de passez outre l'avertissement qui se superpose
    MessageAlerteEcrasementpar471.png
    en cliquant sur le bouton OK

    Votre Gestionnaire ne comprend plus que l'extension d’incrémentation automatique,
      GDE2015AlainetEn11.png
      Gde_avecAlain21Seul.png
      sauf si vous avez installé des dictionnaires d'autres langues.

  2. Téléchargez l'extension adaptée à AOO 4
    Site Grammalecte a écrit: :alerte: Si le lien direct situé en dehors de ce cadre est mort, passez par le site de Grammalecte pour télécharger la dernière version mise à jour.
    http://www.dicollecte.org/grammalecte/telecharger.php

    Le lien de l'extension Grammalecte pour AOO 4 se situe à droite de la page de Grammalecte
    juste en dessous du cadre bleu de droite
    AUTRES VERSIONS v0.4.10.2 (rétrocompatible)
    spéciale pour les systèmes employant encore une ancienne version Python qui est le cas de AOO 4.
    Gramma04102AOO.png
    pour télécharger Grammalecte-v0.4.10.2-py27.oxt (3,5 Mo) ( py27 pour Python version 2.7)


    Lien direct au 8 août 2015 :

    http://www.dicollecte.org/grammalecte/oxt/Grammalecte-v0.4.10.2-py27.oxt

      OuverturegrammaAOO102.png
  3. Installation par le Gestionnaire des extensions.
    Menu : Outils > Gestionnaire des extensions...>

    Dans la fenêtre Gestionnaire des extensions,
    1. clic sur le Bouton Ajouter... > (1)
      S'ouvre la boite de dialogue Ajouter des extensions
      AjouterGramma10AOO.png
      qui permet de parcourir l'arborescence des dossiers
    2. Choisir le fichier téléchargé Grammalecte-v0.4.10.2-py27.oxt
      Validez par le bouton Ouvrir.

    3. Dans la boite de dialogue superposée OpenOffice 4.1.1
      SeulementGramma48.png
      choisir l'installation que vous préférez par exemple Bouton Pour tous les utilisateurs (2)
      Mise à jour sans désinstaller la précédente version a écrit:Un message d'alerte apparaît si vous n'avez pas supprimé la précédente version du dictionnaire ou de Grammalecte
      AlertesurancienneversionAOO.png
      Validez le message par le bouton OK



    4. L'extension se pré-installe comme en témoigne la petite barre de progression très rapide au bas de la boite de dialogue.
      GDEGramma102.png
    5. mais il faudra quitter AOO pour que l'extension soit prise en compte.


Quittez AOO par Ctrl + Q

Le Dictionnaire 5.3.3 est bien installé : dans le Gestionnaire, s'affiche Grammalecte (pack) [rétrocompatible] 5.3.3.
Vous pourrez le constater au redémarrage de AOO.
Ce dictionnaire est particulièrement remarquable pour les Enseignants de Français car il est possible de choisir simplement d'utiliser l'un des 4 dictionnaires proposés, n'étant obligé que de redémarrer AOO après un autre choix.

A propos de Grammalecte 0.4

  • Le dictionnaire grammatical fonctionne alors en bleu dans le cadre du dictionnaire orthographique.

  • La version 0.4 apporte un flot d'informations, un clic droit sur le mot souligné est particulièrement riche.
    Nouveauté : désormais un mot, pouvant être employé comme verbe ou comme adjectif, est repéré
    verbeou adjectif.png
    et l'accord éventuel est proposé. :super:

  • Grammalecte s'intègre désormais dans le Menu principal de AOO Writer,
    Menu Grammalecte48.png
    et propose un sous-menu avec
    1. Formateur de texte...
      qui ouvre la boite de dialogue Formateur de texte
      Gramma48Formateur.png
      qui permet en une seule passe de corriger toutes les erreurs signalées par le Bouton Appliquer
      Attention à la case Retour à la ligne = fin de paragraphe :
      si elle est cochée, elle permet de modifier tous les retours à la ligne ↵ (maj + Entrée) d'un texte collé du net en des fins de paragraphe ¶ (Entrée).
      La fermeture après traitement se fait désormais avec le bouton Fermer.

    2. Conjugueur... : Nouveauté en version bêta :
      Conjugueur47.png
      "De nombreux verbes n'ont pas été étiquetés et contrôlés.
      Pour ceux-ci, les options "usage pronominal" et "temps composés" sont désactivés".

    3. Dictionnaire orthographique... permet de modifier de dictionnaire utilisé
      OrthographeFrançaise.png
      après un simple redémarrage de AOO,
        commande identique à celle du menu : Outils > Langue > Dictionnaires orthographiques français...
        MenuOutilsLangueDictionnaires.png

    4. Modifier le champ "Auteur"...
      ouvre une nouvelle boite de dialogue Grammalecte . Éditer le champ "Auteur"
      qui permet de modifier le Prénom et NOM de l'auteur du document en cours
      ModifierChmpsAuteur.png
      Remplir la zone de saisie et validez par Modifier.

    5. Options... ouvre une nouvelle boite de dialogue Grammalecte . Options du contrôle grammatical
      OptionsGramma49Vide.png
      étrangement videqu'il faut remplir en cochant les bonnes cases.
      Une InfoBulle signale les caractéristiques des options en passant la souris sur leur nom.
      OptionsGrammaRemplies.png


    Suite : Autre dictionnaire grammatical ➫
    Avatar de l’utilisateur
    Papayes
    Membre fOOndateur
    Membre fOOndateur
     
    Message(s) : 4154
    Inscrit le : 07 Déc 2005 14:55
    Localisation : Vic-Fezensac dans le Gers

    AOO➫ VIII. Autre dictionnaire grammatical Language Tool

    Messagepar Papayes » 12 Avr 2014 17:19

    Installation _411_sur_Yosemite_réduit.png

     Ajout : Édition du 28 février 2015 

    Attention : en raison d'un bogue sur Yosemite et Java, allez au message du tutoriel d’installation :
    Installation de Language Tool sur Yosemite 10.10.2

    Installation411réduit_surMavericks.png


    Installation de Language Tool sur les autres versions de macOsX

    Ne vous concerne pas si vous avez installé Grammalecte 0.4.8 .
    :!: Il est nécessaire de n'installer que l'une des deux extensions LanguageTool ou Grammalecte,
    car il ne peut y avoir deux correcteurs grammaticaux se disputant le contrôle d’une langue.

    Le dictionnaire Language Tool fonctionne avec le dictionnaire 5.1 par défaut.
      Dico51installé_parDéfaut Ajouter.png
      Il suffit d'installer Language Tool, une fois téléchargée, en cliquant sur le bouton Ajouter (1)

    Installation optionnelle du Dictionnaire 5.3 a écrit:Je vous recommande cependant d'installer la dernière version du Dictionnaire français.

    1. Supprimez le dictionnaire Dictionnaire 5.1
      simplement en le sélectionnant dans le Gestionnaire des Extensions
      SupprimerDico51.png
      et en cliquant sur son bouton Supprimer
      C'est aussi rapide que d'attendre que l'installateur du nouveau dictionnaire supprime les anciens fichiers, surtout qu'il faudra ensuite supprimer quand même le 5.1 pour qu'apparaisse le 5.3 !

    2. Télécharger l'extension à gauche de la page de Grammalecte :
      http://www.dicollecte.org/grammalecte/telecharger.php

        TéléchargementDico53.png
      Cliquez sur le cadre bleu DICTIONNAIRES Version 5.3 • 28 février 2015
      pour télécharger lo-oo-ressources-linguistiques-fr-v5-3.oxt (3,2 Mo)
        OuvertureDico53.png

    3. Installer par le Gestionnaire des extensions
      Menu : Outils > Gestionnaire des extensions...>
      Dans la fenêtre Gestionnaire des extensions
      1. Cliquez sur le Bouton Ajouter... (1) >
        S'ouvre la boite de dialogue Ajouter des extensions
        AjouterDico53.png
        qui permet de parcourir l'arborescence des dossiers :

      2. Sélectionner le fichier téléchargé > lo-oo-ressources linguistiques-fr-v5-3.oxt
        Valider par le bouton Ouvrir.
          Choisir dans la mini boite de dialogue
          PourTousdeDico53.png
          qui se superpose entre "Seulement pour moi" ou "Pour tous les utilisateurs"

            Si vous n'avez pas désinstallé le dictionnnaire par défaut, vous auriez droit au message habituel
              Alerte deDico53.png
            à valider par la touche OK
      3. L'extension se pré-installe comme en témoigne la petite barre de progression en bas de la boite de dialogue Gestionnaire des extensions.
        Dico53Installé.png
    4. ➫ mais il faudra quitter AOO pour que cette modification soit prise en compte.


    Installation de Language Tool
    1. Téléchargement de l'extension

      par LanguageTool par dnaber : Get it

      :alerte: La dernière version de Language Tool (LT) version 2.6 nécessite Java 7 ou Java 8 pour fonctionner.
      Vérifiez votre version de Java activée avant de télécharger LT
        ActiverJava820MacAOO411.png

        afin d'éviter ce message d'erreur bloquant :
        message erreurLT24 et java6.png
      A. Java 1.7 ou 1.8 activé dans AOO 4.1 pour installer Language Tool 26

      Lien direct de téléchargement de LT 2.6 pour AOO 4
      OuvertureLT26.png


      B. Si vous êtes resté avec la version de Java 6 proposée par Apple, il faut utiliser la version LT 2.2.0

    2. Installation de LT
      Toujours avec le Gestionnaire des extensions
      Menu : Outils > Gestionnaire des extensions...>
      1. Bouton Ajouter... (1)
      2. Sélectionnez le fichier téléchargé dans la boite de dialogue Ajouter des extensions
        AjouterLT26sur52.png
        Validez par le bouton Ouvrir
      3. Dans la boite de dialogue qui se superpose OpenOffice 4.1.1,
        52ChoixpourLT26.png
        choisir l'installation que vous préférez par exemple Bouton Seulement pour moi.
        La petite barre de progression en bas de la boite fonctionne lentement
        LT26Installésur52.png
        et l'extension est pré-installée.
    3. Le dictionnaire grammatical fonctionnera alors en bleu dans le cadre du dictionnaire orthographique.

    Quittez AOO par cmd⌘ + Q et redémarrer AOO pour que l'extension soit prise en compte.


    Très cordialement,
    Avatar de l’utilisateur
    Papayes
    Membre fOOndateur
    Membre fOOndateur
     
    Message(s) : 4154
    Inscrit le : 07 Déc 2005 14:55
    Localisation : Vic-Fezensac dans le Gers


    Retour vers macOS X Intel ou PPC

    Qui est en ligne ?

    Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité