Page 1 sur 1

[Résolu] Remplir des cellules suivant un critère

MessagePublié: 19 Mars 2006 15:12
par LeSurcitaire
Bonjour,

Tout d'abord je tiens à vous dire que je suis débutant.
Mon souhait serai de remplir un tableau suivant un critère.
J'ai une feuille appelée Aptitudes ou se trouve des noms en colonne C et prénoms en colonne D
En colonne A j'ai des numéros, j'aimerai dans une feuille nommée liste
que la colonne B se remplisse des noms qui correspondent suivant si dans ma feuille Aptitudes en colonne a j'ai mis

J'espère mettre fait comprendre

MessagePublié: 19 Mars 2006 17:03
par Papayes
Bonjour,
Si tu as bien nommé tes feuilles ,
clique sur la feuille 2 "liste" en B2,tape =
va sur l'onglet de la feuille 1 "Aptitudes" , clic sur la cellule C2 : tu obtiens le nom de la cellule B2 , c'est à dire Aptitudes.C2
Touche Entrée.
Tu obtiens en B2 =Aptitudes.C2 comme formule et la valeur correspondante.
Mais...
Pour éviter les 0 des cellules vides, il faut mettre une condition "Non vide", la plus simple est la fonction SI

Image


(dans la copie d'écran, la colonne D montre le contenu des formules en B)

Si la cellule d'Aptitude.C2"n'est pas vide;
alors le contenu est celle de la cellule Aptitude.C2;
sinon le contenu est vide "".
qui se traduit par :
=SI(Aptitudes.C2<>"";Aptitudes.C2;"")
Entrée
Tu n'as plus qu'à copier la formule par copier-glisser avec la poignée de recopie (angle droit en bas de la cellule) pour le reste de ta colonne..

A+
papayes

MessagePublié: 19 Mars 2006 17:36
par LeSurcitaire
C'est presque cela que je veux mais j'aimerai que mes noms se suivent c'est dire que si le nom correspondant au numéro est en ligne 15 sur ma feuille Aptitudes mais que la ligne 2 de ma feuille liste et vide alors qu'il se mette là
Voici une adresse pour mon fichier si vous voulez voir
http://cjoint.com/?dtrJ6cVIIk

MessagePublié: 19 Mars 2006 17:57
par Papayes
Re,
voici la suite , feuille n°1
Image

le problème des lignes non remplies est résolu par ceci
Attention à la syntaxe de la fonction OU
Nota, j'ai remplacé <> par ="" pour faciliter la lecture, donc la condition SI est modifiée en
alors "non renseigné"; ( c'est plus parlant pour l'exercice !)
sinon j'écris le nom de la cellule Aptitudes.C2
ce qui donne:
Image

ce n'est plus tellement pour débutant ! :wink:
A+
papayes

MessagePublié: 19 Mars 2006 19:46
par Papayes
Re,
vu ton post... trop tard !
oui, il aurait été plus simple d'envoyer de suite ton problème en ci-joint.
Je te signale que le forum a son propre système de Ci-joint à cette adresse...

http://oooforum.free.fr/cijoint/?#

A+
papayes

MessagePublié: 19 Mars 2006 20:13
par Papayes
Bonsoir,
Votre tableur de départ :
Vous affectez un numéro d'équipe 1 ou 2 ou 3 ou 4 à un nom de la colonne C de la feuille Aptitudes

Image

vous voulez que dans la feuille Liste, à chaque colonne affectée du numéro d'équipe, corresponde le nom du coéquipier,
( le nom pouvant s'écrire sur (presque) la même ligne que dans la feuille Aptitudes [en fait décalage de 1 ligne à cause de la présentation de cette feuille]

Solution:

Image

En B2:
SI le numéro de la ligne 3 de la feuille Aptitudes est égal à 1 (B1);
alors j'écris le nom contenu en Aptitudes.C3;
sinon je mets un vide ""
ce qui se traduit par la formule

=SI(Aptitudes.$A3=B$1;Aptitudes.$C3;"")

les $ représentent le signe des références absolues utilisées afin de pouvoir recopier la formule

Tapez donc cette formule en B2 , Touche Entrée
Puis copier-glisser avec la poignée vers la droite, sur la même ligne pour couvrir les 4 colonnes, Touche Entrée
puis tirer vers le bas pour couvrir l'ensembles des lignes. Entrée.

Voila
Bons matches !
A+
papayes

MessagePublié: 19 Mars 2006 21:14
par MichelXld
bonsoir LeSurcitaire , bonsoir Papayes


j'espere que cet exemple pourra t'aider


http://oooforum.free.fr/cijoint/fichier/060319091301.ods



bonne soiree
michel

MessagePublié: 19 Mars 2006 22:17
par Papayes
Bonsoir Michel
Ta formule est superbe ! Merci , je ne sais pas si cela ne va pas donner mal à la tête à Surcitaire ! :D
LeSurcitaire a écrit:Tout d'abord je tiens à vous dire que je suis débutant.


A bientôt ,
papayes

MessagePublié: 20 Mars 2006 07:10
par LeSurcitaire
Merci beaucoup c'est exactement ce que je voulais et pour le mal de tête j'ai de l'aspirine ne réserve. En fin de compte c'est comme excel ooo2.0.2