Page 1 sur 1

[Résolu] "Borner" entre une valeur mini et maxi

MessagePublié: 23 Juin 2021 13:33
par Jmichel
Bonjour,
Apres un calcul, je voudrai afficher la valeur calculée si elle est comprise entre 20 et 25, si la valeur calculée est inferieure a 20, j'affiche 20, si elle est superieure a 25, j'affiche 25.
le tout dans une seule cellule avec une formule imbriquée.
Merci,

Re: "Borner" entre une valeur mini et maxi

MessagePublié: 23 Juin 2021 14:43
par Jean-Louis Cadeillan
Bonjour et bienvenue sur le forum,
Une solution serait :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(A1<=25;A1>=20);A1;SI(A1<20;20;25))

Cordialement,
Jean-Louis

Re: "Borner" entre une valeur mini et maxi

MessagePublié: 23 Juin 2021 16:28
par Jmichel
Merci beaucoup :D

Re: [Résolu] "Borner" entre une valeur mini et maxi

MessagePublié: 24 Juin 2021 07:18
par gerard24
Bonjour,

Un peu après la bataille, mais plus court :

Code : Tout sélectionner   AgrandirRéduire
=MEDIANE(A1;20;25)

A+

Re: [Résolu] "Borner" entre une valeur mini et maxi

MessagePublié: 24 Juin 2021 15:10
par Jean-Louis Cadeillan
Bonjour,
Dans le même esprit :
Code : Tout sélectionner   AgrandirRéduire
=MIN(25;MAX(20;A1))
:wink:
Cordialement,
Jean-Louis