[Résolu] Fonction SOMME en fonction d'une PLAGE qui varie

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Fonction SOMME en fonction d'une PLAGE qui varie

Messagepar cyril260 » 03 Nov 2020 01:17

Bonjour à tous,

Après de longue recherches dont je n'ai pas trouvé de solution, je fais appel à votre sagesse afin de savoir si il est possible
d'appliquer une formule qui calculerais la Somme de façon automatique.

Je m explique j'ai un tableau dans lequel la somme du mois de Janvier correspond à 499,73€ et plutôt que d'appliquer manuellement la SOMME de la plage D3:F12 j aimerais qu'à l'aide d'une formule, CALC puisse définir la plage D3:F12 afin que cela s'automatise.
Le petit hic est que les lignes varie en fonction de chaque mois.
J'ai donc commencé par ce début de piste:

Code : Tout sélectionner   AgrandirRéduire
=SI(NB.SI(C13:C13;"Janvier-2020")=1;SOMME(D3:F12);"")


Mais ce que j'aimerais c est une formule qui me définirais la plage
Code : Tout sélectionner   AgrandirRéduire
(D3:F12)


Avez vous quelque pistes à me conseiller?

Merci sincèrement pour votre aide,

Cordialement,

Cyril
Pièces jointes
test.ods
(19.03 Kio) Téléchargé 13 fois
Dernière édition par cyril260 le 03 Nov 2020 17:10, édité 1 fois.
OpenOffice 4.1.5 AOO415m1(Build:9789) - Rev. 1817496
2017-12-11 17:25
sous Windows XP Service Pack 3

Obligation de version.
cyril260
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 51
Inscrit le : 29 Nov 2015 17:17

Re: Fonction SOMME en fonction d'une PLAGE qui varie

Messagepar cyril260 » 03 Nov 2020 14:11


La modération vous a écrit: Merci de ne pas poster plusieurs messages à la suite. Vous disposez d'un bouton ÉDITER en haut à droite de chaque message et d'un autre bouton ajout si vous désirez ajouter un complément lorsqu'il n'y a pas de réponse.


Re Bonjour à tous,

Suite à mon premier message, j'ai modifié le premier fichier en espérant que la solution y est proche et en combinant des formules de type NB.SI et CONCATENER , la plage souhaitée a été finalement trouvée sous forme de résultat d'une formule CONCATENER.
Pour être plus précis la cellule D13 m'affiche le résultat: "F3:H12".
La question que je me pose est la suivante: Est il possible d'appliquer cette valeur comme plage dans une formule?

Comme par exemple appliquer la fonction =SOMME(D13) qui reviendrait plutôt à =SOMME(F3:H12) ?

Merci pour votre aide :)

Cyril
Pièces jointes
test2.ods
(17 Kio) Téléchargé 11 fois
OpenOffice 4.1.5 AOO415m1(Build:9789) - Rev. 1817496
2017-12-11 17:25
sous Windows XP Service Pack 3

Obligation de version.
cyril260
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 51
Inscrit le : 29 Nov 2015 17:17

Re: Fonction SOMME en fonction d'une PLAGE qui varie

Messagepar Jeff » 03 Nov 2020 15:39

Bonjour,

Pas de version AOO sous la main pour tester, mais peut-être une source d'inspiration ici :

viewtopic.php?f=29&t=42550

A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.8 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 20.04 x64 (Focal Fossa), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8388
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: Fonction SOMME en fonction d'une PLAGE qui varie

Messagepar yclik » 03 Nov 2020 16:41

Bonjour
une proposition
Code : Tout sélectionner   AgrandirRéduire
=SOMME(INDIRECT(D13))

ou en D13
Code : Tout sélectionner   AgrandirRéduire
=SOMME(INDIRECT(SI(NB.SI(E13:E13;"Janvier-2020")=1;CONCATENER("F";C13;":";"H";B13);SI(NB.SI(E13:E13;"Février-2020")=1;CONCATENER("F";C13;":";"H";B13);""))))
OpenOffice 4.1.7 sous Windows 10
Avatar de l’utilisateur
yclik
SuppOOrter
SuppOOrter
 
Message(s) : 1253
Inscrit le : 15 Déc 2010 09:33

Re: [Résolu] Fonction SOMME en fonction d'une PLAGE qui vari

Messagepar cyril260 » 03 Nov 2020 17:16

Bonjour Jeff et Yclik,

Merci pour vos précieuse réponses, effectivement la fonction INDIRECT fonctionne à merveille !

Les solutions cités:
Code : Tout sélectionner   AgrandirRéduire
=SOMME(INDIRECT(D13))


Et
Code : Tout sélectionner   AgrandirRéduire
=SOMME(INDIRECT(SI(NB.SI(E13:E13;"Janvier-2020")=1;CONCATENER("F";C13;":";"H";B13);SI(NB.SI(E13:E13;"Février-2020")=1;CONCATENER("F";C13;":";"H";B13);""))))


sont exactement ce que j'avais besoin.

Merci sincèrement pour votre aide, cela faisait longtemps que je cherchais cette solution :)))

A+

Cyril
OpenOffice 4.1.5 AOO415m1(Build:9789) - Rev. 1817496
2017-12-11 17:25
sous Windows XP Service Pack 3

Obligation de version.
cyril260
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 51
Inscrit le : 29 Nov 2015 17:17


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 20 invité(s)