[Résolu] RECHERCHEV sur plusieurs feuilles

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] RECHERCHEV sur plusieurs feuilles

Messagepar Jack21 » 13 Oct 2020 19:31

Salut à tous,

Après des heures à chercher une solution qui, je pensais, était assez simple, je me retrouve dans l'impasse.

J'ai une feuille PRINCIPAL dans laquelle j'aimerais pouvoir taper une date et que celle-ci soit trouvée parmi les autres feuilles (nommées 2020, 2019, 2018...), chaque date ayant une description mise en deuxième colonne
Exemple: si je tape 21/8/18 dans la feuille PRINCIPAL, la fonction trouve dans la feuille "2018" la description mise à côté de "21/8/18" et me l'affiche dans la feuille PRINCIPAL

Pour être plus clair j'ai mis en pièce jointe un exemple, je parviens ici à renvoyer à une feuille (exemple 2020) mais pas aux autres

Merci d'avance pour vos lumières!
Pièces jointes
exemple.ods
(33.59 Kio) Téléchargé 16 fois
Dernière édition par micmac le 16 Oct 2020 17:19, édité 1 fois.
Raison: Balisage
OpenOffice 4.1.7 sous Windows 10
Jack21
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 13 Oct 2020 18:37

Re: RECHERCHEV sur plusieurs feuilles

Messagepar Noonours » 13 Oct 2020 20:43

Bonjour,

Comme tes pages sont nommées d'après l'année d'archivage, je te propose cette formule qui extrait l'année de ta recherche pour déterminer la feuille où doit s'appliquer la fonction RECHERCHEV().
Je te laisse décortiquer ma formule alambiquée :marto:

Code : Tout sélectionner   AgrandirRéduire
=RECHERCHEV(D3;INDIRECT(TEXTE(ANNEE(D3);"0000")&".A2:B367");2)


PS: Le module Base ne serait pas plus approprié pour l'archivage et la recherche de données? Je dis ça, je dis rien ;)

Cordialement,
Noonours plantigrade râleur

Pour obtenir la réponse la plus précise possible, N’HÉSITEZ SURTOUT PAS À JOINDRE UN FICHIER

LibO 7.0.3.1 et AOO 4.1.8 sous Windows 10
LibO 6.1.6.3_M14 MIMO (obligation de version) sous Win 7
Avatar de l’utilisateur
Noonours
Membre cOOnverti
Membre cOOnverti
 
Message(s) : 396
Inscrit le : 11 Mai 2013 01:11
Localisation : Aix en Provence

Re: RECHERCHEV sur plusieurs feuilles

Messagepar Michel JANZEF » 13 Oct 2020 20:51

Bonsoir,
J'ai utilisé ici la fonction INDIRECT en plus de RECHERCHEV plus des zones nommées et une liste déroulante pour l'année sur laquelle faire la recherche.
Pièces jointes
Jack21-MJ_13102020_01.ods
(34.02 Kio) Téléchargé 25 fois
1- AOo 4.1.8 et LibO 6.4.7.2 (x64) - Windows 10 Famille 1909 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 2440
Inscrit le : 12 Jan 2006 11:04

Re: RECHERCHEV sur plusieurs feuilles

Messagepar Jack21 » 14 Oct 2020 08:59

C'est exactement ce que je cherchais, merci beaucoup !! :D :bravo:
OpenOffice 4.1.7 sous Windows 10
Jack21
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 13 Oct 2020 18:37


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 12 invité(s)