Page 1 sur 1

Nombre d'occurences texte dans plusieurs cellules

MessagePublié: 02 Juil 2020 07:09
par yodo24

La modération vous a écrit: Titre corrigé : formule nombre d'occurence d'un texte dans plsueiurs cellule
Veillez à la qualité la prochaine fois : ce n'est pas pour vous mais pour tous ceux effectuant des recherches ensuite.


Bonjour à tous

En PJ un exemple de mon objectif
colonne B : des textes de noms de documents
colonne C : extraction du numéro concerné par le document
colonne D: les numéros que je cherche dans les textes
colonne G: le nombre de documents correspondant a chaque occurrence du numéro dans les textes

enfin mon problème
colonnes E et F (j'ai mis les valeurs attendues sans les formules)
pour E : le nombre de documents correspondant au numéro de la colonne D et a l’occurrence du texte dans la cellule E8
pour F : le nombre de documents correspondant au numéro de la colonne D et a l’occurrence du texte dans la cellule F8

j'ai essayé de décomposer en plusieurs formules avant de regrouper mais rien a faire. J'obtiens parfois le texte VALEUR, que je ne sais pas gérer
J'ai bien pensé a un tableau croisé mais ... il me fait aller pécher l'info dedans pour renseigner les colonnes E et F

Merci a tous pour votre aide

Re: formule nombre d'occurence d'un texte dans plsueiurs cel

MessagePublié: 02 Juil 2020 07:31
par Dude
Salut,

yodo24 a écrit:En PJ un exemple de mon objectif

Certes mais on ne voit pas comment les données sont organisées au départ.
Cela ressemble nettement au résultat d'un tableau croisé.

Dans ta signature, il y a écrit:Open Office 5.3 sous Windows 7

Cette version n'existe pas. Corrige l'information.

formule nombre d'occurences d'un texte dans plusieurs cellul

MessagePublié: 02 Juil 2020 09:10
par yodo24
Bonjour

Ok , la signature est corrigée

j'ai aussi corrigé une erreur de formule, et mis en évidence en ROUGE que je veux obtenir tout en clarifiant le tableau
voir nouvelle PJ

Pour le tableau croisé je vais creuser l'affaire car je connais un peu mais je souhaitais ne pas en passer par la

Re: formule nombre d'occurence d'un texte dans plsueiurs cel

MessagePublié: 02 Juil 2020 09:14
par jeanmimi
Bonjour,
Par Données > Sous-totaux il est possible de calculer le nombre de diplômes ou d'attestations.
A tester pour voir si l'affichage du résultat est conforme à ce qui est souhaité.

Re: Nombre d'occurences texte dans plusieurs cellules

MessagePublié: 02 Juil 2020 13:37
par yodo24
merci a jeanmimi pour sa proposition

Cela semble fonctionner, mais ce n'est franchement pas très lisible, pour quelqu'un qui découvre les résultats sans explications

De plus j'aurai aimé que si un N° de la colonne F, n'a ni diplôme ni attestation s'affiche un 0 en G et H

je poursuis mes essais plutôt vers tableau croisé

Re: Nombre d'occurences texte dans plusieurs cellules

MessagePublié: 03 Juil 2020 00:27
par OOotremer971
Bonsoir,

Et comme ça (formule matricielle) en G9 à propager vers la droite puis vers le bas:
Code : Tout sélectionner   AgrandirRéduire
=NB.SI(ESTNUM(TROUVE(G$8;$B$9:$B$15)*TROUVE($F9;$B$9:$B$15));VRAI())

yodo24.png
Cliquer sur l'image pour l'agrandir