[Résolu] Alignement de cellules avec même valeur

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Alignement de cellules avec même valeur

Messagepar Alderyos » 09 Juin 2020 21:20

Bonjour,

J'aimerais pouvoir rapidement aligner les cellules avec les mêmes valeurs, de différentes colonnes, sur la même ligne.

Puisqu'une image vaut mille mots, j'aimerais passer de ceci :
Aligner_Cellule_01-Avant.png
Aligner_Cellule_01-Avant.png (6.07 Kio) Consulté 394 fois


à cela :
Aligner_Cellule_02-Après.png
Aligner_Cellule_02-Après.png (5.87 Kio) Consulté 394 fois


Toute aide serait grandement appréciée.

Mon document est disponible ci-bas en attachement.
Alignement_cellule.ods
(14.28 Kio) Téléchargé 46 fois


Merci!
Dernière édition par Alderyos le 09 Juin 2020 22:51, édité 1 fois.
AOO 4.1.7 sous Windows 10 (x64)
LibreOffice 6.4.4 sous Windows 10 (x64)
Alderyos
Fraîchement OOthentifié
 
Message(s) : 6
Inscrit le : 18 Oct 2014 19:04

Re: Alignement de cellules avec même valeur

Messagepar OOotremer971 » 09 Juin 2020 22:47

Bonjour,

En C2 par exemple :
Code : Tout sélectionner   AgrandirRéduire
=SIERREUR(INDEX($B$1:$B$15;EQUIV(A2;$B$1:$B$15;0));"")

à étirer vers le bas

A+

 Ajout : Formule modifiée entre temps 
En principe, toujours à jour des dernières versions dites stables
AOO
LibreOffice
Debian 10
Ubuntu 18.04.4 LTS
OpenSuse Leap
Avatar de l’utilisateur
OOotremer971
ManitOOu
ManitOOu
 
Message(s) : 2503
Inscrit le : 16 Avr 2010 14:31

Re: [Résolu] Alignement de cellules avec même valeur

Messagepar Alderyos » 09 Juin 2020 22:53

Bonjour OOotremer971,

Merveilleux! Merci infiniment de votre aide!

Cordialement,
AOO 4.1.7 sous Windows 10 (x64)
LibreOffice 6.4.4 sous Windows 10 (x64)
Alderyos
Fraîchement OOthentifié
 
Message(s) : 6
Inscrit le : 18 Oct 2014 19:04

Re: [Résolu] Alignement de cellules avec même valeur

Messagepar Jean-Louis Cadeillan » 09 Juin 2020 23:47

Bonsoir,
Une variante (valable sous OpenOffice ou LibreOffice), par exemple en C2 :
Code : Tout sélectionner   AgrandirRéduire
=SI(ESTNA(EQUIV(A2;$B$1:$B$15;0));"";A2)
Cordialement,
Jean-Louis
LibO 6.4.7.2 (x64 avec Java 1.8.0_281) et AOO 4.1.8 (avec Java x32 1.8.0_241), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5030
Inscrit le : 03 Jan 2009 00:56


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 20 invité(s)