[Résolu] Calculer un montant en fonction d'âge

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Calculer un montant en fonction d'âge

Messagepar larso21 » 04 Juin 2020 07:17

Bonjour,
Je voudrais trouver une formule de calcul qui puisse me donner le montant en fonction d'un âge (c'est pour l'arbre de Noël de mon travail).
Je vous donne les 3 groupes :
de 2009 à 2004 : 70 €
de 2010 à 2014 : 55 €
de 2015 à 2020 : 40 €
Je vous joins le fichier... (ma colonne F est la date de naissance des enfants)
J'ai essayé la formule si :=SI(F23<="31/12/2009";70;SI(F23>="1/1/2010";55;SI(F23>="1/1/2015";40;""))) mais cela ne fonctionne pas...
=SI(F22<=31/12/2009;70;SI(F22>=1/1/2010;55;SI(F22>=1/1/2015;40;"")))
Merci pour votre aide
Pièces jointes
test.ods
(9.93 Kio) Téléchargé 40 fois
OpenOffice 4.1.7
larso21
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 04 Juin 2020 07:00

Re: Calculer un montant en fonction d'âge

Messagepar micmac » 04 Juin 2020 07:20

Bonjour et bienvenue sur notre forum,
votre signature a écrit:OpenOffice 4.1.7

La signature que vous avez indiquée manque de clarté et risque d'induire en erreur les gens qui vous répondront.
Vous devez préciser la version exacte d'OpenOffice ou de LibO (version officielle ou des dépôts selon le cas) et le système sur lequel il tourne.
Voici quelques exemples : AOO 4.1.7, LibO 6.3.6, sous Windows XP SP3, Vista SP2, Win7 SP1, Win 8.1, Win 10, macOS 10.15.5, Ubuntu 20.04 ...etc.

Lien direct pour accéder à votre signature

Cordialement
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 7246
Inscrit le : 28 Août 2010 09:45

Re: Calculer un montant en fonction d'âge

Messagepar Michel JANZEF » 04 Juin 2020 07:56

Bonjour,
Dans votre fichier test, en D2
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(ANNEE(C2)>=2004;ANNEE(C2)<=2009);70;SI(ET(ANNEE(C2)>=2010;ANNEE(C2)<=2014);55;SI(ET(ANNEE(C2)>=2015;ANNEE(C2)<=2020);40)))

Si, dans votre fichier réel, la date de naissance est en colonne F, remplacer C par F dans la formule.
1- AOo 4.1.8 et LibO 6.4.7.2 (x64) - Windows 10 Famille 1909 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 2440
Inscrit le : 12 Jan 2006 11:04

Re: Calculer un montant en fonction d'âge

Messagepar Jeff » 04 Juin 2020 18:28

Bonjour,

Autre solution, passer par la somme des valeurs booléenne, toujours en D2 :
Code : Tout sélectionner   AgrandirRéduire
=(ET(ANNEE(C2)>=2004;ANNEE(C2)<=2009)*70+(ET(ANNEE(C2)>=2010;ANNEE(C2)<=2014)*55+(ET(ANNEE(C2)>=2015;ANNEE(C2)<=2020)*40)))


A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.8 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 20.04 x64 (Focal Fossa), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8388
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: Calculer un montant en fonction d'âge

Messagepar Michel JANZEF » 04 Juin 2020 19:40

Une autre solution encore, dans laquelle les années prochaines vous n'aurez qu'à changer les valeurs dans les cellules contenant les années et le montant alloué. Ça peut éviter de faire une erreur en modifiant une formule.

A noter que cette solution fonctionne également avec la formule proposée par Jeff qu'il suffit juste d'adapter.
Pièces jointes
larso21-MJ04062020_01.ods
(11.68 Kio) Téléchargé 34 fois
1- AOo 4.1.8 et LibO 6.4.7.2 (x64) - Windows 10 Famille 1909 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 2440
Inscrit le : 12 Jan 2006 11:04

Re: Calculer un montant en fonction d'âge

Messagepar gerard24 » 04 Juin 2020 19:58

Bonsoir,

Avec une formule de recherche, basé sur le fichier joint au message précédent.

Code : Tout sélectionner   AgrandirRéduire
=RECHERCHE(ANNEE(C2);$G$2:$I$4)

A+
OOodidacte
LibreOffice 6.4.5 sous Windows 10.
pour télécharger LibreOffice
Avatar de l’utilisateur
gerard24
ManitOOu
ManitOOu
 
Message(s) : 3155
Inscrit le : 06 Juil 2008 18:08
Localisation : dans le Périgord


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : malokran et 15 invité(s)