[Résolu] Graphique avec les mois des dates...

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Graphique avec les mois des dates...

Messagepar wee wee » 29 Avr 2020 13:39

Bonjour,

Je cherche un tuto pour faire un graphique, cela me paraissait simple mais je m'arrache les cheveux...

Voila j'ai un logbook avec des heures avions, je voudrais faire un graphique bâton avec en x les mois depuis 2010, et en y la somme des heures de vol pour le mois allant jusqu'a 100?
Les heures de vols sont en plus dans des colonnes différent en fonction du type de vol....

En vous remerciant d'avance,
Je joint le tableau en question.

LOG BOOK NEW 2019 avion et ulm 290420.ods
(85.78 Kio) Téléchargé 19 fois
Dernière édition par micmac le 30 Avr 2020 12:10, édité 1 fois.
Raison: Balisage
OpenOffice 4.1.6 sous Windows 10
wee wee
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 24 Juin 2019 10:15

Re: Graphique avec les mois des dates...

Messagepar Jean-Louis Cadeillan » 29 Avr 2020 14:51

Bonjour,
Une formule pour sommer sur des conditions(ici en B1 de Feuille3 du fichier joint) :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(ANNEE(Date)=ANNEE(A1);MOIS(Date)=MOIS(A1);Durée)
Date étant une plage nommée ($fw.$B$7:$B$1411) et Durée aussi ($fw.$AX$7:$AX$1411). Dans cette colonne AX, j'ai fait la somme quotidienne des heures de vol (de la colonne O à la colonne AE de la feuille fw).
Voir fichier joint. À tester.
Cordialement,
Jean-Louis
Pièces jointes
wee_wee_20200429_JLC01.ods
(112.19 Kio) Téléchargé 13 fois
LibO 6.3.6.2 (x64 avec Java 1.8.0_241) et AOO 4.1.7 (avec Java x32 1.8.0_261), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5025
Inscrit le : 03 Jan 2009 00:56

Re: Graphique avec les mois des dates...

Messagepar wee wee » 30 Avr 2020 10:58

Whaou genial, merci beaucoup!

Bon j'ai essayer de le refaire mais sans succès.... par contre en copiant collant tes cellules cela fonctionne a merveille!

Encore un grand merci.
OpenOffice 4.1.6 sous Windows 10
wee wee
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 24 Juin 2019 10:15


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 4 invité(s)