[Résolu] Calcul d'un nombre de valeurs sous condition

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Calcul d'un nombre de valeurs sous condition

Messagepar elde » 28 Avr 2020 09:03

Bonjour,

J'ai créé un tableau qui contient des noms de villes (par forcément classés) et en regard une référence (de divers types).
Je voudrais, dans un tableau annexe, compter le nombre de référence par ville.

Je ne parviens pas à construire ma formule de calcul. Je tourne autour avec NB.SI ou NB.VAL ou encore avec NB.SI.ENS mais ça ne fonctionne pas.
Je joins un exemple en PJ.

Merci pour votre aide.

Cordialement.
Pièces jointes
ref_par_ville.ods
(13.09 Kio) Téléchargé 11 fois
Dernière édition par elde le 28 Avr 2020 15:05, édité 1 fois.
Libre Office 5.2.6.2.lin14 (x64) (Obligation de version) sous Windows 10
Libre Office 6.3.2.2 (x64) sous Windows 10
elde
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 163
Inscrit le : 14 Mai 2010 14:13

Re: Calcul d'un nombre de valeurs sous condition

Messagepar rollmops » 28 Avr 2020 09:37

Bonjour,

Le plus simple dans ton cas, est d'utiliser la fonction "Tableau croisé".
Change le champ Somme Référence par Nombre Référence dans l'assistant.
OpenOffice 4.1.7 - Windows 7
Avatar de l’utilisateur
rollmops
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 267
Inscrit le : 20 Déc 2017 15:45

Re: Calcul d'un nombre de valeurs sous condition

Messagepar yclik » 28 Avr 2020 09:44

Bonjour
en G4
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD($B$4:$B$14=F4)*($C$4:$C$14<>"")
OpenOffice 4.1.7 sous Windows 10
Avatar de l’utilisateur
yclik
SuppOOrter
SuppOOrter
 
Message(s) : 1202
Inscrit le : 15 Déc 2010 09:33

Re: Calcul d'un nombre de valeurs sous condition

Messagepar Jean-Louis Cadeillan » 28 Avr 2020 11:26

Bonjour,
Est-ce qu'une ville peut ne pas avoir de référence (cellule de la colonne C vide) ?
Est-ce qu'une ville peut avoir deux fois ou plus la même référence ? Et dans ce dernier cas, faut-il ne compter qu'une occurrence ?
Cordialement,
Jean-Louis
LibO 6.3.6.2 (x64 avec Java 1.8.0_241) et AOO 4.1.7 (avec Java x32 1.8.0_251), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5005
Inscrit le : 03 Jan 2009 00:56

Re: Calcul d'un nombre de valeurs sous condition

Messagepar elde » 28 Avr 2020 11:50

A yclik

J'obtiens bien le résultat attendu avec la fonction SOMMEPROD mais à quoi sert la suite de la formule ?

Code : Tout sélectionner   AgrandirRéduire
*($C$4:$C$14<>"")


A Jean-Louis Cadeillan,

La réponse est non deux fois :
- Une ville a toujours une référence,
- Une ville ne peut pas avoir deux références ou plus identiques.
Libre Office 5.2.6.2.lin14 (x64) (Obligation de version) sous Windows 10
Libre Office 6.3.2.2 (x64) sous Windows 10
elde
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 163
Inscrit le : 14 Mai 2010 14:13

Re: Calcul d'un nombre de valeurs sous condition

Messagepar Jean-Louis Cadeillan » 28 Avr 2020 12:35

elde a écrit:- Une ville a toujours une référence,
- Une ville ne peut pas avoir deux références ou plus identiques.
Dans ce cas, en G4 :
Code : Tout sélectionner   AgrandirRéduire
=NB.SI($B$4:$B$14;F4)
suffit. Les références n'entrent pas en ligne de compte, il suffit de compter combien de fois une ville est citée.
Et également :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD($B$4:$B$14=F4)
convient. La suite supposait d'éviter le cas où une ville n'aurait pas encore de référence, mais il aurait fallu ajouter des parenthèses :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(($B$4:$B$14=F4)*($C$4:$C$14<>""))
Cordialement,
Jean-Louis
LibO 6.3.6.2 (x64 avec Java 1.8.0_241) et AOO 4.1.7 (avec Java x32 1.8.0_251), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5005
Inscrit le : 03 Jan 2009 00:56

Re: Calcul d'un nombre de valeurs sous condition

Messagepar elde » 28 Avr 2020 15:03

Jean-Louis a écrit:il suffit de compter combien de fois une ville est citée

Bon sang, mais c'est bien sûr ! Il fallait raisonner sur la ville et non pas sur la référence.

C'était effectivement simple.

Merci à vous deux pour votre aide rapide et efficace.
Libre Office 5.2.6.2.lin14 (x64) (Obligation de version) sous Windows 10
Libre Office 6.3.2.2 (x64) sous Windows 10
elde
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 163
Inscrit le : 14 Mai 2010 14:13

Re: [Résolu] Calcul d'un nombre de valeurs sous condition

Messagepar rollmops » 29 Avr 2020 08:08

elde a écrit:Merci à vous deux pour votre aide rapide et efficace.

Et en quoi ma solution de tableau croisé ne répondait pas au problème ?
OpenOffice 4.1.7 - Windows 7
Avatar de l’utilisateur
rollmops
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 267
Inscrit le : 20 Déc 2017 15:45


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 9 invité(s)