[Résolu] Concaténer et cellule #N/D

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Concaténer et cellule #N/D

Messagepar EJM » 11 Avr 2020 10:07

Bonjour, je suis en train de travailler sur un document construit comme suit :
Feuille 2 : une entrée, sa ligne (ceci est une colonne à part entière), et du contenu.
Feuille 5 : une famille qui regroupe plusieurs entrées (retrouvables à l'aide d'une liste déroulante) et qui y associe la ligne corresponant grâce à la fonction rechercheV. Quand il n'y a rien, elle renvoie #N/D. Le nombre d'entrée au sein d'une famille est variable, et le processus de liste déroulante a été "scrollé" (je ne connais pas le terme technique) une dizaine de fois.

Voici mon problème : je cherche à concaténer les numéros de lignes d'une même famille. Cependant dès qu'il est question de concaténer une cellule contenant #N/D la formule part en vrille.

Pour ma part je vois 2 solutions, mais que je ne sais pas mettre en place :
- retirer le #N/D quand la fonction rechercheV renvoie à une cellule vide
- adapter la fonction concaténer

Sauriez vous m'aider? Merci!
Pièces jointes
Magie faces fantasy v1.3.22.ods
(161.02 Kio) Téléchargé 11 fois
Dernière édition par EJM le 18 Avr 2020 23:16, édité 1 fois.
Open office 4.1.7 sous Windows
EJM
Membre lOOyal
Membre lOOyal
 
Message(s) : 41
Inscrit le : 21 Mars 2020 17:56

Re: Concaténer et cellule #N/D

Messagepar Michel JANZEF » 11 Avr 2020 10:14

Bonjour,
Il ne faut poser qu'une question par fil (Voir la règle n° 7).
Pour répondre à
EJM a écrit:...- retirer le #N/D quand la fonction rechercheV renvoie à une cellule vide...

En O2 :
Code : Tout sélectionner   AgrandirRéduire
=SI(N2="";"";RECHERCHEV(N2;'Sorts détaillés'.$B$1:$Z$408;2;0))

puis étirer vers le bas.
Domicile :
1- AOo 4.1.7 et LibO 6.3.6.2 (x64) - Windows 10 Famille 1903 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 2216
Inscrit le : 12 Jan 2006 11:04

[Résolu] Re: Concaténer et cellule #N/D

Messagepar EJM » 11 Avr 2020 16:49

Ca fonctionne! merci!
Open office 4.1.7 sous Windows
EJM
Membre lOOyal
Membre lOOyal
 
Message(s) : 41
Inscrit le : 21 Mars 2020 17:56


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 2 invité(s)