[Résolu]empêcher d'entrer une donnée

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu]empêcher d'entrer une donnée

Messagepar Franck55 » 02 Fév 2020 13:37

Bonjour.

J'aimerai savoir comment faire pour empecher un utilisateur de renseigner le nom d'un jeune (dans la colonne W de l'onglet «atelier du savoir fer» s'il à été sorti du dispositif dans l'onglet tableau de donnée (date de la sortie colonne AA).

Par exemple, dans le document en piece jointe, j'aimerai qu'on ne puisse pas pouvoir entrer le jeune
CHANT Temal.

Merci par avance.

Franck.
Pièces jointes
version test 2 Tableau annuel 2020.ods
(156.71 Kio) Téléchargé 14 fois
Dernière édition par Franck55 le 03 Fév 2020 18:41, édité 2 fois.
Obligation de version: LibreOffice Version: 5.0.4.2 sous Windows 7
Franck55
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 50
Inscrit le : 11 Juin 2016 06:52

Re: empecher d'entrée une donnée

Messagepar Jeff » 02 Fév 2020 15:58

Bonjour,

La validité pour la colonne W pourrait être :
Code : Tout sélectionner   AgrandirRéduire
=SI(ESTERREUR(PETITE.VALEUR(SI(ESTVIDE($DONNEES.$AA$7:$AA$256);LIGNE($DONNEES.$AA$7:$AA$256));LIGNE($A$1:$A$255)));"";INDIRECT(ADRESSE(PETITE.VALEUR(SI(ESTVIDE($DONNEES.$AA$7:$AA$256);LIGNE($DONNEES.$AA$7:$AA$256));LIGNE($A$1:$A$255));17;;;"DONNEES")))


Avec Libo, (que je n’ai pas, donc sous réserve) :
Code : Tout sélectionner   AgrandirRéduire
=SIERREUR(INDIRECT(ADRESSE(PETITE.VALEUR(SI(ESTVIDE($DONNEES.$AA$7:$AA$256);LIGNE($DONNEES.$AA$7:$AA$256));LIGNE($A$1:$A$255));17;;;"DONNEES")));"")


Et compléter le dialogue de validité pour afficher le message d’erreur.

A +
Pièces jointes
version_test_2_Tableau_annuel_2020_Jeff.ods
(153.52 Kio) Téléchargé 14 fois
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 18.04.1 x64 (Bionic Beaver), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8335
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: empecher d'entrée une donnée

Messagepar Oukcha » 02 Fév 2020 16:01

Bonjour,

Votre signature a écrit:Obligation de version: LibreOffice Version: 5.0.4.2 sous Windows 7

Vous avez toujours l’obligation d’utiliser cette version obsolète ?

Cordialement
                                        
:arrow: A lire avant tout ! Image
Avatar de l’utilisateur
Oukcha
RespOOnsable modération
RespOOnsable modération
 
Message(s) : 3154
Inscrit le : 06 Oct 2008 09:03

Re: empêcher d'entrer une donnée

Messagepar Franck55 » 03 Fév 2020 18:41

bonjour à tout. merci beaucoup jeff, c'est top, ca correspond tout à fait à mes attentes... pour le message d'erreur, ce n'es tpas nécessaire car le fait de ne plus pouvoir valider le jeune est suffisant.

pour ce qui es de la version obsolète, c'es tla version que j'a iactuellement sur le pc que j'utilise, mais à priori on devrai me le changer et du coup la version évoluera sans doute avec le changement d'ordinateur.
je ne manquerai pas de modifier ma fiche en fonction.

encore merci à vous.
j'aurai de nouveau besoins de vos compétences, mais il faut que je remette déja de l'ordre dans le document support.
Obligation de version: LibreOffice Version: 5.0.4.2 sous Windows 7
Franck55
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 50
Inscrit le : 11 Juin 2016 06:52


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 3 invité(s)