[Résolu]Recherche une valeur dans plusieurs tableaux

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu]Recherche une valeur dans plusieurs tableaux

Messagepar kylejake » 28 Jan 2020 10:38

Bonjour
Des jours de recherche sur les forum sans trouver la solution qui fonctionne.
J'ai fais plusieurs essais dans "essai formule" aucune ne fonctionne car elles sont fausses ou des erreurs de transcription.

J'ai plusieurs petits tableaux avec des résultats.
Je veux retrouver la valeur exacte correspondante pour l'inscrire dans un autre tableau.
Par exemple je recherche la valeur de "NED" dans les 3 tableaux.

Merci pour votre aide

Kylejake
Pièces jointes
kylejake 20200127_V1.ods
(12.15 Kio) Téléchargé 12 fois
Dernière édition par kylejake le 28 Jan 2020 14:36, édité 1 fois.
Pc portable Win 10 pro AOO 4.1.7 LibO 6.3.4 Mozilla Firefox 74.0 IE 11.0 Pc salon Win 8.1 home Mozilla Firefox 74.0 Chrome 76.0.3 Opera 62.0.3 AOO 4.1.7 LibO 6.3.4
Avatar de l’utilisateur
kylejake
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 74
Inscrit le : 06 Juin 2014 09:03

Re: Recherche une valeur dans plusieurs tableaux

Messagepar yclik » 28 Jan 2020 11:51

Bonjour
si limité à 3 tableaux
Code : Tout sélectionner   AgrandirRéduire
=SI(ESTERREUR(RECHERCHEV(Q5;$A$5:$D$7;4;0));SI(ESTERREUR(RECHERCHEV(Q5;$F$5:$I$7;4;0));SI(ESTERREUR(RECHERCHEV(Q5;$K$5:$N$7;4;0));"";RECHERCHEV(Q5;$K$5:$N$7;4;0));RECHERCHEV(Q5;$F$5:$I$7;4;0));RECHERCHEV(Q5;$A$5:$D$7;4;0))


attention certains espace en trop comme "FRA "

cela serait plus simple avec RECHERCHEV d'avoir les tableaux l'un en dessous de l'autre, quitte à les recopier avec liaison sur un autre onglet.
OpenOffice 4.1.7 sous Windows 10
Avatar de l’utilisateur
yclik
SuppOOrter
SuppOOrter
 
Message(s) : 1202
Inscrit le : 15 Déc 2010 09:33

Re: Recherche une valeur dans plusieurs tableaux

Messagepar Jeff » 28 Jan 2020 12:36

Bonjour à tous,

Un peu plus court mais plus complexe, en B23 :
Code : Tout sélectionner   AgrandirRéduire
=RECHERCHEV(A23;DECALER($A$1;MAX(LIGNE(A5:N7)*(A5:N7=$A$23))-1;MAX(COLONNE(A5:N7)*(A5:N7=$A$23))-1;;4);4)

:arrow: À valider matriciellement pat Ctrl + Maj + Entrer

La plage est fabriquée avec DECALER (voir tuto)

Ce qui donne pour R5 :
Code : Tout sélectionner   AgrandirRéduire
=RECHERCHEV(Q5;DECALER($A$1;MAX(LIGNE($A$5:$N$7)*($A$5:$N$7=Q5))-1;MAX(COLONNE($A$5:$N$7)*($A$5:$N$7=Q5))-1;;4);4;0)

:arrow: À valider par Ctrl + Maj + Entrer, à étirer vers le bas en pressant CTRL

Capture d’écran du 2020-01-28 12-51-21.png


Pas-à-pas fourni dans le fichier joint :)

yclik a écrit:attention certains espace en trop comme "FRA "
ou "ENG " :wink:


A +
Pièces jointes
kylejake 20200127_V1_Jeff.ods
(12.55 Kio) Téléchargé 11 fois
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 18.04.1 x64 (Bionic Beaver), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8335
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: Recherche une valeur dans plusieurs tableaux

Messagepar gerard24 » 28 Jan 2020 13:30

Bonjour,

La recherche portant sur une valeur unique,
et
la valeur a retourner étant numérique,

on peut détourner la fonction SOMME.SI de son but initial :

Code : Tout sélectionner   AgrandirRéduire
=SOMME.SI($A$5:$K$7;Q5;$D$5:$N$7)

*noter le décalage en colonnes des plages critère et somme.

A+
OOodidacte
LibreOffice 6.4.5 sous Windows 10.
pour télécharger LibreOffice
Avatar de l’utilisateur
gerard24
ManitOOu
ManitOOu
 
Message(s) : 3152
Inscrit le : 06 Juil 2008 18:08
Localisation : dans le Périgord

Re: Recherche une valeur dans plusieurs tableaux

Messagepar Jeff » 28 Jan 2020 13:39

gerard24 a écrit:on peut détourner la fonction SOMME.SI

Ou adapter à SOMMEPROD :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD($A$5:$K$7=Q5;$D$5:$N$7)

Avec le même décalage en colonnes des plages critère et somme
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 18.04.1 x64 (Bionic Beaver), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8335
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: Recherche une valeur dans plusieurs tableaux

Messagepar kylejake » 28 Jan 2020 14:00

Bonjour, Yclik,Jeff,Gérard 24

Merci de vos interventions.

Il y aura au maximum 12 petit tableaux + 1 récapitulatif.
Je pense qu'il y aura 4 tableaux en horizontal et 3 en vertical avec des espaces d' une colonne et une ligne
Je ne sais pas encore si le récap se fera sur la même feuille ou sur une autre

Sur la formule de Yclik et Gérard 24, tout serait OK sauf pour ENG et FRA, je ne sais pas pourquoi !
Sur la formule de Jeff, dans ma retranscription ,recopier ou copier/coller, la valeur n’apparaît pas ou ### ou la formule (= recherchev.....), là aussi je ne ais pas pourquoi !

Merci
Pc portable Win 10 pro AOO 4.1.7 LibO 6.3.4 Mozilla Firefox 74.0 IE 11.0 Pc salon Win 8.1 home Mozilla Firefox 74.0 Chrome 76.0.3 Opera 62.0.3 AOO 4.1.7 LibO 6.3.4
Avatar de l’utilisateur
kylejake
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 74
Inscrit le : 06 Juin 2014 09:03

Re: Recherche une valeur dans plusieurs tableaux

Messagepar Jeff » 28 Jan 2020 14:04

kylejake a écrit:tout serait OK sauf pour ENG et FRA, je ne sais pas pourquoi !
Parce que tu lis en diagonale les réponses qui te sont faites :mrgreen:
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 18.04.1 x64 (Bionic Beaver), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8335
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: [Résolu]Recherche une valeur dans plusieurs tableaux

Messagepar kylejake » 28 Jan 2020 14:41

J'ai effacé ENG et FRA, puis formater la cellule, et tout fonctionne à merveille.
Sauf la formule de Jeff, peut être un problème de format !
Tout est OK pour moi encore merci à tout les trois.

Cordialement

Kylejake
Pc portable Win 10 pro AOO 4.1.7 LibO 6.3.4 Mozilla Firefox 74.0 IE 11.0 Pc salon Win 8.1 home Mozilla Firefox 74.0 Chrome 76.0.3 Opera 62.0.3 AOO 4.1.7 LibO 6.3.4
Avatar de l’utilisateur
kylejake
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 74
Inscrit le : 06 Juin 2014 09:03


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 2 invité(s)