[Résolu] Fonction NB.SI et opérateur de comparaison

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Fonction NB.SI et opérateur de comparaison

Messagepar elde » 22 Jan 2020 13:46

Bonjour,

Je souhaite calculer le nombre de cellules d"un tableau qui ne contiennent pas la valeur "so" étant entendu que les autres cellules peuvent être vides, contenir une date ou du texte autre que "so".
J'utilise la fonction NB.SI et l'opérateur de comparaison <> mais j'obtiens systématiquement une erreur 510 quelle que soit la syntaxe utilisée.
Je joins un fichier pour exemple.

Comment faire pour obtenir le résultat souhaité ?

Merci pour votre aide.

Cordialement.
Pièces jointes
NB-SI-DIFF.ods
(11.08 Kio) Téléchargé 25 fois
Dernière édition par elde le 23 Jan 2020 13:32, édité 1 fois.
Libre Office 5.2.6.2.lin14 (x64) (Obligation de version) sous Windows 10
Libre Office 6.3.2.2 (x64) sous Windows 10
elde
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 171
Inscrit le : 14 Mai 2010 14:13

Re: Fonction NB.SI et opérateur de comparaison

Messagepar njhub » 22 Jan 2020 14:27

Bonjour elde,

essayez avec:
Code : Tout sélectionner   AgrandirRéduire
=NB.SI(B2:D5;"<>"&"so")
LibreOffice 7.0.3.1/ (x64) FR-YT 25/10/20
OS : Windows 10.0
njhub
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 282
Inscrit le : 18 Juin 2017 06:43
Localisation : 976

Re: Fonction NB.SI et opérateur de comparaison

Messagepar elde » 22 Jan 2020 14:35

Merci njhub, mais cela ne fonctionne pas, le résultat est erroné.
Libre Office 5.2.6.2.lin14 (x64) (Obligation de version) sous Windows 10
Libre Office 6.3.2.2 (x64) sous Windows 10
elde
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 171
Inscrit le : 14 Mai 2010 14:13

Re: Fonction NB.SI et opérateur de comparaison

Messagepar njhub » 22 Jan 2020 16:09

Bonjour elde,

Vérifiez que le libellé de vos "so" ne contiennent pas d'espaces "so " ou " so" sans quoi ils ne sont pas comptés
LibreOffice 7.0.3.1/ (x64) FR-YT 25/10/20
OS : Windows 10.0
njhub
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 282
Inscrit le : 18 Juin 2017 06:43
Localisation : 976

Re: Fonction NB.SI et opérateur de comparaison

Messagepar joel275 » 22 Jan 2020 16:11

Bonjour,

chez moi, la formule donnée par njhub fonctionne, tout comme:
Code : Tout sélectionner   AgrandirRéduire
=NB.SI(B2:D5;"<>so")

Un problème de version peut-être? De toutes façons, avoir la dernière version stable n'a que des avantages.....

A plus.
OpenOffice 4.1.2 LibreOffice 6-2-8-2 Windows 8.1
joel275
InconditiOOnnel
InconditiOOnnel
 
Message(s) : 790
Inscrit le : 10 Jan 2009 09:05

Re: Fonction NB.SI et opérateur de comparaison

Messagepar elde » 22 Jan 2020 17:20

C'est curieux, car avec la même formule
Code : Tout sélectionner   AgrandirRéduire
=NB.SI(B2:D5;"<>so")

le résultat obtenu est erroné. J'obtiens 2... au lieu de 9.

Je mets le fichier en PJ.
Pièces jointes
NB-SI-DIFF-2.ods
(10.99 Kio) Téléchargé 23 fois
Libre Office 5.2.6.2.lin14 (x64) (Obligation de version) sous Windows 10
Libre Office 6.3.2.2 (x64) sous Windows 10
elde
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 171
Inscrit le : 14 Mai 2010 14:13

Re: Fonction NB.SI et opérateur de comparaison

Messagepar Jeff » 22 Jan 2020 18:03

Bonjour,

Autre technique envisageable :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(B2:D5<>"so"


NB.SI ne s'occupe pas des cellules vides, autre solutions :
Code : Tout sélectionner   AgrandirRéduire
=NB.SI($B$2:$D$5;"<>so")+NB.VIDE(B2:D5)


A + :wink:
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 20.04 x64 (Focal Fossa), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8352
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: Fonction NB.SI et opérateur de comparaison

Messagepar Michel JANZEF » 22 Jan 2020 18:12

Bonjour,
Dans vos options : menu Outils --> Options --> Libreoffice Calc --> cocher Autoriser les caractères génériques dans les formules
1- AOo 4.1.7 et LibO 6.4.7.2 (x64) - Windows 10 Famille 1903 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 2256
Inscrit le : 12 Jan 2006 11:04

Re: Fonction NB.SI et opérateur de comparaison

Messagepar gerard24 » 22 Jan 2020 21:01

Bonsoir,

Pour info, un comptage avec NB.SI et les opérateurs de comparaison <> ne prend pas en compte les cellules vides,
  • avec OpenOffice
  • avec LibreOffice, pour les versions antérieures à la version 6.1.3

Voir https://bugs.documentfoundation.org/sho ... i?id=73081

A+
OOodidacte
LibreOffice 6.4.5 sous Windows 10.
pour télécharger LibreOffice
Avatar de l’utilisateur
gerard24
ManitOOu
ManitOOu
 
Message(s) : 3154
Inscrit le : 06 Juil 2008 18:08
Localisation : dans le Périgord

Re: Fonction NB.SI et opérateur de comparaison

Messagepar ALBIN MARIE » 23 Jan 2020 08:59

Bonjour elde,

Si votre tableau a une taille "supportable", vous pouvez toujours faire ceci sans utiliser NB.SI :
Pièces jointes
NBSIDIFF.ods
Manipe sans nb.si
(12.38 Kio) Téléchargé 19 fois
OpenOffice 4.1.7 sous W10 V1909
Avatar de l’utilisateur
ALBIN MARIE
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 21 Jan 2020 21:04

Re: Fonction NB.SI et opérateur de comparaison

Messagepar elde » 23 Jan 2020 10:18

Bonjour à tous,

Il y avait donc deux raisons à ce dysfonctionnement :
1 - j'ignorais que NB.SI avec un opérateur de comparaison ne traitait pas les cellules vides,
2 - l'utilisation des caractères génériques dans les formules n'était pas coché.

Après avoir modifié la coche, le comptage fonctionne parfaitement avec SOMMEPROD.
Petit plus, si l'on veut un comptage avec "SO" en majuscule on peut faire comme cela
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(B2:D5<>"so";B2:D5<>"SO")


Mais peut-être peut on utiliser une autre technique pour obtenir un calcul qui prend en compte les majuscules et les minuscules ?

En tout cas, merci beaucoup pour votre aide.

Cordialement.
Libre Office 5.2.6.2.lin14 (x64) (Obligation de version) sous Windows 10
Libre Office 6.3.2.2 (x64) sous Windows 10
elde
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 171
Inscrit le : 14 Mai 2010 14:13

Re: Fonction NB.SI et opérateur de comparaison

Messagepar gerard24 » 23 Jan 2020 12:04

elde a écrit:Mais peut-être peut on utiliser une autre technique pour obtenir un calcul qui prend en compte les majuscules et les minuscules ?


Menu Outils > Options > LOCalc > Calcul, décocher "respecter la casse".
OOodidacte
LibreOffice 6.4.5 sous Windows 10.
pour télécharger LibreOffice
Avatar de l’utilisateur
gerard24
ManitOOu
ManitOOu
 
Message(s) : 3154
Inscrit le : 06 Juil 2008 18:08
Localisation : dans le Périgord

Re: Fonction NB.SI et opérateur de comparaison

Messagepar elde » 23 Jan 2020 13:32

C'est parfait, la question des majuscules et des minuscules est aussi réglée.

Merci à tous pour votre aide.

Cordialement.
Libre Office 5.2.6.2.lin14 (x64) (Obligation de version) sous Windows 10
Libre Office 6.3.2.2 (x64) sous Windows 10
elde
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 171
Inscrit le : 14 Mai 2010 14:13


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 12 invité(s)