[Résolu] Concatener et zéros significatifs

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Concatener et zéros significatifs

Messagepar cosmocrator » 21 Jan 2020 15:54

Bonjour,

Je sèche sur plusieurs problèmes dans le fichiers ci-joint.
Premièrement dans l'onglet "CLE CCP&RIB&RIP" je souhaiterai faire apparaître les zéros dans la cellule Q11 qui fait un concatener des cellules Q10 et W10

Malgré mes tentatives de formatage, les zéros n'apparaissent pas. J'y arrive si la cellule Q10 ne sépare pas les milliers. Et je souhaiterai que les 18 chiffres de la case Q10 soit séparés.

Deuxièmement est il possible de créer une formule dans la cellule Q11, en plus du concatener :
Si la cellule Q11 a 20 chiffres alors faire le concatener de Q10 et W10
Si la cellule compte moins de 20 chiffres alors faire apparaître "RIB invalide"

Merci pour vos lumières, (si vous pouviez m'expliquer la marche à suivre, ce serai cool)
Pièces jointes
RIB.ods
(52.1 Kio) Téléchargé 16 fois
Dernière édition par cosmocrator le 22 Jan 2020 10:05, édité 1 fois.
Libre Office Version: 5.2.6.2.lin14 (x64) par obligation Sous windows 10
cosmocrator
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 16
Inscrit le : 08 Fév 2017 11:52

Re: Concatener et zéros significatifs

Messagepar joel275 » 21 Jan 2020 17:26

Bonjour,

teste:
Code : Tout sélectionner   AgrandirRéduire
=TEXTE(Q10;"000 000 000 000 000 000")&TEXTE(W10;"_00")

pour la première question.

Normalement il ne faut poser qu'une seule question par fil, mais les fonctions si et nbcar sont pour toi.

A plus.
OpenOffice 4.1.2 LibreOffice 6-2-8-2 Windows 8.1
joel275
InconditiOOnnel
InconditiOOnnel
 
Message(s) : 790
Inscrit le : 10 Jan 2009 09:05

Re: Concatener et zéros significatifs

Messagepar cosmocrator » 22 Jan 2020 09:29

Merci pour ton code.
A quoi correspond le _ dans la partie (W10;"_00") ???

Merci pour ta réponse,
Libre Office Version: 5.2.6.2.lin14 (x64) par obligation Sous windows 10
cosmocrator
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 16
Inscrit le : 08 Fév 2017 11:52

Re: Concatener et zéros significatifs

Messagepar Michel JANZEF » 22 Jan 2020 10:01

Bonjour,
Ce que dit l'aide du logiciel (F1) :
Pour définir la largeur d'un espace dans un format numérique en utilisant un caractère, saisissez un trait de soulignage ( _ ) suivi du caractère.
Domicile :
1- AOo 4.1.7 et LibO 6.3.6.2 (x64) - Windows 10 Famille 1903 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 2212
Inscrit le : 12 Jan 2006 11:04


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 4 invité(s)