[Résolu] Moyenne de toutes les valeurs d'une colonne (durée)

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Moyenne de toutes les valeurs d'une colonne (durée)

Messagepar Fanla » 13 Jan 2020 19:38

Bonjour,

Dans le tableau joint, la cellule E6 contient cette formule :

=MOYENNE(B1-A1;B2-A2;B3-A3)-MOD(MOYENNE(B1-A1;B2-A2;B3-A3);1)&" jour"&SI(MOYENNE(B1-A1;B2-A2;B3-A3)-MOD(MOYENNE(B1-A1;B2-A2;B3-A3);1)>1;"s ";" ")&TEXTE(MOD(MOYENNE(B1-A1;B2-A2;B3-A3);1);"h")&" heures"

Comment peut-on calculer la moyenne de toutes les valeurs figurant dans la colonne C, sans avoir à citer toutes les lignes ? En effet, ce tableau comportera in fine des centaines de lignes, et j'ai besoin de la moyenne de toutes les durées que comportera la colonne C.

D'avance merci à vous pour votre aide.
Pièces jointes
Fanla3.ods
Tableau recensant des durées exprimées en jours et heures
(12.47 Kio) Téléchargé 11 fois
Dernière édition par micmac le 14 Jan 2020 11:12, édité 1 fois.
Raison: Balisage dans le premier message SVP
LibreOffice version 6.1.6.3.M13
Windows 10
Fanla
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 03 Jan 2020 18:49

Re: Moyenne de toutes les valeurs d'une colonne (durée)

Messagepar OOotremer971 » 13 Jan 2020 20:49

Bonjour,

Éventuellement :
Code : Tout sélectionner   AgrandirRéduire
=ENT(SOMMEPROD(MOYENNE(B1:B3-A1:A3)))&" jour(s) "&(HEURE(SOMMEPROD(MOYENNE(B1:B3-A1:A3))))&" heure(s) "


Il faudra quand même remplacer B3 et A3 par Bx et Ax (x étant le numéro de la dernière ligne à prendre en compte). Attention, il ne faut pas inclure de cellule vide dans les plages A1:Ax et B1:Bx

 Ajout : 1 : Une autre solution qui permet de prévoir dès le départ une plage plus grande et de ne plus se soucier des éventuelles cellules vides :
Code : Tout sélectionner   AgrandirRéduire
=ENT((SOMME(B1:B1000)-SOMME(A1:A1000))/NB(A1:A1000))&"jour(s) "&HEURE((SOMME(B1:B1000)-SOMME(A1:A1000))/NB(A1:A1000))&" heure(s)"
 

 Ajout : 2 : Tu peux avantageusement remplacer la formule de la colonne C :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(MOD(A1;1)>MOD(B1;1);B1-A1<1);TEXTE(MOD(B1-A1;1);"h")&" heures";ENT(B1)-ENT(SI(MOD(A1;1)>MOD(B1;1);A1+1;A1))&" jour"&SI(ENT(B1)-ENT(SI(MOD(A1;1)>MOD(B1;1);A1+1;A1))>1;"s ";" ")&TEXTE(MOD(B1-A1;1);"h")&" heures")

par
Code : Tout sélectionner   AgrandirRéduire
=ENT(B1-A1)&" jour(s) "&HEURE(B1-A1)&" heure(s)"
 
Dernière édition par OOotremer971 le 13 Jan 2020 22:38, édité 1 fois.
En principe, toujours à jour des dernières versions dites stables
AOO
LibreOffice
Debian 10
Ubuntu 18.04.4 LTS
OpenSuse Leap
Avatar de l’utilisateur
OOotremer971
HédOOniste
HédOOniste
 
Message(s) : 2351
Inscrit le : 16 Avr 2010 14:31

Re: Moyenne de toutes les valeurs d'une colonne (durée)

Messagepar Jean-Louis Cadeillan » 13 Jan 2020 22:08

Bonsoir,
... et Noonours t'avait donné une solution dans ton précédent fil...
Cordialement,
Jean-Louis
LibO 6.3.6.2 (x64 avec Java 1.8.0_241) et AOO 4.1.7 (avec Java x32 1.8.0_251), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
GourOOu
GourOOu
 
Message(s) : 5005
Inscrit le : 03 Jan 2009 00:56

Re: [Résolu] Moyenne de toutes les valeurs d'une colonne (du

Messagepar Fanla » 14 Jan 2020 10:55

Bonjour,

Merci beaucoup pour ton aide ! :super:

J'avais bien pris en compte la réponse de Nounours, à la question "comment calculer la moyenne de valeurs exprimées en jours et heures".
Dans un second temps, en remplissant mon tableau, je me suis rendue compte qu'il serait utile d'avoir une formule permettant de prendre en compte par défaut toutes les lignes de la colonne (la formule de Nounours, que je remercie portait, elle aussi, uniquement sur les trois lignes du tableau-exemple). Tu l'as compris, je suis très novice, je comprend maintenant en te lisant qu'il suffisait de changer une valeur dans sa formule, mais je l'ignorais. :oops:
Et comme on ne peut pas reposer une question sur un premier fil de discussion, j'ai demandé cette précision ici ... :wink:

Encore merci et bonne journée

Fanla
LibreOffice version 6.1.6.3.M13
Windows 10
Fanla
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 03 Jan 2020 18:49

Re: [Résolu] Moyenne de toutes les valeurs d'une colonne (du

Messagepar micmac » 14 Jan 2020 11:18

Fanla a écrit:on ne peut pas reposer une question sur un premier fil de discussion
Rien n'empêche de demander des précisions dans une discussion en cours, c'est même le but d'une discussion.
C'est le muti-postage qui est interdit.
Les formats ouverts (ODF) assurent la pérennité de vos documents.
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 6888
Inscrit le : 28 Août 2010 09:45


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 11 invité(s)