[Résolu] calcul à la demi-journée

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] calcul à la demi-journée

Messagepar ledébutant » 27 Mai 2019 17:41

Bonjour,

dans le petit tableau joint je souhaiterai que les dates soient calculée en demi-journée avec matin et après midi pour être à la fin être calculé en jours type 1 ou 1,5.

est-ce possible?

Merci de votre aide
Pièces jointes
calcul demi journée.ods
(9.7 Kio) Téléchargé 17 fois
Dernière édition par micmac le 27 Mai 2019 20:10, édité 1 fois.
Raison: Balisage
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49

Re: calcul à la demi-journée

Messagepar Pristio » 27 Mai 2019 18:26

Il y a peut-être mieux, mais voici une formule qui devrait t'aider (à mettre dans la colonne "Soit en jours") :

Code : Tout sélectionner   AgrandirRéduire
=SI(B5<>"";1;0.5)+SI(E5<>"";1;0.5)+JOURS(SI(D5<>"";D5;E5);SI(B5<>"";B5;C5))-2


J'ai fais une vérification si la cellule est vide ou non pour ajouter les premier 0.5/1, et ensuite je te mets la vérification du nombre de jours entre les deux date (le -2 est la car j'ai déjà calculé la date d'arrivé, et la date de sortie)
LibreOffice 6.2.4.2 (x64) - Windows 10
Pristio
Fraîchement OOthentifié
 
Message(s) : 5
Inscrit le : 27 Mai 2019 17:59

Re: calcul à la demi-journée

Messagepar ledébutant » 27 Mai 2019 18:47

j'ai un peu de mal à comprendre mais quand je tape une date en après midi cela ne donne rien et j'ai l'impression que cela ne donne pas en demi journée quand il y a .
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49

Re: calcul à la demi-journée

Messagepar Pristio » 27 Mai 2019 18:53

Oups, oui je t'es mis des points a la place des virgules, mauvaises habitudes ça :P c'est surement pour ça

Code : Tout sélectionner   AgrandirRéduire
=SI(B6<>"";1;0,5)+SI(E6<>"";1;0,5)+JOURS(SI(D6<>"";D6;E6);SI(B6<>"";B6;C6))-2


Après le coté "Ne donne rien", je ne sais pas, il est au moins sensé te donner une valeur inimaginable :lol:
LibreOffice 6.2.4.2 (x64) - Windows 10
Pristio
Fraîchement OOthentifié
 
Message(s) : 5
Inscrit le : 27 Mai 2019 17:59

Re: calcul à la demi-journée

Messagepar Michel JANZEF » 27 Mai 2019 18:55

Bonjour,
Essayez :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(B5<>"";D5<>"");DATEDIF(B5;D5;"d")+0,5;SI(ET(B5<>"";E5<>"");DATEDIF(B5;E5;"d")+1;SI(ET(C5<>"";D5<>"");DATEDIF(B5;D5;"d");SI(ET(C5<>"";E5<>"");DATEDIF(C5;E5;"d")+0,5;DATEDIF(B5;D5;"d")))))
Pièces jointes
ledébutant-MJ27052019_1.ods
(11.28 Kio) Téléchargé 20 fois
Domicile :
1- AOo 4.1.7 et LibO 6.2.7.1 (x64) - Windows 10 Famille 1903 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Bureau : LibO 5.1.2.2 (imposée) sous Linux Ubuntu 16.04
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 2024
Inscrit le : 12 Jan 2006 11:04

Re: calcul à la demi-journée

Messagepar ledébutant » 27 Mai 2019 19:39

Pristio a écrit:Oups, oui je t'es mis des points a la place des virgules, mauvaises habitudes ça :P c'est surement pour ça

Code : Tout sélectionner   AgrandirRéduire
=SI(B6<>"";1;0,5)+SI(E6<>"";1;0,5)+JOURS(SI(D6<>"";D6;E6);SI(B6<>"";B6;C6))-2


Après le coté "Ne donne rien", je ne sais pas, il est au moins sensé te donner une valeur inimaginable :lol:


:bravo: :D
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49

Re: calcul à la demi-journée

Messagepar ledébutant » 27 Mai 2019 19:50

Michel JANZEF a écrit:Bonjour,
Essayez :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(B5<>"";D5<>"");DATEDIF(B5;D5;"d")+0,5;SI(ET(B5<>"";E5<>"");DATEDIF(B5;E5;"d")+1;SI(ET(C5<>"";D5<>"");DATEDIF(B5;D5;"d");SI(ET(C5<>"";E5<>"");DATEDIF(C5;E5;"d")+0,5;DATEDIF(B5;D5;"d")))))



super par contre petite question comment déterminez vous la demi journée ? il y a t-il une question d'heure ?
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49

Re: calcul à la demi-journée

Messagepar Michel JANZEF » 27 Mai 2019 19:57

Le fonction DATEDIFF calcule la différence, en nombre de jours, entre deux dates et ensuite, j'ajoute +0,5
Domicile :
1- AOo 4.1.7 et LibO 6.2.7.1 (x64) - Windows 10 Famille 1903 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Bureau : LibO 5.1.2.2 (imposée) sous Linux Ubuntu 16.04
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 2024
Inscrit le : 12 Jan 2006 11:04

[Résolu] calcul à la demi-journée

Messagepar ledébutant » 27 Mai 2019 20:07

merci pour les explications, cela reste complexe pour mon niveau :fou:
Encore merci
Bonne soirée
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49

Re: [Résolu] calcul à la demi-journée

Messagepar Jeff » 28 Mai 2019 09:17

Bonjour à tous,

Une autre méthode pour obtenir le nombre de jours entre 2 dates, est de soustraire l'une à l'autre :wink:
On peut également savoir si une cellule contient une date lorsque sa valeur est supérieure à 0 (non valable pour le 30/12/1899 :mrgreen: ).

La formule de Michel devient alors :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(B5>0;D5>0);D5-B5+0,5;SI(ET(B5>0;E5>0);E5-B5+1;SI(ET(C5>0;D5>0);D5-C5;SI(ET(C5>0;E5>0);E5-C5+0,5;D5-B5))))


Ce qui devrait pouvoir se résumer à :
Code : Tout sélectionner   AgrandirRéduire
=SI(SOMME(B8:E8)=0;0;MAX(D8+0,5;E8+1)-MAX(B8;C8+0,5))


A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Debian Stable LXDE i686 10.1 (buster) et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8132
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: [Résolu] calcul à la demi-journée

Messagepar ledébutant » 28 Mai 2019 18:16

Bonsoir Jeff,
un résumé parfait :bravo: :bravo: :bravo:

Encore une petite question ou puis je glisser la formule =si(xx="";"")

Merci par avance

très bonne soirée
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49

Re: [Résolu] calcul à la demi-journée

Messagepar Jeff » 28 Mai 2019 19:04

Forcément, je donne un coup la syntaxe pour le cinquième ligne, et l’autre coup pour la huitième... :oops:

Voir le classeur joint en fin de post

A +
Pièces jointes
ledébutant-Jeff.ods
(10.99 Kio) Téléchargé 15 fois
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Debian Stable LXDE i686 10.1 (buster) et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8132
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: [Résolu] calcul à la demi-journée

Messagepar ledébutant » 28 Mai 2019 20:31

Jeff a écrit:Forcément, je donne un coup la syntaxe pour le cinquième ligne, et l’autre coup pour la huitième... :oops:

Voir le classeur joint en fin de post

A +


pas de soucis j'avais remarqué la subtilité :D

mais ma question est plus sur la formule =si(xx="";"") que j'arrive pas à intégrer dans le developpement du tableau que j'ai adapté à mes besoins pour éviter les zéros

Merci
Pièces jointes
ledebutant.ods
(12.04 Kio) Téléchargé 13 fois
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49

Re: [Résolu] calcul à la demi-journée

Messagepar Jeff » 29 Mai 2019 07:14

En fait j'aime pas trop renvoyer du texte vide lorsque je traite des chiffres, c'est pour cela que j'utilise :
Jeff a écrit:=SI(SOMME(B8:E8)=0;0;MAX(D8+0,5;E8+1)-MAX(B8;C8+0,5))

(à toi de changer le 0 :wink: )

Je préfère nettement utiliser un format de cellule qui masque les 0, tout en ne touchant pas le contenu :

Capture du 2019-05-29 08-09-21.png
Capture du 2019-05-29 08-09-21.png (10.67 Kio) Consulté 271 fois


A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Debian Stable LXDE i686 10.1 (buster) et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8132
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: [Résolu] calcul à la demi-journée

Messagepar ledébutant » 31 Mai 2019 16:18

Super merci, bon weekend
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49

Re: [Résolu] calcul à la demi-journée

Messagepar ledébutant » 03 Juin 2019 07:42

Me revoilà car je rencontre un soucis

La modération a écrit:Nous vous rappelons que la règle n° 7 stipule qu'il ne faut mettre qu'une question par fil.

Poser plusieurs questions complique la compréhension et n'encourage pas les réponses : il vaut donc mieux découper votre problème. Le titre de votre question ne peut pas refléter l'ensemble des problèmes exposés.

Afin que nous puissions avoir une base de connaissance efficace lors d'une recherche sur un seul de vos problèmes, nous vous prions de créer autant de fil que de questions.

Merci de votre collaboration.

dans le fichier joint et dans la cellule M3 apparait une écriture alors qu'il n'y a rien dans les cellules J3:K3. Idéalement il ne devrait pas y avoir d’écriture ou seulement 0, je ne parvient pas à faire en sorte.

Merci par avance de votre aide.
Pièces jointes
ledebutant-2.ods
(13.68 Kio) Téléchargé 12 fois
Libreoffice 6.0.2.1 sur windows 10
ledébutant
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 15 Nov 2018 20:49


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 31 invité(s)