Page 1 sur 1

[Résolu] Trouver valeur dans une colonne

MessagePublié: 19 Mai 2019 17:40
par kamil12
Bonjour,

Cela fait plusieurs heures que je cherche sur les forums pour trouver une formule. Après plusieurs essais, je n'y arrive pas..

J'ai besoin d'une formule qui me permettrait de : Retrouver le contenu d'une cellule A1 de la Feuille1, sur une colonne A de la Feuille2, si ce contenu existe, alors copier le contenu de la cellule B1 de la Feuille 2 sur la cellule B1 de la Feuille1.

Je sais ca a l'air un peu compliqué.. n'hésitez pas si vous avez besoin de plus d'explications..

Merci d'avance de votre aide !!

Re: Trouver valeur dans une colonne

MessagePublié: 19 Mai 2019 17:47
par micmac
Bonjour et bienvenue sur le forum,
Dans votre signature il y a écrit: open office 4.0.1
Votre signature est incomplète et fait mention d'une version de OpenOffice qui n'est plus maintenue.
Est-ce une erreur, un oubli, un choix, une obligation ?
Dans ce dernier cas, mentionnez-le dans votre signature par Obligation de version.

Pour connaître la version que vous possédez : viewtopic.php?p=11582#p11582

Afin de profiter des dernières améliorations, il est fortement recommandé d'être à jour de la dernière version AOO 4.1.6.

Dans votre signature il est nécessaire d'indiquer :
1- La version exacte de AOO ou LibO (AOO 4.1.6, LibO 6.0.7 par exemple) ;
2- La version exacte du système d'exploitation (Windows XP SP3, Vista SP2, Windows 7 SP1, Win 8.1, Win 10, Ubuntu 18.04, MacOS 10.14.4 par exemple).
Accès direct à votre signature pour la corriger.

Cordialement.

Re: Trouver valeur dans une colonne

MessagePublié: 19 Mai 2019 18:51
par OOotremer971
Bonjour,

Pour éclaircir un peu, est-ce que tu peux joindre un fichier exemple stp ? Merci

Re: Trouver valeur dans une colonne

MessagePublié: 19 Mai 2019 19:06
par kamil12
Bonjour,

Ci joint deux images qui j'espère pourront vous éclairer !

Merci

Re: Trouver valeur dans une colonne

MessagePublié: 19 Mai 2019 19:19
par micmac
Votre signature n'est toujours pas complète.
Merci d'y remédier sans délai.

Re: Trouver valeur dans une colonne

MessagePublié: 19 Mai 2019 20:28
par OOotremer971
Pour rappel, ce forum n'a pas vocation à faire les devoirs des élèves ou stagiaires.
Tu devrais orienter tes recherches en direction de la fonction RECHERCHEV(). Note bien la présence du V à la fin de recherche. Elle permet de rechercher verticalement une valeur et de retourner le contenu des colonnes adjacentes à droite trouvées sur la même ligne
Apparemment tu te fiches des recommandations du modérateur :bravo:


A+

Re: Trouver valeur dans une colonne

MessagePublié: 19 Mai 2019 20:59
par njhub
Bonjour kamil12,

Essayez les formules ci-dessous
LOCalc
Code : Tout sélectionner   AgrandirRéduire
=INDIRECT("Feuille2.B"&EQUIV(A1;Feuille2.A:A;0);1)

Code : Tout sélectionner   AgrandirRéduire
=RECHERCHEV(A1;Feuille2.A:Feuille2.B;2;0)

OOCalc @OOotremer971 :wink:
Code : Tout sélectionner   AgrandirRéduire
=INDIRECT("Feuille2.B"&EQUIV(A1;Feuille2.A1:A10000;0);1)

Code : Tout sélectionner   AgrandirRéduire
=RECHERCHEV(A1;Feuille2.A1:Feuille2.B10000;2;0)

Re: Trouver valeur dans une colonne

MessagePublié: 19 Mai 2019 22:57
par kamil12
Bonjour,

J'y suis arrivé avec la formule VLOOKUP ou RECHERCHEV, merci beaucoup !!

Juste pour information, OOotremer971, C'est pour mon entreprise que je fais ca.

Merci encore