[Résolu] insérez un resultat dans un tableau

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] insérez un resultat dans un tableau

Messagepar Lythande » 04 Mai 2019 10:15

Bonjour tout le monde,
exemple 1.ods
(11.86 Kio) Téléchargé 20 fois


voici un modèle de ce que je cherche à faire.
je tire un nombre aléatoire de pots (cases en jaunes) que je veux renvoyez dans la case total (cases en orange) de la couleur adéquate en faisant s'additionner d'éventuel doublon.

habituellement j'utiliserai la fonction si imbriqué mais j'ai 130 couleurs dans mon tableau et çà bloque.
j'ai cherché avec equiv, mais çà coince aussi au niveau de l'addition des doublons.

bref, après une nuit blanche, je ne suis plus très frais et je suis coincé pour l'instant.
ne faites pas forcement la formule, mais si quelqu'un pouvais me dire dans quelle direction chercher et/où quelle fonction utilisé pour résoudre mon problème, ma dead ligne pour ce projet approche et j'aimerais éviter la perte de temps d'explorer des voies sans issue.

merci à vous, pour ce formidable forum.
Dernière édition par micmac le 01 Juin 2019 08:15, édité 1 fois.
Raison: Balisage
Libre office Version: 6.0.7.3 (x64) sur windows 10
Lythande
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 18 Mars 2019 08:58

Re: insérez un resultat dans un tableau

Messagepar DLE » 04 Mai 2019 11:05

Bonjour,

SOMMEPROD devrait faire l'affaire.

A+
AOO 4.1.7 et Libreoffice 6.2.8.2 sous Windows 10 64 bits, FireFox, Thunderbird, ORB 1.2.1
Avatar de l’utilisateur
DLE
SuppOOrter
SuppOOrter
 
Message(s) : 1226
Inscrit le : 30 Déc 2007 19:56
Localisation : Lille

Re: insérez un resultat dans un tableau

Messagepar Lythande » 04 Mai 2019 11:47

merci, je vais faire un somme et je m'y attèle demain
Libre office Version: 6.0.7.3 (x64) sur windows 10
Lythande
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 18 Mars 2019 08:58

Re: insérez un resultat dans un tableau

Messagepar Jean-Louis Cadeillan » 04 Mai 2019 12:11

Bonjour (euh Bonne nuit !)
Ci-joint la solution préconisée par DLE (que je salue :wink: ), ici en D17 :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD($B$5:$B$10=B17;$D$5:$D$10)
et une autre basée sur SOMME.SI(), ici en E17 :
Code : Tout sélectionner   AgrandirRéduire
=SOMME.SI($B$5:$B$10;B17;$D$5:$D$10)
Cordialement,
Jean-Louis
Pièces jointes
Lythande_20190504_JLC01.ods
(14.02 Kio) Téléchargé 17 fois
LibO 6.2.8.2 (x64 avec Java 1.8.0_231) et AOO 4.1.6 (avec Java x32 1.8.0_201), Windows 7 Édition Intégrale 64 SP1, (Domicile)
LibO 5.4.1.2 (x86) sous Ubuntu LTS 16.04.1, noyau 4.4.0-93 et Xfce 4.12, Java (x86) 1.8.0_131 (Travail) [obligation de version]
Avatar de l’utilisateur
Jean-Louis Cadeillan
ManitOOu
ManitOOu
 
Message(s) : 4588
Inscrit le : 03 Jan 2009 00:56

Re: insérez un resultat dans un tableau

Messagepar micmac » 01 Juin 2019 08:15

Dernière visite de l'intéressé(e) le : 24 Mai 2019 03:42
N'ayant plus de nouvelles, on peut en déduire que le problème est résolu ou ne se reproduit plus.

Merci de baliser par vous-même la prochaine fois.
Un remerciement fait aussi plaisir aux bénévoles qui vous ont consacré de leur temps..
Les formats ouverts (ODF) assurent la pérennité de vos documents.
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 6307
Inscrit le : 28 Août 2010 09:45

Re: [Résolu] insérez un resultat dans un tableau

Messagepar Lythande » 10 Juin 2019 02:54

désolé de mon délai de réponse, un gros pépin de santé m'a éloigné de chez moi.
merci à tous pour vos solutions

bonne continuation à tous.
Libre office Version: 6.0.7.3 (x64) sur windows 10
Lythande
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 14
Inscrit le : 18 Mars 2019 08:58


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 29 invité(s)