[Résolu] Selection de valeur dans le calcul automatique

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Selection de valeur dans le calcul automatique

Messagepar Lebleu06 » 04 Mai 2019 02:20

Bonjour à tous, je suis un nouveau sur openoffice j'ai enfin sauté le pas dans le monde du open source :D
J'ai du coup, quelques soucis sur OpenOffice dont un qui m'est très handicapant:
Lorsque je veux utiliser la fonction de calcul automatique (en maintenant le clique et en glissant ma souris vers la droite ) pour calculer ma formule
Code : Tout sélectionner   AgrandirRéduire
"=B3*$Calcule.B1"

Ma formule se met automatiquement à jour de la façon suivante
Code : Tout sélectionner   AgrandirRéduire
"=C3*$Calcule.C1"

Hors, j'aimerai pourvoir utiliser la fonction de calcule automatique, mais seulement en modifiant la première valeur, de la sorte
Code : Tout sélectionner   AgrandirRéduire
"=B3*$Calcule.B1" / "=C3*$Calcule.B1" / "=D3*$Calcule.B1" / "=E3*$Calcule.B1" / "=F3*$Calcule.B1"

Car la case B1de ma feuille de calcule "Calcule" contient un coefficient que ne souhaite pas modifier

Comment puis je résoudre ce problème ? Merci d'avance pour votre aide et votre bienveillance qui n'est propre que dans le monde du libre ! :bravo: :bravo: :bravo:
OpenOffice 4.1.6 sous windows 10
Lebleu06
Fraîchement OOthentifié
 
Message(s) : 1
Inscrit le : 04 Mai 2019 02:01

Re: Selection de valur dans le calcul automatique

Messagepar OOotremer971 » 04 Mai 2019 02:38

Bonjour,

Pour figer un nom de colonne ou un numéro de ligne, il faut le faire précéder du caractère $ par exemple :
Code : Tout sélectionner   AgrandirRéduire
=B3*$Calcule.$B1


N'hésite pas à te servir en premier lieu de l'aide intégrée à AOO (touche de fonction F1). Elle est riche d'informations élémentaires et approfondies.

Voilà ce qu'elle dit au sujet des références relatives et absolues :
Adresses et références : absolues et relatives

Adressage relatif

A1 désigne la colonne A et la ligne 1. Pour désigner une plage de cellules voisines, indiquez la cellule occupant le coin supérieur gauche de la plage suivi de deux-points, puis de la cellule occupant le coin inférieur droit de la plage. Le rectangle contenant les quatre premières cellules (coin supérieur gauche) est ainsi désigné par A1:B2.
Dans le cas de ce type d'adressage d'une plage, à savoir la référence A1:B2, on parle de référence relative. Le terme "relatif" signifie que la référence à la plage est adaptée dès que vous copiez les formules.

Adressage absolu

En opposition à l'adressage relatif, on rencontre la référence absolue, de type $A$1:$B$2. Le symbole du dollar est ici antéposé à chaque indication devant être considérée comme absolue.
OpenOffice est capable de convertir la référence actuelle (dans laquelle le curseur est placé dans la ligne de saisie) de relative en absolue et vice versa : il suffit d'appuyer sur Maj+F4. Admettons une adresse relative commençant par A1 : la première fois que vous appuyez sur ces deux touches, ligne et colonne deviennent absolues ($A$1) ; la seconde fois, seule la ligne devient absolue (A$1) ; la troisième fois, uniquement la colonne ($A1), et une quatrième action rend la référence relative dans les deux sens (A1)
OpenOffice Calc affiche clairement les références d'une formule. Si vous cliquez sur la formule =SOMME(A1:C5;D15:D24) dans une cellule, les deux plages référencées dans la feuille de calcul sont mises en évidence par des couleurs. L'élément "A1:C5" de la formule peut par ex. être affiché en bleu et la plage de cellules concernée est encadrée de la même couleur. L'élément suivant "D15:D24" peut être marqué de la même façon, mais en rouge.

Utilisation des références relatives et des références absolues

Caractéristiques d'une référence relative. Supposons que vous vouliez calculer dans la cellule E1 la somme des cellules de la plage A1:B2. La formule à saisir dans E1 serait alors : =SOMME(A1:B2). Vous décidez ensuite d'insérer une nouvelle colonne avant la colonne A. Les éléments que vous souhaitez ajouter se trouvent maintenant dans B1:C2 et la formule ne figure plus dans E1, mais dans F1. Après insertion de la nouvelle colonne, vous devriez donc vérifier et corriger toutes les formules contenues dans la feuille (et éventuellement dans d'autres feuilles).
Heureusement, OpenOffice assure automatiquement cette tâche. Dès que la nouvelle colonne A est insérée, la formule =SOMME(A1:B2) se met à jour automatiquement pour devenir =SOMME(B1:C2). Les numéros de ligne se mettent également à jour automatiquement lorsque vous insérez une nouvelle ligne 1. OpenOffice Calc adapte toujours les références absolues et relatives lorsque la zone référencée est déplacée. Cependant, vous devez procéder avec soin lorsque vous copiez une formule, car dans un tel cas les références relatives sont adaptées, mais non les références absolues.
Les références absolues sont utilisées lorsqu'un calcul fait référence à une cellule spécifique de la feuille. Si une formule faisant référence à cette cellule est copiée relativement à une cellule située sous la cellule d'origine, la référence est également déplacée vers le bas si vous n'avez pas défini comme "absolues" les coordonnées de la cellule.
Les références peuvent changer, non seulement lors de l'insertion de nouvelles colonnes ou lignes, mais aussi lorsqu'une formule faisant référence à des cellules particulières est copiée dans une autre zone de la feuille. Prenons l'exemple d'une formule, =SOMME(A1:A9), saisie sur la ligne 10. Si vous souhaitez calculer la somme pour la colonne adjacente de droite, il vous suffit de copier la formule dans la cellule de droite. La copie de la formule dans la colonne B est automatiquement adaptée et devient =SOMME(B1:B9).
En principe, toujours à jour des dernières versions dites stables
AOO
LibreOffice
Ubuntu
OpenSuse Leap
Avatar de l’utilisateur
OOotremer971
HédOOniste
HédOOniste
 
Message(s) : 2011
Inscrit le : 16 Avr 2010 14:31


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot] et 12 invité(s)