[Résolu] J'ai l'Aperçu qui n'y voit pas bien

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] J'ai l'Aperçu qui n'y voit pas bien

Messagepar atd » 05 Mars 2006 08:39

Bonjour

Je suis entrain de faire passer un classeur xls vers calc.

Il s'agit d'un planning fait maison comprenant une trentaine d'onglets dont les 12 premiers représentent les 12 mois de l'année.

Je suis arrivé à peu près à tout remettre dans l'ordre mais je bute sur un problème que je n'arrive pas à comprendre.

Les recherches effectuées sur forum ne m'ayant pas permis de trouver un sujet approchant, je pose donc ma question.

Je suis par exemple sur le 1er onglet (représentant le mois de janvier), je clique sur le bouton Aperçu avant impression et là j'obtiens bien l'aperçu du mois de janvier. Si je vais sur l'onglet 2, j'ai bien l'aperçu de février mais arrivant sur l'onglet 3 cette fois j'obtiens l'aperçu du mois de mai :shock:. Si je vais sur l'onglet 4, j'ai également l'aperçu du mois de Mai. Ensuite, si je me trompe pas (car je n'ai pas le fichier ici chez moi) l'aperçu pour les onglets suivants passent au mois de septembre et cet aperçu redevient conforme à partir de l'onglet 10 soit octobre.

Si quelqu'un a une explication, je suis preneur.

Merci.
OOo 2.0.2 + Win SP2
Avatar de l’utilisateur
atd
Membre lOOyal
Membre lOOyal
 
Message(s) : 34
Inscrit le : 14 Déc 2005 10:51

Aperçu

Messagepar Michel JANZEF » 05 Mars 2006 13:17

Bonjour
J'ai déjà vu le problème. Celà vient du fait que des zones d'impression sont définies.
Domicile :
1- AOo 4.1.6 et LibO 6.2.6.2 (x64) - Windows 10 Famille 1903 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Bureau : LibO 5.1.2.2 (imposée) sous Linux Ubuntu 16.04
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 2006
Inscrit le : 12 Jan 2006 11:04

Messagepar atd » 05 Mars 2006 16:48

Re

Merci pour le tuyau car franchement je serai jamais allé chercher de ce côté là :shock:

Dés demain, je vérifie et vous tiens au courant.

Merci.
OOo 2.0.2 + Win SP2
Avatar de l’utilisateur
atd
Membre lOOyal
Membre lOOyal
 
Message(s) : 34
Inscrit le : 14 Déc 2005 10:51

Messagepar atd » 06 Mars 2006 21:11

Bonsoir

Comme promis, je viens donc donner le résultat des courses.

Il y avait bien des zones d'impression qui étaient définies dans les feuilles de janvier, février puis mai et enfin septembre et octobre.

J'en déduis donc que lorsque des zones d'impression sont définies dans certaines feuilles, les aperçus avant impression ne vont que sur ces feuilles.

Bon admettons mais maintenant je rencontre un autre souci.

En effet j'ai donc supprimé toutes les zones d'impression de toutes les feuilles qui en étaient pourvues mais maintenant lorsque je fais un aperçu avant impression, il n'y a plus d'aperçu :shock: :shock: :shock:

Pourtant j'ai fait un classeur vite fait avec 3 feuilles et bien qu'aucune zone d'impression ne soit définie, l'aperçu avant impression fonctionne parfaitement sur ce classeur.

Si vous aviez une explication ou une direction dans laquelle il faudrait aller.

Merci.
OOo 2.0.2 + Win SP2
Avatar de l’utilisateur
atd
Membre lOOyal
Membre lOOyal
 
Message(s) : 34
Inscrit le : 14 Déc 2005 10:51

Messagepar Gaillette » 07 Mars 2006 08:54

J'avais déjà rencontré le problème en OOo 1.1.4. Apparemment, la gestion de l'aperçu n'a pas évolué (Soit on définit les zones à imprimer et dans ce cas là, tout ce qui est en dehors n'est pas imprimé, soit on ne définit rien et tout est imprimé : est-ce mieuxqu'avec la concurence payante ?)

As-tu sélectionné toutes les feuilles du classeur en même temps, puis supprimer les zones d'impressions?
Je viens de faire un essai, cela fonctionne sous 2.0.1 à condition qu'il y ait du contenu dans les feuilles. Si tes feuilles sont vierges, elles n'apparaissent pas dans l'aperçu
Il n'y a point de soleil pour les aveugles, ni de tonnerre pour les sourds,
S'ils ne veulent pas croire les autres.
OOo 2.3.1 sous Kubuntu et encore un peu Win XP SP2
Gaillette
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 16
Inscrit le : 23 Jan 2006 10:03

Messagepar atd » 07 Mars 2006 21:23

As-tu sélectionné toutes les feuilles du classeur en même temps, puis supprimer les zones d'impressions?

Non je les ai supprimées feuille après feuille.

Je viens de faire un essai, cela fonctionne sous 2.0.1 à condition qu'il y ait du contenu dans les feuilles.

Ok toujours bon à savoir.

Si tes feuilles sont vierges, elles n'apparaissent pas dans l'aperçu

Dans ce cas là, je dirai que c'est tout à fait normal car il n'y a rien à imprimer (d'ailleurs xls réagit de la même façon).

Mais pour ce qui me concerne toutes les feuilles sont remplies de données et même bien remplies mais rien n'apparaît dans l'aperçu :(
OOo 2.0.2 + Win SP2
Avatar de l’utilisateur
atd
Membre lOOyal
Membre lOOyal
 
Message(s) : 34
Inscrit le : 14 Déc 2005 10:51

Messagepar Michel JANZEF » 07 Mars 2006 21:30

Recréez les zones d'impression pour chaque feuille
ou
Créez un nouveau classeur dans lequel vous copiez les données du classeur en cause (mais ne déplacez pas ou ne copiez pas les feuilles ; uniquement les données)
Domicile :
1- AOo 4.1.6 et LibO 6.2.6.2 (x64) - Windows 10 Famille 1903 64 bits
2- AOo 4.0.1 et LibO 4.1.5.3 sous Windows XP Familiale SP3
Bureau : LibO 5.1.2.2 (imposée) sous Linux Ubuntu 16.04
Avatar de l’utilisateur
Michel JANZEF
HédOOniste
HédOOniste
 
Message(s) : 2006
Inscrit le : 12 Jan 2006 11:04

Messagepar Pyanepsion » 14 Mars 2006 13:03

Bien compliqué tout ça. Existe-il un réglage pour que l'aperçu et l'impression n'affiche que la feuille en cours, comme le fait Excel, sans afficher toutes les autres feuilles?
Window XP. Excel 2000. Works suite 2003. Open Office. Java Sun. Maxthon. Le tout mis à jour sur les nouvelles versions françaises dès qu'elles sont disponibles.
Avatar de l’utilisateur
Pyanepsion
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 191
Inscrit le : 11 Mars 2006 08:53

Messagepar Dude » 14 Mars 2006 16:25

Pyanepsion a écrit:Existe-il un réglage pour que l'aperçu et l'impression n'affiche que la feuille en cours, comme le fait Excel, sans afficher toutes les autres feuilles?


Menu Outils / Options -> Calc / Impression et une case à cocher.
AOO 4.1.6 sous Windows 7 Pro x64

Poser une question, c'est bien. Répondre aux autres, c'est encore mieux.
Améliorez AOO et votez pour les issues
Avatar de l’utilisateur
Dude
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 20872
Inscrit le : 03 Mars 2006 08:45
Localisation : 127.0.0.1

Messagepar Pyanepsion » 14 Mars 2006 17:06

Tout simplement ! :lol:

Reste le texte d'entête et de bas de page, ainsi que l'orientation et les marges,... : tout cela est dans le menu Édition/Page et semble plus performant que Excel. Une très bonne chose.

Merci Dude. :)
Window XP. Excel 2000. Works suite 2003. Open Office. Java Sun. Maxthon. Le tout mis à jour sur les nouvelles versions françaises dès qu'elles sont disponibles.
Avatar de l’utilisateur
Pyanepsion
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 191
Inscrit le : 11 Mars 2006 08:53


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 7 invité(s)