[Résolu] Cellule vide = nulle

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Cellule vide = nulle

Messagepar sebast76 » 18 Août 2018 21:36

Bonjour, voici mon problème

Sur mon fichier de résultats de matchs, je veux que le noms des 2 joueurs soient affiché comme dans le fichier joint en cas de match nul

Le souci c'est que leurs noms sont affichés alors que le match n'a pas encore été joué

Je voudrais que les noms s'affiche que lorsqu'il y a un résultat nul

En gros que la cellule vide soit considéré comme nulle en non 0

Merci pour votre aide


Sans nom 1.ods
Resultats
(8.43 Kio) Téléchargé 6 fois
Dernière édition par toucan le 18 Août 2018 23:49, édité 1 fois.
Raison: Ajout de la balise [Résolu]
Open Office 4.1.5
Windows 10
sebast76
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 18 Août 2018 21:23

Re: Cellule vide = nulle

Messagepar OOotremer971 » 18 Août 2018 22:12

Bonjour,

Sous réserve de bien avoir compris
En F1 :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(B1=C1;ESTNUM(B1));A1;"")

En G1 :
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(B1=C1;ESTNUM(C1));D1;"")

en plus de tester l'égalité, on teste aussi le contenu pour s'assurer qu'il est numérique avec la fonction ESTNUM(). Cela permet d'écarter le cas de cellules vides.

@+
En principe, toujours à jour des dernières versions
(Sous Linux)
Avatar de l’utilisateur
OOotremer971
HédOOniste
HédOOniste
 
Message(s) : 1708
Inscrit le : 16 Avr 2010 14:31

Re: Cellule vide = nulle

Messagepar sebast76 » 18 Août 2018 22:20

Parfait, c'est exactement le résultat recherché

Merci beaucoup pour ton aide :super:
Open Office 4.1.5
Windows 10
sebast76
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 18 Août 2018 21:23

Re: Cellule vide = nulle

Messagepar toucan » 18 Août 2018 23:47

Bonsoir et bienvenue,

Il semble que votre question ait trouvé une solution. Il faut alors ajouter dans le titre du premier message la balise [Résolu]. Ceci augmente la lisibilité du forum. Vous vous en êtes sûrement rendu compte en parcourant les différents fils de discussion.

Nous l'avons fait à votre place mais la prochaine fois, nous vous prions de le faire.

Merci de respecter la syntaxe [Résolu] : entre crochets, avec un R majuscule et un é. Cette balise est à placer au début du titre. Il faut également cocher la case de l'icône de sujet (le V vert).

Suivez ce sujet pour savoir comment procéder : https://forum.openoffice.org/fr/forum/ftopic3299.html

Merci de votre collaboration pour nous faciliter le travail de modération de ce forum.

Si nous avons fait une erreur, il vous suffit d'enlever de la même manière la balise. Il vous faudra bien sûr donner suite aux réponses proposées.
toucan
MOOdérateur
MOOdérateur
 
Message(s) : 175
Inscrit le : 23 Fév 2016 00:49


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot], jeanmimi et 22 invité(s)