[Résolu] Fonctions SI, ET et OU imbriquées

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Fonctions SI, ET et OU imbriquées

Messagepar Vachelin » 06 Août 2018 20:02

Bonjour,
Je cherche à me faire un cahier de caisse sur calc, et j'aimerais que le prix unitaire d'un produit s'affiche automatiquement quand je rentre le nom du produit. Sachant que le prix du produit peut être différent selon où il est vendu.
Capture d’écran (47).png

Après quelques recherches, j'ai essayé de faire ceci:
Code : Tout sélectionner   AgrandirRéduire
=SI(ET(A3=b;C3=yaourt);2,5;SI(ET(A3=OU(a;"");C3=yaourt);2,3;SI(C3=consignes;0,5;SI(ET(A3=b;C3=brousse);14,5;SI(ET(A3=OU(a;"");C3=brousse);14;SI(ET(A3=b;C3=pm);5,5;SI(ET(A3=OU(a;"");C3=pm);5;SI(ET(A3=b;C3=tomme);24,3;SI(ET(A3=OU(a;"");C3=tomme);23;SI(C3=lait;2;SI(ET(A3=a;C3=placedemarché);3,5)))))))))))

Mais ça ne fonctionne pas...
Quelqu'un verrait-il une erreur? Ou tout est peut-être bon à jeter, je suis néophyte...
Bonne soirée,
Dernière édition par micmac le 07 Août 2018 14:54, édité 3 fois.
Raison: [Résolu] remplace [RESOLU]+ ajout de la coche verte
Libreoffice 5.4.7.2 sous Windows 10
Vachelin
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 06 Août 2018 19:28

Re: Fonctions SI, ET et OU imbriquées

Messagepar DLE » 07 Août 2018 08:31

Bonjour et bienvenue sur le forum,

Dans votre formule vous devez mettre entre double quote ( " ) les valeurs à tester et non entre ( ' ) ex. SI(A3="B".....

Dans le fichier joint une fonction SI teste si colonne "A" = A ou B puis fait une recherche verticale (RECHERCHEV) dans la plage $I$3:$K$9, l'indice de déplacement dépendant de la valeur de colonne A.
Si la colonne "A" est vide, le marché "A" sera pris par défaut.

Bonne journée.

P.S. modifier votre signature vous utilisez une version LibreOffice et non OpenOffice
Pièces jointes
Vachelin_Caisse_V1.ods
(10.79 Kio) Téléchargé 6 fois
AOO 4.1.5 sous Windows 10 64 bits, FireFox, Thunderbird, ORB 1.2.1
Avatar de l’utilisateur
DLE
SuppOOrter
SuppOOrter
 
Message(s) : 1157
Inscrit le : 30 Déc 2007 19:56
Localisation : Lille

Re: Fonctions SI, ET et OU imbriquées

Messagepar Vachelin » 07 Août 2018 14:26

Bonjour,
Merci beaucoup pour votre réponse rapide et efficace! La fonction recherchev est plus simple. J'ai encore beaucoup à apprendre!
Bonne journée.
Libreoffice 5.4.7.2 sous Windows 10
Vachelin
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 06 Août 2018 19:28


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : OOotremer971 et 20 invité(s)