[Résolu] Compter nombre stagiaires en fonction du code stage

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Compter nombre stagiaires en fonction du code stage

Messagepar lucno » 02 Août 2018 10:53

Bonjour,

Je sais que la fonction Sommeprod() le fait très bien pour une plage de référence fixe, mais je voudrais compter mes stagiaires avec une plage de référence qui évolue. C'est à dire qu'a chaque inscription de stagiaire, j'insère une nouvelle ligne où je rappelle le code stage, je renseigne le nom et si il est stagiaire ou autres.

Je joins un fichier pour expliciter ma demande.

Merci d'avance pour l'aide que vous pouvez m'apporter

Luc

Sur cet ordinateur j'utilise LibreOffice V 4.1.3.2 avec XP (je n'ai pas la possibilité de changer de version)
Pièces jointes
Test Sommeprod().ods
(10.82 Kio) Téléchargé 7 fois
Dernière édition par micmac le 03 Août 2018 10:23, édité 1 fois.
Raison: Balisage et adaptation de la longueur du titre
LibreOffice Version: 5.3.7.2 - Windows 10
lucno
Membre lOOyal
Membre lOOyal
 
Message(s) : 32
Inscrit le : 15 Déc 2009 23:16

Re: Compter un nombre de stagiaires en fonction du code stag

Messagepar Hubert Lambert » 02 Août 2018 13:50

Bonjour,

Le plus simple (me semble-t-il) : utiliser des plages nommées, par exemple "codes" et "profils". La référence de la plage sera adaptée à chaque insertion :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(codes=A4;profils="Stagiaire")

Astuce : pour que cela fonctionne même avec la dernière ligne, chaque plage nommée doit inclure la première ligne vide qui suit.
Cordialement.
Pièces jointes
Test Sommeprod().ods
(18.89 Kio) Téléchargé 6 fois
AOOo 4.1.2 sur Win7
AOOo 4.1.x sur Linux Mint
LibreOffice 5.x/6.x sur Linux Mint
--
| « Nos défauts devraient nous donner une qualité : l'indulgence pour les défauts des autres » (Rivarol)
Avatar de l’utilisateur
Hubert Lambert
InconditiOOnnel
InconditiOOnnel
 
Message(s) : 946
Inscrit le : 06 Avr 2016 08:26

Re: Compter un nombre de stagiaires en fonction du code stag

Messagepar Jean-Louis Cadeillan » 02 Août 2018 14:19

Bonjour,
De toute façon ton SOMMEPROD() filtre sur deux critères : le code et le profil, donc il n'y a aucun intérêt à créer une plage adaptée au code. Une formule (ici en D4) du style :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(A4:A$100=A4;B4:$B100="Stagiaire")
fait parfaitement l'affaire. On pourrait aussi utiliser en matriciel :
Code : Tout sélectionner   AgrandirRéduire
=SOMME((A4:A$100=A4)*(B4:B$100="Stagiaire"))
Le fait de prendre une notation absolue sur la fin de plage te permet de la recopier au début de chaque nouveau code en prospectant aussi loin dans tous les cas.
L'avantage d'une plage nommée, comme Hubert Lambert te le propose, est ici d'améliorer la visibilité et la maintenance.
Cordialement,
Jean-Louis
LibreOffice 6.1.1.2 (x64) et Apache OpenOffice 4.1.5, Windows 7 Édition Intégrale 64 SP1, Java (x64) 1.8.0_181 (Domicile)
LibreOffice 5.4.1.2 (x86) sous Linux Karoshi 5.0 (Ubuntu LTS 16.04.1, noyau 4.4.0-93) et Xfce 4.12, Java (x86) 1.8.0_131 (Travail)
Avatar de l’utilisateur
Jean-Louis Cadeillan
ManitOOu
ManitOOu
 
Message(s) : 3736
Inscrit le : 03 Jan 2009 00:56

Re: Compter un nombre de stagiaires en fonction du code stag

Messagepar lucno » 03 Août 2018 09:10

Bonjour,

Je suis toujours émerveillé par Vous, qui prenez du temps pour nous aider à progresser.

Encore merci

Luc
LibreOffice Version: 5.3.7.2 - Windows 10
lucno
Membre lOOyal
Membre lOOyal
 
Message(s) : 32
Inscrit le : 15 Déc 2009 23:16


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : njhub et 43 invité(s)