[Résolu] Somme de 2 colonnes de hauteurs différentes

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Somme de 2 colonnes de hauteurs différentes

Messagepar multipress » 02 Août 2018 05:33

Bonjour à tous,
nouvelle dans l'utilisation de Calc, j'aurais besoin de vos lumières.
Je dois dans la cellule h16 faire apparaître la somme des cellules h(2018) moins celles de d(2014) mais à mois équivalent c'est à dire la somme de janvier à juillet 2018 moins la somme de janvier à juillet 2014 puis lorsque août 2018 sera rempli la somme de janvier à août 2018 moins la somme de janvier à aout 2014 et ainsi de suite pour septembre, novembre ... Le but étant d'obtenir le nombre noté en h18 mais de manière automatique sans avoir à modifier la formule.
J'ai essayé plusieurs combinaisons avec NBVAL pour isoler le nombre de cellules mais rien ne fonctionne ?!?!
Si l'un d'entre vous à la solution, et si possible l'explication, je vous en serait infiniment reconnaissante.
Belle journée et merci d'avance pour vos retours
Virginie
Pièces jointes
CHIFFRE AFFAIRE MENSUEL.ods
(27.75 Kio) Téléchargé 5 fois
Dernière édition par multipress le 02 Août 2018 22:46, édité 2 fois.
La version installée est AOO4.1.5 sur Windows XP SP3
multipress
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 02 Août 2018 05:15

Re: SOMME DES 2 COLONNES DE HAUTEURS DIFFERENTES

Messagepar micmac » 02 Août 2018 06:34

Bonjour et bienvenue,

1_Les minuscules suffisent pour se faire entendre.
L'emploi des caractères en majuscules est assimilable sur internet à des hurlements.
Veuillez corriger le titre de votre premier message.

2_
votre signature a écrit:La version install??e est OpenOffice.org 3.3.0.
Windows XP Pro Version 2002 SP3
Votre signature indique une version de OpenOffice qui n'est plus maintenue.
Est-ce une erreur, un oubli, un choix, une obligation ?
Dans ce dernier cas, mentionnez-le dans votre signature par "Obligation de version".

Pour connaître la version que vous possédez : https://forum.openoffice.org/fr/forum/v ... 582#p11582

Afin de profiter des dernières améliorations, il est fortement recommandé d'être à jour de la dernière version

Dans votre signature il est nécessaire d'indiquer :
1- La version exacte de AOO ou LibO (AOO 4.1.5, LibO 5.4.7 par exemple) ;
2- La version exacte du système d'exploitation (Windows XP SP3, Vista SP2, Windows 7 SP1, Win 8.1, Win 10, Ubuntu 18.4, MacOS 10.13.6 par exemple).
Accès direct à votre signature pour la corriger.

3_ Le document joint est au format propriétaire fermé de MS Office.
Merci de joindre un document au format ODF (.ods).


Un rappel de nos : Conseils : Utilisation de Writer / Word applicables à Calc/Excel
Avatar de l’utilisateur
micmac
RespOOnsable forum
RespOOnsable forum
 
Message(s) : 5245
Inscrit le : 28 Août 2010 09:45

Re: SOMME DES 2 COLONNES DE HAUTEURS DIFFERENTES

Messagepar Jeff » 02 Août 2018 14:19

Bonjour,

Merci de suivre les recommandations du modérateur ;)

À tester :
Code : Tout sélectionner   AgrandirRéduire
=SOMME(H2:H13)-SOMMEPROD((NON(ESTVIDE(H2:H13))*(D2:D13)))


A +

 Ajout : Plutôt que de faire des sommes du type : 
Code : Tout sélectionner   AgrandirRéduire
=H2+H3+H4+H5+H6+H7+H8+H9+H10+H11+H12+H13

...mieux vaut utiliser la fonction SOMME :
Code : Tout sélectionner   AgrandirRéduire
=SOMME(H2:H13)


Plus lisible, plus simple :wink:
  
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.5 sur Xubuntu 16.04_i586 et sur Win 10 pro x64
Avatar de l’utilisateur
Jeff
GourOOu
GourOOu
 
Message(s) : 7717
Inscrit le : 18 Sep 2006 10:40
Localisation : France

[Résolu] Somme de 2 colonnes de hauteurs différentes

Messagepar multipress » 02 Août 2018 23:06

Bonjour
Merci à micmac pour ses rappels, j'espère n'avoir oublié aucune modification
Un immense MERCI à Jeff pour sa solution qui marche impeccablement (j'ai aussi modifié le calcul des sommes ;-), je ne suis pas sûre de tout comprendre mais j'ai le week-end pour approfondir.
Merci pour votre communauté de partage
Belle journée à tous et bon week-end
La version installée est AOO4.1.5 sur Windows XP SP3
multipress
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 02 Août 2018 05:15

Re: Somme de 2 colonnes de hauteurs différentes

Messagepar Jean-Louis Cadeillan » 03 Août 2018 01:03

Bonsoir,
multipress a écrit:j'ai le week-end pour approfondir
Quitte à creuser :marto:, quelques variantes :
  1. Code : Tout sélectionner   AgrandirRéduire
    =SOMME(H2:H13)-SOMME.SI(H2:H13;">0";D2:D13)
    Le critère ">0" pourrait être remplacé par "<>"&"" dans ce contexte.
  2. Code : Tout sélectionner   AgrandirRéduire
    =SOMMEPROD(H2:H13-D2:D13;H2:H13>0)
    Le critère >0 pourrait être remplacé par <>"" dans ce contexte.
  3. Code : Tout sélectionner   AgrandirRéduire
    =SOMME((H2:H13-D2:D13)*(H2:H13>0))
    Cette formule (en vert dans le fichier joint) est matricielle (à valider par Ctrl+Maj+Entrée).
  4. Code : Tout sélectionner   AgrandirRéduire
    =SOMME(H2:H13)-BDSOMME(B1:H13;3;K12:K13)
    Cette formule est un peu spéciale, elle fait appel à une fonction de base de données, BDSOMME() qui nécessite de stocker dans des cellules (ici K12:K13) les critères de choix (formule et critères en jaune dans le fichier joint), ce qui peut être intéressant quand on change souvent de critère.
Pour l'utilisation et la syntaxe des fonctions, voir l'aide intégrée (F1) ou en ligne (ici).
Cordialement,
Jean-Louis
Pièces jointes
multipress_20180802_JLC01.ods
(33.2 Kio) Téléchargé 4 fois
LibreOffice 6.1.1.2 (x64) et Apache OpenOffice 4.1.5, Windows 7 Édition Intégrale 64 SP1, Java (x64) 1.8.0_181 (Domicile)
LibreOffice 5.4.1.2 (x86) sous Linux Karoshi 5.0 (Ubuntu LTS 16.04.1, noyau 4.4.0-93) et Xfce 4.12, Java (x86) 1.8.0_131 (Travail)
Avatar de l’utilisateur
Jean-Louis Cadeillan
ManitOOu
ManitOOu
 
Message(s) : 3866
Inscrit le : 03 Jan 2009 00:56


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot] et 9 invité(s)