somme avec critère dans un liste

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

somme avec critère dans un liste

Messagepar speuak » 18 Juil 2018 08:23

Bonjour, je vais essayer d'être clair.
Pour ça je vais faire un exemple:

____A____!___B___!_____C
1362797__!___9___!__1364129
1364129__!___1___!__1310910
1310910__!___1___!
1348679__!__18___!
_________!___1___!
1365117__!___5___!

Je voudrais faire la somme des valeurs de la colonne B pour les valeurs de la colonne A différentes de la liste dans la colonne C et les vides =10.

Je vais avoir beaucoup de valeurs (env 500 en A et B et 50-75 en C)

Merci beaucoup !!
openoffice 4.0.1 ; Windows 7
speuak
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 15 Jan 2014 13:38

Re: somme avec critère dans un liste

Messagepar Jean-Louis Cadeillan » 18 Juil 2018 11:07

Bonjour,
speuak a écrit:pour les valeurs de la colonne A différentes de la liste dans la colonne C et les vides
Je ne suis pas sûr d'avoir bien compris, mais si le résultat à trouver est 10 dans ton exemple, je suppose que tu veux la somme des valeurs de B, uniquement si les valeurs correspondantes de C sont non vides et qu'elles diffèrent de celles de A. Dans ce cas une réponse pourrait être :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(B1:B6;A1:A6<>C1:C6;C1:C6<>"")
Cordialement,
Jean-Louis
LibreOffice 6.1.1.2 (x64) et Apache OpenOffice 4.1.5, Windows 7 Édition Intégrale 64 SP1, Java (x64) 1.8.0_181 (Domicile)
LibreOffice 5.4.1.2 (x86) sous Linux Karoshi 5.0 (Ubuntu LTS 16.04.1, noyau 4.4.0-93) et Xfce 4.12, Java (x86) 1.8.0_131 (Travail)
Avatar de l’utilisateur
Jean-Louis Cadeillan
ManitOOu
ManitOOu
 
Message(s) : 3736
Inscrit le : 03 Jan 2009 00:56

Re: somme avec critère dans un liste

Messagepar Xunor » 02 Août 2018 17:02

Bonjour,
Le plus simple est de rajouter une colonne ou tu met 0 si tu compte pas et la valeur de B si tu comptes.
Quitte à la cacher ;) puis tu fais simplement la somme sur cette nouvelle colonne.
Si non tu fais une petite macro.
Programmeur relativement expérimenté (on n'est jamais expert ;) )
Débutant Open Office (adieu Microsoft et ses incompatibilités)
principalement avec Apache OpenOffice 4.1.2 sous Windows 10 Famille
Xunor
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 12
Inscrit le : 02 Août 2018 12:02

Re: somme avec critère dans un liste

Messagepar Jeff » 02 Août 2018 17:28

Bonjour à tous,

Jean-Louis Cadeillan a écrit:Je ne suis pas sûr d'avoir bien compris
+ 1, pas sûr d’avoir tout compris également :?

speuak a écrit:et les vides =10

Les vides où ? Colonne A ? Ça vaut 10 ou B x 10 ?

De ce que j’ai compris, on cherche 43 :

speuak.png
Cliquer sur l’image pour zoomer


A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.5 sur Xubuntu 16.04_i586 et sur Win 10 pro x64
Avatar de l’utilisateur
Jeff
GourOOu
GourOOu
 
Message(s) : 7652
Inscrit le : 18 Sep 2006 10:40
Localisation : France


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot] et 18 invité(s)