[Résolu]Nombre de dimanches

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu]Nombre de dimanches

Messagepar thibdb13 » 13 Juin 2007 12:56

Bonjour,

j'aurais besoin de calculer le nombre de fois qu'un jour donné apparaît entre deux dates, dans le cas présent le nombre de dimanches apparaissant durant la période du 03/01/2007 au 18/05/2007.
J'avais d'abord pensé à calculer le nombre total de jours et à en soustraire le nombre de jours ouvrables mais le problème provient du fait que le samedi est, lui, considéré comme jour non ouvrable.

D'avance, merci
Dernière édition par thibdb13 le 13 Juin 2007 15:51, édité 2 fois.
2.1. Windows XP et 3.1.1 Archlinux
thibdb13
Membre lOOyal
Membre lOOyal
 
Message(s) : 41
Inscrit le : 25 Mai 2007 14:06

Messagepar Vandeput » 13 Juin 2007 13:25

Bonjour,

A1 : 03/01/07
B1 : 18/05/07

=SOMMEPROD((JOURSEM(LIGNE(INDIRECT(A1&":"&B1)))=1)*1)
Résultat : 19

=1 pour les dimanches, =2 pour les lundis, =3 pour les mardis, ...
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles

Messagepar thibdb13 » 13 Juin 2007 14:09

Merci
2.1. Windows XP et 3.1.1 Archlinux
thibdb13
Membre lOOyal
Membre lOOyal
 
Message(s) : 41
Inscrit le : 25 Mai 2007 14:06


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot] et 11 invité(s)