[Résolu] Syntaxe de SOMMEPROD(NBSI())

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Syntaxe de SOMMEPROD(NBSI())

Messagepar Vandeput » 12 Juin 2007 14:28

Bonjour,

A nouveau une formule qui fonctionnait sous Excel et dont la syntaxe n'est pas acceptée par Calc.

A1:A10 des valeurs alphabétiques
=SOMMPROD(NB.SI(A1:A10;{"oui";"non"}))
renvoie le nombre de fois que oui et non sont compris dans la plage.

Quelqu'un a-t-il une idée de la syntaxe à employer sous Calc ?

En dehors de l'addition de deux NB.SI, évidemment !
Dernière édition par Vandeput le 13 Juin 2007 06:10, édité 1 fois.
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles

Messagepar JMR 59126 » 12 Juin 2007 15:08

Bonjour

Peut être avec SOMME.SI ?
Openoffice 2.3.1 win xp, Openoffice 2.3.0 Ubuntu 7.10
JMR 59126
Membre cOOnfirmé
Membre cOOnfirmé
 
Message(s) : 234
Inscrit le : 08 Sep 2006 10:46
Localisation : 59 Lille

Messagepar vinc-mai » 12 Juin 2007 15:48

Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(NB.SI(A1:A10;B1:B2))

semble marcher B1 contient oui et B2 non.
(Ooo 2.3 sur windows XP)
OOo 2.3 sur Ubuntu 7.10
Avatar de l’utilisateur
vinc-mai
PassiOOnné
PassiOOnné
 
Message(s) : 540
Inscrit le : 22 Déc 2005 15:13
Localisation : Rhône-Alpes

Messagepar Vandeput » 12 Juin 2007 16:36

Bonjour vinc-mai,

Bien vu !
Cela fonctionne effectivement, et aussi sous Excel.
Merci.

Dommage toutefois qu'il faille (j'aime le subjonctif) deux cellules supplémentaires pour les conditions et qu'on ne puisse incorporer les conditions dans la formule.

Il ne me reste plus qu'à les modifier (pas une mince affaire !).
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles

Messagepar vinc-mai » 12 Juin 2007 16:48

Si çà marche sous excel aussi, tes classeur seront portables.

Une demande d'amélioration peut-être faîte. Je ne sais pas si c'est difficile à coder mais un amélioration de la portabilité est toujours intéressante.

Bon courage pour tes modifications.
(Ooo 2.3 sur windows XP)
OOo 2.3 sur Ubuntu 7.10
Avatar de l’utilisateur
vinc-mai
PassiOOnné
PassiOOnné
 
Message(s) : 540
Inscrit le : 22 Déc 2005 15:13
Localisation : Rhône-Alpes


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot] et 17 invité(s)