RECHERCHEV : Problème pour trouver un nom

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

RECHERCHEV : Problème pour trouver un nom

Messagepar vjbeng » 11 Juin 2007 17:35

salut,

je suis un newbie sur ooo mais j'essaie de changer..

J'ai défini une liste dans la feuille 2 de ce type :

IPE80 78
IPE100 125
IPE160 190
IPE200 400
.... ...

Et j'y fais appel depuis la feuille 1 comme ceci :

=RECHERCHEV(C5;profilés;2)

et cela fonctionne.

Mais lorsque j'ai agrandi ma "base de données" en rajoutant d'autres références (de profilés métalliques pour info) :

IPE80 78
IPE100 125
IPE160 190
IPE200 400
.... ...
HEA100 546
HEA140 684
HEA200 890

Et bien cela ne marche plus qu'a moitié, c'est a dire que lorsque je recherche IPE80, cela marche et tous les "IPE" cela marche, mais quand je tape "HEA140" cela retourne #NA

j'ai fait plusieurs essais, rien à faire

J'ai l'impression que je m'y prends mal pour rechercher des "noms", ce que veux, c'est rentrer exactement un nom au caractère près dans mon critère de recherche.

Merci de votre aide !
[/img]
windows Xp Sp2
OOO 2.03
vjbeng
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 11 Juin 2007 17:16

Messagepar Pierre-Yves Samyn » 11 Juin 2007 17:47

Bonjour

Deux aspects : le dernier paramètre (facultatif) de recherchev indique le "tri" cf. l'aide en ligne :
Tri est un paramètre facultatif indiquant si la première colonne de la matrice est triée par ordre croissant. Saisissez la valeur booléenne FAUX si la première colonne n'est pas triée par ordre croissant.

Concernant l'ajout de données à une plage, il te suffit de "prévoir large" quand tu définis le nom (profilés en l'occurrence) : inclure autant de lignes que d'ajouts prévisibles...

Enfin, tu peux aussi gérer l'affichage de #NA (not available, non disponible) par la fonction ESTNA (rechercher dans la section tableur du forum sur ce terme pour avoir des exemples)
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11276
Inscrit le : 02 Mai 2006 09:42

Messagepar Jeff » 11 Juin 2007 18:46

Bonjour,

Le mieux serait de joindre un bout de fichier test (Ci-Joint est en haut de page, n'oublie pas de copier/coller le lien donné dans ta réponse) afin que l'on puisse tester.

Tu as nommée ta liste Profilés ?

Tu as renommé ensuite cette même liste ???

Enfin bref, document ci-joint bienvenue :wink:

A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 18.04.1 x64 (Bionic Beaver), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8341
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Messagepar Jeff » 11 Juin 2007 19:22

Re...

Si tu as renommée ta plage complète de données en profilés, avec les conseils de Pierre-Yves, tu devrai arriver à la fonction suivante :

Code : Tout sélectionner   AgrandirRéduire
=RECHERCHEV(C5;profilés;2;0)


Pour vérifier si ta plage complète est bien nommée, sélectionne la puis regarde dans l'affichage de l'adresse de cellule (à gauche de la barre de fonction), ou bien contrôle ou redimensionne cette plage nommée par le menu Insertion->noms->définir

A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 18.04.1 x64 (Bionic Beaver), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8341
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Messagepar vjbeng » 11 Juin 2007 20:29

merci c'est résolu !

comme ma liste n'était pas classée par ordre alphabétique, je devais rajouter l'argument facultatif, ce que je n'avais pas fait...

avant

=RECHERCHEV(C5;profilés;2)

après

=RECHERCHEV(C5;profilés;2;0)

merci !
windows Xp Sp2
OOO 2.03
vjbeng
Fraîchement OOthentifié
 
Message(s) : 2
Inscrit le : 11 Juin 2007 17:16

Messagepar Jeff » 11 Juin 2007 21:15

Alors, merci de mettre la balise [Résolu] qui facilitera les futures recherches :arrow: Comment faire

A + :wink:
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 18.04.1 x64 (Bionic Beaver), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8341
Inscrit le : 18 Sep 2006 10:40
Localisation : France


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : jeanluck et 11 invité(s)