Calculer la moyenne d'une plage excepté quelques valeurs

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

Calculer la moyenne d'une plage excepté quelques valeurs

Messagepar tbassetto » 11 Juin 2007 15:10

Bonjour,

Je voudrais calculer la moyenne d'une plage contenant que des nombres or cette plage contient des valeurs textuelles de temps en temps (ces cellules contiennent en fait exactement : "Jamais eu").

J'ai essayé plusieurs formulaires mais j'y connais vraiment rien :oops:

Autre question : quelle ets la différence entre MOYENNE() et MOYENNE.ALGEBRIQUE() ?

Dernière question : J'ai essayé de répeter la formule disponible ici : http://user.services.openoffice.org/fr/ ... .html#1464 mais ça ne me l'affiche tel quel :
Code : Tout sélectionner   AgrandirRéduire
{=FREQUENCE(D2:D320;D342:D346)}

Pourquoi ?

Merci beaucoup.
OOo 3.0.0 sous Mac OS X 10.5.5
tbassetto
Fraîchement OOthentifié
 
Message(s) : 6
Inscrit le : 15 Mai 2007 14:22

Messagepar Pierre-Yves Samyn » 11 Juin 2007 15:22

Bonjour

Il est demandé de ne poser qu'une question par fil afin de simplifier les recherches ultérieures.

Donc pour la première question, la réponse dépend de ce que tu veux...
Si les données sont en A1:A12

Code : Tout sélectionner   AgrandirRéduire
=MOYENNE(A1:A12)


calcule la moyenne sans tenir compte des textes

Code : Tout sélectionner   AgrandirRéduire
=MOYENNEA(A1:A12)


fait intervenir les cellules de texte (pour zéro)
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11276
Inscrit le : 02 Mai 2006 09:42

Messagepar tbassetto » 11 Juin 2007 17:51

Désolé d'avoir posé plus de 3 questions mais je me voyais mal créer 3 sujets :?

Le problème avec MOYENNEA c'est que les 0 faussent la valeur de la moyenne justement :?
OOo 3.0.0 sous Mac OS X 10.5.5
tbassetto
Fraîchement OOthentifié
 
Message(s) : 6
Inscrit le : 15 Mai 2007 14:22

Messagepar Pierre-Yves Samyn » 11 Juin 2007 17:58

tbassetto a écrit:Désolé d'avoir posé plus de 3 questions mais je me voyais mal créer 3 sujets :?


Pas de problème mais Fréquence n'a rien à voir avec "calculer la moyenne excepté quelques valeurs"...

tbassetto a écrit:Le problème avec MOYENNEA c'est que les 0 faussent la valeur de la moyenne justement :?


Non MOYENNEA ne fausse pas le résultat puisque c'est son objet de compter les valeurs de texte comme zéro, ce qui n'est pas le cas de MOYENNE
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11276
Inscrit le : 02 Mai 2006 09:42


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 15 invité(s)