[Résolu] tri et recherche

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] tri et recherche

Messagepar elbarto » 08 Juin 2007 13:45

Bonjour à tous,

je me débrouille un peu en tableur mais je souhaite faire un "truc" spécial très simple à comprendre.

J'ai une colonne avec des noms puis une seconde représentant un test 1 avec des classements pour chaque nom. UN seconde colonne avec un test 2 et un nouveau classement.

Je souhaiterais mettre en dessous de chaque colonne de tests, le nom des 3 premiers pour chaque test.

ci-joins le doc sous calc
http://user.services.openoffice.org/fr/ci-joint/fichier/2007/06/08-024938.xls

J'ai éssayé avec différentes formule comme recherche ùais peut-être pas assez poussé.
J'essaye de trouver une solution sans macro si possible

Je vous remercie d'avance pour les réponses.

Nicolas
Dernière édition par elbarto le 08 Juin 2007 16:01, édité 1 fois.
Windows XP SP2 - openoffice.org 2.2.0
elbarto
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 08 Juin 2007 13:21

Messagepar Vandeput » 08 Juin 2007 14:48

Bonjour,

En B8 : =SI(NB.SI(B$2:B$6;LIGNE()-7)=0;"";INDEX($A$2:$A$6;EQUIV(LIGNE()-7;B$2:B$6;0)))
à copier vers le bas et vers la droite.

Problème de doublon en test3, que faut-il en faire ?
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles

Messagepar elbarto » 08 Juin 2007 14:58

Merci pour la supra-rapidité.
ça marche bien, je l'ai compris et je peux donc la modifier.

Il n'y a normalement pas de doublon ;-) c'est une erreur de ma part...

Encore merci
Windows XP SP2 - openoffice.org 2.2.0
elbarto
Fraîchement OOthentifié
 
Message(s) : 7
Inscrit le : 08 Juin 2007 13:21

Messagepar Vandeput » 08 Juin 2007 16:07

Heureux que ton problème soit résolu !

Puis-je te demander d'éditer ton message initial et de faire précéder le sujet de [Résolu] ?

Edition : là, vraiment, trop rapide !
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 21 invité(s)