[Résolu 50%] Autofiltre et mise à jour des données

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu 50%] Autofiltre et mise à jour des données

Messagepar Hagar Delest » 24 Fév 2006 12:18

Il semble que l'autofiltre gère bizarrement les plages de données :
- Si on a plusieurs ligne et que l'on applique l'autofiltre, pour la première fois, tout se passe bien.
- Si on ajoute des lignes en dessous de précédentes (sans ligne vide bien sûr) elles ne sont pas prises en compte par l'autofiltre.
- En revanche, si on sélectionne l'option Standard dans la liste déroulante de la tête de colonne, la valeur de l'autofiltre est conservée et là, les nouvelles lignes sont prises en compte. Il suffit d'ailleurs d'afficher les options supplémentaires de la fenêtre du filtre standard pour voir que la plage de données prend en compte les nouvelles lignes.

Pourquoi OOo ne met pas à jour automatiquement la plage de données de l'autofiltre ou encore pourquoi il donne une ligne limite ($A1:$B10 au lieu de $A:$B par exemple) ?
Dernière édition par Hagar Delest le 27 Fév 2006 11:40, édité 2 fois.
Désormais sur le forum anglophone avec une version Sun sur une xubuntu (maison) et Windows (boulot).
Avatar de l’utilisateur
Hagar Delest
SuppOOrter
SuppOOrter
 
Message(s) : 1467
Inscrit le : 01 Fév 2006 09:12

Messagepar sisyphi » 25 Fév 2006 20:25

Salut,

En effet, le comportement du filtre ne semble pas fonctionner correctement :

1/lorsque la liste contient des formules renvoyant des valeurs d'erreurs de type #NA.

J'ai effectué le test en comparant 2 listes de données avec la fonction RECHERCHEV. En positionnant un filtre sur la liste, la valeur #NA n'apparaît pas dans le filtre, on a un "blanc". Ce blanc est malgré tout sélectionnable...mais cela prête à confusion.

Avec une liste de ce type :

Résultat de le recherche
Liste 1
Liste 1
#NA
Liste 1

On a un filtre qui affiche :

-tout-
-Standard-
-Top 10-

Liste 1


2/le filtre affiche toujours toutes les types données présentes dans la colonne (sauf les valeurs d'erreurs). Cela pose problème lorsqu'on filtre sur plusieurs colonnes afin d"affiner une de recherche de valeurs. Par exemple si j'ai 2 colonnes (Forme en A et Couleur en B) alimentées ainsi :

Forme
Rond
Rond
Carré
Rond
Triangle
Triangle

Couleur
Jaune
Vert
Rouge
Jaune
Rouge
Bleu

Si on place un autofiltre dans ce tableau et que l'on filtre sur "Rond", dans la colonne "Forme", on obtient les valeurs Jaune, Vert Jaune. Si on poursuit le filtrage dans la colonne B, "Couleur", on a un filtre qui affiche :

-tout-
-Standard-
-Top 10-
Bleu
Jaune
Rouge
Vert

La liste ne devrait pas afficher "Rouge", puisque cette valeur n'existe pas pour le forme "Rond".

Ce comportement peut être assez gênant (voire trompeur) sur les tableaux comportant beaucoup de données. Le filtre devant fonctionner à la base comme une sorte de "tamis" à plusieurs niveaux.

En bref, le filtre de Calc n'est pas encore "intelligent".
OOo 2.0.1 Windows Me
sisyphi
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 17
Inscrit le : 09 Fév 2006 19:57

Messagepar Hagar Delest » 27 Fév 2006 08:50

Voici la parade, donnée par le site anglais :
Il faut définir la/les colonne(s) comme une "plage de données" (menu Données>Définir une plage). Les informations sont alors mises à jour en temps réel (même s'il y a des lignes vides à l'intérieur de la sélection, ce que ne sait pas gérer Excel).

Attention, il ne faut faire qu'une seule plage de données sinon seul le dernier autofiltre s'applique :
- Avec une seule plage pour 2 colonnes, on peut trier la première colonne suivant le critère A, puis la seconde selon le critère B. Les résultats seront ceux correspondant aux critères A ET B.
- Avec 2 plages de données (une pour chaque colonne), si on trie la première colonne selon le critère A puis que l'on trie la seconde selon le critère B, les résultats affichés sont ceux correspondant au critère B, y compris ceux que le filtre A avait fait disparaître ! NB: la flèche autofiltre sur l'en-tête de la première colonne reste trompeusement bleue.
Désormais sur le forum anglophone avec une version Sun sur une xubuntu (maison) et Windows (boulot).
Avatar de l’utilisateur
Hagar Delest
SuppOOrter
SuppOOrter
 
Message(s) : 1467
Inscrit le : 01 Fév 2006 09:12

Messagepar Hagar Delest » 27 Fév 2006 11:40

Petit bémol à la solution ci-dessus : avec une plage de données, l'application du tri ne permet plus d'ajouter des données à la suite des lignes triées.

Donc ça ne convient pas forcément à l'utilisation que l'on souhaite (filtre pour affichage seul ou filtre pour affichage et édition).
Désormais sur le forum anglophone avec une version Sun sur une xubuntu (maison) et Windows (boulot).
Avatar de l’utilisateur
Hagar Delest
SuppOOrter
SuppOOrter
 
Message(s) : 1467
Inscrit le : 01 Fév 2006 09:12


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 24 invité(s)