[Résolu]ormat cellule avec nombre et texte zéro significatif

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu]ormat cellule avec nombre et texte zéro significatif

Messagepar mog » 31 Mai 2007 11:41

bonjour,

sur la feuille mes données nombre sont formatées avec 2, 3, 4 ou 5 chiffres après la virgule.
par contre pour le résultat j'accole un élément texte qui lui aussi peut différer.

mon soucis est que, lors du résultat, les zéros significatifs ne sont pas affichés :

ma formule est :
=ARRONDI(AU8;NBCAR($H$3)-2)&" "&$H$1

avec AU8 = 1000.0198007
h3 = 0.002 donc nbcar(H3)-2 = 3
H1 = g

le résultat de cette formule est : 1000.02 g alors que je souhaite
1000.020 g

NB : si la valeur en AU est arrondie à 1000.021 là j'ai bien 1000.021 g, mais dès qu'il y a des zéros ils ne sont pas repris.

auriez-vous un avis ?

merci à vous
Dernière édition par mog le 26 Sep 2007 14:34, édité 1 fois.
openoffice 3.0 - windows XP SP2
mog
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 23
Inscrit le : 28 Fév 2007 15:14

Messagepar Pierre-Yves Samyn » 31 Mai 2007 11:59

Bonjour

Tu peux déjà utiliser la fonction Texte

Code : Tout sélectionner   AgrandirRéduire
=TEXTE(ARRONDI(AU8;NBCAR($H$3)-2);"###0.000")
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11276
Inscrit le : 02 Mai 2006 09:42

Messagepar mog » 31 Mai 2007 12:07

bonjour,

oui j'y ai bien pensé, mais la fonction m'oblige à définir à chaque fois le format de la cellule.
et en fait ce format est fonction de la valeur du nombre, il n'est pas définit une fois pour toute.

j'ai pensé également passer par un formatage conditionnel, mais je n'ai que 3 possibilité et je gère 6 formats différents !

merci
openoffice 3.0 - windows XP SP2
mog
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 23
Inscrit le : 28 Fév 2007 15:14

Messagepar Vandeput » 31 Mai 2007 12:11

Bonjour,

Il y a peut-être plus simple, mais celle-ci a l'air de fonctionner :
=TEXTE(AU8;"0."&REPT(0;NBCAR($H$3)-2))&" "&$H$1
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles

Messagepar jeanmimi » 31 Mai 2007 12:12

Bonjur,

Et en construisant 6 petites Macros correspondant à chaque formatage désiré ?
Ensuite, appelées à s'exécuter par un clique sur un Bouton ?
LibreOffice Version : Version : 7.0.1.2 (x64)(13 septembre 2020)
Adoptopen JRE ou Oracle JRE (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 15459
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Messagepar mog » 31 Mai 2007 12:43

bonjour

oui apparemment cette formule fonctionne, merci beaucoup
mais help , je n'arrive pas à la comprendre !! - j'y retourne immédiatement

concernant les macros, je ne souhaite pas m'y lancer !

merci
openoffice 3.0 - windows XP SP2
mog
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 23
Inscrit le : 28 Fév 2007 15:14

Messagepar mog » 31 Mai 2007 12:55

bonjour,

j'ai trouvé également cette formule :

CTXT(AU8;NBCAR($H$3)-2)&" "&$H$1

à confirmer sur mes feuilles de travail
openoffice 3.0 - windows XP SP2
mog
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 23
Inscrit le : 28 Fév 2007 15:14

Messagepar Vandeput » 31 Mai 2007 12:57

Re,

Je viens de tester cette formule, pas de problème sauf s'il n'y pas de décimale(s) pour la valeur en H3.

Il vaudrait donc mieux la remplacer par la suivante :
=TEXTE(AU8;SI(NBCAR($H$3)=1;"0";"0."&REPT(0;NBCAR($H$3)-2)))&" "&$H$1

Encore plus difficile à comprendre ?
S'il faut un mot d'explication, avec plaisir !
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles

Messagepar mog » 31 Mai 2007 13:15

ah non là, je ne suis même pas dans les conditions pour essayer de lire la formule !!!

concernant la valeur en H3, j'ai forcément une décimale. donc je suis sauvé je peux sans coup férir conserver ma formule !

je garde tout de même sous le coude la formule, pour quand je serai en forme !

merci pour tout
openoffice 3.0 - windows XP SP2
mog
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 23
Inscrit le : 28 Fév 2007 15:14


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot] et 22 invité(s)