Nombre d'arguments dans la même colonne

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

Nombre d'arguments dans la même colonne

Messagepar yalou » 23 Avr 2007 20:43

Bonsoir,

Je souhaiterais savoir s'il y a un moyen de savoir combien de fois une valeur est présente dans la même colonne.

Les fichiers que je dois gérer vont contenir plus d'un millier de lignes, sur une dizaines de colonnes, mais surtout avec des dizaines voir des centaines de valeurs differentes dans la même colonne.

Je souhaiterais donc connaitre, soit au moyen d'une formule, soit au moyen d'une macro, directement combien de fois la même valeur est présente.

L'idéal serait de pouvoir savoir combien de fois toutes les valeurs sont présentes dans la même colonne.

Par avance, merci de vos réponses et de votre aide.
Plateforme: WinXP
OOo: 2.2.0
yalou
Fraîchement OOthentifié
 
Message(s) : 4
Inscrit le : 18 Avr 2007 09:05

Messagepar jeanmimi » 23 Avr 2007 21:16

Bonsoir et bienvenue,

Comme ce type de question est déjà passé, tu trouveras ici les possibilités :

http://user.services.openoffice.org/fr/forum/setopic_3626-sommeprod.html

En faisant la recherche sur SOMMEPROD, tu auras accès à toutes les réponses postées sur le forum.

Sur son site, Christian propose aussi des exemples :

http://christianwtd.free.fr/index.php?rubrique=DebFonctions13#FnSOMMEPROD
LibreOffice Version : Version : 7.0.1.2 (x64)(13 septembre 2020)
Adoptopen JRE ou Oracle JRE (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 15459
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Re: nb d'argument dans la même colonne...

Messagepar Gorfael » 24 Avr 2007 16:37

yalou a écrit:Bonsoir,

Je souhaiterais savoir s'il y a un moyen de savoir combien de fois une valeur est présente dans la même colonne.

Les fichiers que je dois gérer vont contenir plus d'un millier de lignes, sur une dizaines de colonnes, mais surtout avec des dizaines voir des centaines de valeurs differentes dans la même colonne.

Je souhaiterais donc connaitre, soit au moyen d'une formule, soit au moyen d'une macro, directement combien de fois la même valeur est présente.

L'idéal serait de pouvoir savoir combien de fois toutes les valeurs sont présentes dans la même colonne.

Par avance, merci de vos réponses et de votre aide.
Salut
en considérant que tes valeurs soit en colonne A, et que tu écrives la formule dans une cellule de la ligne 1 (hormis A1) :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD((A$1:A$65536)=A1)*1)

ça te donnera le nombre de fois que la valeur en A1 est contenue dans la colonne A
La formule peut être recopiée vers le bas et vers la droite
A+

EDIT Faut que j'arrête de bégayer :D
Dernière édition par Gorfael le 25 Avr 2007 07:05, édité 1 fois.
OO 2.2
Windows XP SP1
Gorfael
Fraîchement OOthentifié
 
Message(s) : 6
Inscrit le : 11 Avr 2007 10:07
Localisation : Basse Goulaine(44)

Messagepar Vandeput » 24 Avr 2007 17:56

Bonjour,

=NB.SI(A$1:A$65536;A1)
à copier vers le bas, renvoie le même résultat.

Mais il me semble que ce n'est que répondre partiellement à la question.
Ne faudrait-il pas d'abord lister les valeurs sans doublons, puis pour chacune d'entre elles compter leur nombre d'occurences ?

Un petit exemple sur Ci-Joint avec les données de départ et le résultat à obtenir faciliterait grandement la réposne.
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 24 invité(s)