[Résolu] mettre en évidence des dates fériées

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] mettre en évidence des dates fériées

Messagepar durtol » 13 Avr 2007 11:03

Bonjour, :D
Comment mettre en évidence des dates fériées (en rouge par exemple) et des dimanches (en bleu par exemple)
http://user.services.openoffice.org/fr/ci-joint/fichier/2007/04/13-111616.ods

merci
durtol
Dernière édition par durtol le 14 Avr 2007 14:10, édité 1 fois.
windows xp
openoffice 2.2
durtol
Fraîchement OOthentifié
 
Message(s) : 4
Inscrit le : 13 Avr 2007 09:59
Localisation : Aquitaine

Messagepar janjan » 13 Avr 2007 12:57

Pour les jours fériés, le plus simple est de créer une plage de données jourférié ou tu stoques les jours fériés (à moins qu'il y ai une fonction journ férié fiable (mais que faire de la pentecote ?).
Ensuite tu crée un style pour les dimanches et un style pur les jour férié.
Dans formatage conditionel comme première condition tu places comme formule : JOURSEM(A10)=1 si A10 les une cellule de date et comme deuxième condition : EQUIV(A10;ferie;0)>0 ou ferie est la plage des jours férié.
Copie le format sur l'ensemble de la plage.
Cela implique que tes cellules soit au format date (ce qui n'est pas le cas du classeur fourni) il faut donc que tu aménage ton fichier pour cela (création d'une ligne masquée avec des dates par exemple.

je joins un fichier exemple.
http://user.services.openoffice.org/fr/ci-joint/fichier/2007/04/13-015621.ods
OOo 3.1
Windows XP
janjan
Membre hOOnoraire
Membre hOOnoraire
 
Message(s) : 115
Inscrit le : 21 Nov 2006 11:53

Messagepar Vandeput » 13 Avr 2007 13:30

Bonjour,

Il y a moyen de simplifier quelque peu les formules :

C2 : 01.01.2002 au format J renverra 1
D2 : =C2+1 au format J renverra 2
à copier vers la droite ... 2, 3, 4, ...
A1 : =MAJUSCULE(TEXTE(C2;"mmmm")) renverra JANVIER
B1 : =SI(C2="";"";MAJUSCULE(GAUCHE(TEXTE(C2;"jjj");2)))
J'ai opté pour deux lettres, pour faire la différence entre mardi et mercredi.
Pour une lettre il faut supprimer le ;2 dans la formule.
à copier vers la droite.

Pour les mois de février tu auras les 2 ou 3 premiers jours du mois de mars qui s'afficheront à la droite du tableau.
Si tu veux ne pas les afficher, c'est assez simple, soit par formule, soit par format conditionnel.
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles

Messagepar Vandeput » 13 Avr 2007 13:44

Re,

Voilà, avant qu'on le demande :

En C2 tu remplaces la formule proposée par la suivante :
=SI(MOIS(C2+1)=MOIS($C2);C2+1;"")
à copier vers la droite.
A tester avec le mois de février.

Pour changer de mois ou d'année, il faire la modification en C2.
Mais on peut aussi permuter les formules et faire cette modification en A1.

Le plus facile reste l'emploi d'une barre de défilement (barre d'outils : Contrôle de formulaires) ou des listes de validité.
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles

Résolution formatage conditionnel des dates

Messagepar durtol » 14 Avr 2007 09:14

bonjour
merci pour les réponses sur le fotmatage conditionnel des dates
Problème résolu
windows xp
openoffice 2.2
durtol
Fraîchement OOthentifié
 
Message(s) : 4
Inscrit le : 13 Avr 2007 09:59
Localisation : Aquitaine

Re: Résolution formatage conditionnel des dates

Messagepar Jeff » 14 Avr 2007 09:44

Bonjour et bienvenue sur ce forum,
durtol a écrit:Problème résolu

Alors il faut que tu le signale :arrow: Comment faire

A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 18.04.1 x64 (Bionic Beaver), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8346
Inscrit le : 18 Sep 2006 10:40
Localisation : France


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 23 invité(s)