[Resolu] Format nombres

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Resolu] Format nombres

Messagepar Vandeput » 13 Mars 2007 10:27

Bonjour,

Je cherche comment faire pour obtenir un espace comme séparateur de milliers dans un nombre.

J'ai déjà opté pour un environnement linguiste Français (Suisse) qui me donne le point comme séparateur de décimales sans modifier le pavé numérique (l'anglais le fait aussi).

Si je coche "séparateur de milliers" (Format / Cellules / Nombres), j'obtiens une ' (apostrophe) comme séparateur.

Le "format défini par l'utilisateur" : # ##0.00 fonctionne, mais ma feuille contient des cellules avec deux et trois décimales.
L'icône "Ajouter une décimale" ne résoud pas le problème.

Quelqu'un connaîtrait-il un environnement linguistique qui donne le point comme séparateur de décimales et l'espace comme séparateur de millieurs ?
J'en ai essayé beaucoup, mais sans résultat.

Merci d'avance.
Dernière édition par Vandeput le 13 Mars 2007 13:16, édité 1 fois.
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles

Messagepar jeanmimi » 13 Mars 2007 10:35

Bonjour,

Ce format :
# ##0.000
avec Anglais (Royaume Uni) devrait aller.
Tu peux aussi essayer Français (Suisse).
LibreOffice Version : Version : 7.0.0.3 (x64)(6 aout 2020)
Adoptopen JRE ou Oracle JRE (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 15403
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Messagepar Vandeput » 13 Mars 2007 11:03

Bonjour,

C'est très gentil à toi de m'avoir répondu aussi rapidement, mais peut-être un peu trop rapidement.

J'avais bien précisé que j'avais déjà opté pour l'environnement linguistique Français (Suisse) et que l'Anglais fonctionnait aussi, pour ce qui concerne le séparateur décimal, mais pas pour le séparateur de milliers.
De plus j'avais signalé que le format défini par l'utilisateur fonctionne, mais ne permet pas, à ma connaissance, de faire varier le nombre de décimales.

Voilà où j'en suis :
J'ai créé deux styles (2 et 3 décimales).
A chaque formule j'ajoute : +STYLE("2") ou + STYLE("3")
Cela fonctionne parfaitement, mais c'est laborieux !

Merci quand même.
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles

Messagepar Pierre-Yves Samyn » 13 Mars 2007 13:00

Bonjour

La solution réside en effet dans les styles, mais pourquoi n'appliques-tu pas simplement le style à la cellule au lieu de l'ajouter dans la formule ?
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11276
Inscrit le : 02 Mai 2006 09:42

Messagepar Vandeput » 13 Mars 2007 13:15

Re,

Effectivement, je viens de remarquer (c'est pas trop tôt !), qu'en copiant (poignée de recopie) une cellule avec style, ce style se copie aussi.

Donc aucune différence avec Excel au point de vue vitesse.
Au lieu de copier le format d'une cellule vers une autre (icône avec petite brosse), un double-clic sur le style dans la boîte de dialogue donne le même résultat.

Problème résolu, je m'empresse d'éditer le sujet de ce message (cela fera plaisir à qui tu sais).

Merci beaucoup pour ton aide.
andré
2.2 sous Windows XP
Vandeput
Membre enthOOusiaste
Membre enthOOusiaste
 
Message(s) : 409
Inscrit le : 12 Fév 2007 15:33
Localisation : Bruxelles


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 3 invité(s)