[Résolu] import TXT : mauvais formatage de nombre

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] import TXT : mauvais formatage de nombre

Messagepar chazalmartin » 08 Mars 2007 19:12

Lorsque j'ouvre un fichier txt dans calc ,si une cellule numérique contient un nombre qui peut correspondre à une date elle affiche une date. Exemple le nombre 18.12 s'affiche 18/12/07. Est-il possible de remédier à ce problème.
voici une partie du fichier:
FR0000133308;03/04/06;18.72;18.79;18.46;18.58;9537592
FR0000133308;04/04/06;18.50;18.67;18.29;18.33;11661423
FR0000133308;05/04/06;18.47;18.48;18.12;18.41;11191503
FR0000133308;06/04/06;18.51;18.52;18.19;18.42;14812671
voici l'affichage correspondant:
FR0000133308 03/04/06 18.72 18.79 18.46 18.58 9537592
FR0000133308 04/04/06 18.50 18.67 18.29 18.33 11661423
FR0000133308 05/04/06 18.47 18.48 18/12/07 18.41 11191503
FR0000133308 06/04/06 18.51 18.52 18.19 18.42 14812671
merci de vos lumières.
Dernière édition par chazalmartin le 08 Mars 2007 21:14, édité 1 fois.
OOo 2.1 avec xp2
chazalmartin
Fraîchement OOthentifié
 
Message(s) : 5
Inscrit le : 08 Mars 2007 18:54

Messagepar Jeff » 08 Mars 2007 19:41

Bonjour et bienvenue,

Lors de ton export en texte CSV, il faut que tu sélectionne les colonnes où figurent tes données, pour avoir accés au type, et ainsi modifier de standard en texte (j'ai pas trouvé comment faire une sélection globale, par contre :? ,il faut apparemment sélectionner les colonnes une par une), voir ci dessous :

Image

A + :wink:
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 18.04.1 x64 (Bionic Beaver), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8338
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Messagepar Jeff » 08 Mars 2007 19:49

:oops: j'oublie la moitié de ma solution :

Tu obtiens donc là du texte.
Pour obtenir des chiffres, si tu es en France avec une configuration Français, les nombre ont une virgule comme séparateurs ; il faut donc :
- sélectionner ta plage de cellules obtenue aprés Import
- menu Edition->Rechercher et Remplacer
- en critère de recherche : "." (sans les guillemets bien sûr)
- en critère de remplacement : "," (sans les guillemets bien sûr)
- cocher dans Options->Sélection active seulement
puis cliquer sur Remplacer tout.

Là, je crois que c'est complet...

Image
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 18.04.1 x64 (Bionic Beaver), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8338
Inscrit le : 18 Sep 2006 10:40
Localisation : France

[résolu] fichier txt vers calc mauvais formatage nombre

Messagepar chazalmartin » 08 Mars 2007 21:13

Merci Jeff, pour cette réponse rapide, documentée et qui fonctionne.
Bravo
OOo 2.1 avec xp2
chazalmartin
Fraîchement OOthentifié
 
Message(s) : 5
Inscrit le : 08 Mars 2007 18:54

Messagepar vinc-mai » 09 Mars 2007 11:08

J'avais le même problème que j'ai résolu différemment:
j'utilise l'environnement français (suisse).

Avantage: plus rapide.
Inconvénient: la , n'est plus reconnue comme séparateur décimal (ce qui n'arrange mais bon c'est peut-être pas le cas de tout le monde)
(Ooo 2.3 sur windows XP)
OOo 2.3 sur Ubuntu 7.10
Avatar de l’utilisateur
vinc-mai
PassiOOnné
PassiOOnné
 
Message(s) : 540
Inscrit le : 22 Déc 2005 15:13
Localisation : Rhône-Alpes


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 4 invité(s)