[Résolu] rappel de cellules entre 2 ordinateurs

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] rappel de cellules entre 2 ordinateurs

Messagepar pitou68 » 06 Mars 2007 12:26

Slt a ts,

Voila mon souci :
2 ordinateurs en reseau,

sur l'un, un tableur appelé somme, sur la feuille 1 :
-A1 : 1
-A2 : 2
sur la feuille 2 :
-A1 : =somme(A1:A2)

sur l'autre ordi :
-A1 : ="chemin de la cellule A1 sur l'ordi 1" (sans les guillemets)
ou
-A1 : =cellule("contents";chemin de la cellule A1 sur l'ordi 1)

Dans les deux cas, l'erreur #nom? m'est renvoyée !
J'espère avoir été assez clair pour vos suggestions, merci.
pitou68
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 56
Inscrit le : 06 Mars 2007 07:18

Messagepar Jeff » 06 Mars 2007 12:55

Bonjour et bienvenue,

Avant tout, devrai mettre à jour ta signature (cf. : http://user.services.openoffice.org/fr/ ... 41.html#41 jusqu'au bout )

pitou68 a écrit:sur l'un, un tableur appelé somme, sur la feuille 1 :
-A1 : 1
-A2 : 2
sur la feuille 2 :
-A1 : =somme(A1:A2)

Je pense que ta fonction SOMME devrait plutôt avoir cette syntaxe :
-A1 : =SOMME(Feuille1.A1:A2) :wink:

pitou68 a écrit:l'erreur #nom? m'est renvoyée

A priori, je serai tenté de dire que ta syntaxe n'est pas bonne.
Ce que tu peux essayer :
A partir d'un classeur sur un ordinateur X :
- Taper "=" (sans les guillemets)
- Aller chercher, par un clic de souris, une cellule sur un ordinateur Y
-> la syntaxe affichée devrait être la bonne

N'ayant pas de réseau, je ne peux te fournir qu'une réponse vague, cependant, je ne doute pas que tu ais d'autres réponses (pour autant que ta signature soit à jour :wink: )

A +

EDIT : la syntaxe entre classeur d'un même ordinateur est, par exemple, sur ma configuration :
='file:///C:/Documents%20and%20Settings/Profils/Répertoire/nom_fichier.ods'#Feuille1.A1

Cela peut t'aider ?
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Emmabuntus Debian Edition 3 Buster 32 bits, sur Ubuntu 18.04.1 x64 (Bionic Beaver), et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8338
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Messagepar pitou68 » 06 Mars 2007 16:52

Merci pour ta réponse,

Etant au travail, j'ai accès aux differentes syntaxes qui sont les suivantes :

sur l'ordi 1 : =SOMME(FEVRIER.F6:F505) en B8

sur l'ordi 2 : ='file://Slpt-4/Photos%20num%C3%A9riques/Registre%20B'/2007.ods'#'Stat février'.B8

j'ai aussi essayé
sur l'ordi 2 : =CELLULE("CONTENTS";'file://slpt-4/photos%20num%c3%a9riques/registre%20b'/2007.ods'#'stat février'.b8)

l'erreur reste #NOM ? dans les deux cas

voila pour les précisions, et merci pour vos aides
Dernière édition par pitou68 le 06 Mars 2007 16:56, édité 1 fois.
LiBo Version: 5.0.5.2 sous sept
pitou68
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 56
Inscrit le : 06 Mars 2007 07:18

Messagepar Sylvain » 06 Mars 2007 17:23

Si c'est juste pour faire une liaison entre 2 cellules de classeurs différents (qu'ils soient sur le même ordi ou pas) tu peux aussi faire :
Selectionne la cellule dans le 1er classeur / Copier
Dans le classeur de destination Faire Un Collage Spécial en activant LIER
Tu obtiens alors une fonction DDE matricielle.
A+
OOo 2.1 sur Win XP-SP2
Sylvain
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 21
Inscrit le : 15 Fév 2007 11:55

Messagepar pitou68 » 06 Mars 2007 18:35

Merci, j'essaie cela demain, et je vous tiens au courant
LiBo Version: 5.0.5.2 sous sept
pitou68
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 56
Inscrit le : 06 Mars 2007 07:18

Messagepar pitou68 » 07 Mars 2007 08:09

Ca fonctionne, merci pour la soluce toute simple du "copier-coller".

A+
LiBo Version: 5.0.5.2 sous sept
pitou68
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 56
Inscrit le : 06 Mars 2007 07:18


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 1 invité