Vérifier difference des cellules

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

Vérifier difference des cellules

Messagepar bicounet18 » 15 Mars 2013 13:02

Bonjour,
Comment peut-on vérifier que les contenus d'une plage de cellules (A1:A9) soit toutes différentes.
En bref, que l'on n'ait pas plusieurs fois la même valeur saisie dans cette plage.
Merci
Xubuntu 18.04.1
LibreOffice Version: 6.1.2.1
bicounet18
Fraîchement OOthentifié
 
Message(s) : 3
Inscrit le : 15 Mars 2013 12:54

Re: Vérifier difference des cellules

Messagepar Jeff » 15 Mars 2013 13:17

Bonjour et bienvenue,

Tu cherches donc à trouver les doublons, la liste des sujets peut être longue, on peut s'en tenir à une recherche uniquement sur les titres.
À part les formules, tu peux utiliser les listes de validité, ou faire des tri sans doublon, passer par un formatage conditionnel qui colore les cellules en doublon etc...

Je pense qu'il faudrait que tu précise ce que tu souhaite obtenir.

A + ;)
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.6 sur Debian Stable i586 10 (buster) et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8078
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Re: Vérifier difference des cellules

Messagepar Zelada » 15 Mars 2013 14:50

Bonjour

En cherchant donc les doublons avec la formule
Code : Tout sélectionner   AgrandirRéduire
=SI(NB.SI($A$1:A1;A1)>1;"Doublon";"")

Voir en pièce jointe

P.S. je ne viens pas d'inventer la formule, je l'ai vue sur le Net :wink:

A+

 Ajout : autre solution faire un filtre
http://forum.openoffice.org/fr/forum/viewtopic.php?p=42853#p42853 
Pièces jointes
chercher_doublon.ods
(8.07 Kio) Téléchargé 26 fois
LibreOffice 3.6.5.2 (version imposée) sous Windows XP SP3 au bureau
Avatar de l’utilisateur
Zelada
InconditiOOnnel
InconditiOOnnel
 
Message(s) : 930
Inscrit le : 27 Fév 2013 15:55

Re: Vérifier difference des cellules

Messagepar Jeff » 15 Mars 2013 17:53

Zelada a écrit: je l'ai vue sur le Net


Pas besoin d'aller "si loin" :wink:

Dans les Trucs et astuces pour Calc :
viewtopic.php?p=2175#p2175
viewtopic.php?p=15318#p15318

A +
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.6 sur Debian Stable i586 10 (buster) et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8078
Inscrit le : 18 Sep 2006 10:40
Localisation : France


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 10 invité(s)