[Résolu] NB.SI / Recherche de plusieurs critères sur une...

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] NB.SI / Recherche de plusieurs critères sur une...

Messagepar Fredox » 15 Nov 2011 23:18

Bonjour,
J'aimerai savoir si il est possible de faire une recherche avec le fonction NB.SI afin de compter plusieurs critères differents sur une seule plage ?

Ainsi sur ma plage A1:F1, j'aimerais savoir combien de fois sont écris "Moi" ou "Toi" cumulés sans distinction.

Comme:
Code : Tout sélectionner   AgrandirRéduire
=NB.SI(A1:F1;"Moi" ou "Toi")


C'est possible ? Merci
Dernière édition par micmac le 15 Nov 2011 23:41, édité 2 fois.
Raison: [Résolu] doit être accompagné de la coche
Open Office 3.3.0 sous Windows 7
Continu de bricoler sous Calc (mais en net progrès)
Avatar de l’utilisateur
Fredox
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 83
Inscrit le : 28 Oct 2006 14:55

Re: NB.SI / Recherche de plusieurs critères sur une seule pl

Messagepar Jean-Louis Cadeillan » 15 Nov 2011 23:30

Bonsoir,
Oui, on peut utiliser NB.SI() en matriciel (valider par Ctrl+Maj+Entrée) :
Code : Tout sélectionner   AgrandirRéduire
=NB.SI((A1:F1="Moi")+(A1:F1="Toi");1)
Remarque : dans le fichier joint, de A1 à F1, les formules ne sont là que pour faire varier aléatoirement les Moi et les Toi (Ctrl+Maj+F9 pour relancer)
Cordialement
Jean-Louis
Pièces jointes
Fredox_01.ods
NB.SI () multicritères
(7.76 Kio) Téléchargé 155 fois
LibreOffice 4.1.5.3 et Apache OpenOffice 3.4.1 sous Windows 7 Édition Intégrale 64 SP1 (Domicile)
LibreOffice 3.5.6.2 sous ArchLinux, noyau 3.4.9 - 1
Apache OpenOffice 3.4.0 sous Windows Sept Pro 64 SP1 (Bureau)
Avatar de l’utilisateur
Jean-Louis Cadeillan
ManitOOu
ManitOOu
 
Message(s) : 3377
Inscrit le : 03 Jan 2009 00:56

Re: NB.SI / Recherche de plusieurs critères sur une seule pl

Messagepar Fredox » 15 Nov 2011 23:37

Merci Jean-Louis, en fait j'avais déja mis en pratique cette solution (j'ai oublier de le préciser).
En fait je voulais savoir si il y avait un moyen plus simple qui constiste à ne pas ressaisir à chaques fois la zone de recherche car sur ma formule j'aurais 15 textes differents à chercher pour la meme plage de recherche.

Mais sinon c'est bien ca quand meme.
Open Office 3.3.0 sous Windows 7
Continu de bricoler sous Calc (mais en net progrès)
Avatar de l’utilisateur
Fredox
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 83
Inscrit le : 28 Oct 2006 14:55

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar Jean-Louis Cadeillan » 15 Nov 2011 23:46

A ce moment-là, mets tes textes à rechercher dans une plage, nommée par exemple MesTextes et utilise SOMMEPROD() :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(A1:F1=MesTextes)

Note : tu peux remplacer, dans la formule, MesTextes par {"Toi"; "Moi";etc.}
A+
Jean-Louis
LibreOffice 4.1.5.3 et Apache OpenOffice 3.4.1 sous Windows 7 Édition Intégrale 64 SP1 (Domicile)
LibreOffice 3.5.6.2 sous ArchLinux, noyau 3.4.9 - 1
Apache OpenOffice 3.4.0 sous Windows Sept Pro 64 SP1 (Bureau)
Avatar de l’utilisateur
Jean-Louis Cadeillan
ManitOOu
ManitOOu
 
Message(s) : 3377
Inscrit le : 03 Jan 2009 00:56

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar gerard24 » 16 Nov 2011 09:33

Bonjour,
Jean-Louis Cadeillan a écrit:A ce moment-là, mets tes textes à rechercher dans une plage, nommée par exemple MesTextes et utilise SOMMEPROD() :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(A1:F1=MesTextes)


Attention avec cette formule, si la plage de recherche est en ligne (comme ici A1:F1) la plage de critères (mestextes) doit être en colonnne.
Et inversement, avec une plage de recherche en colonne, la plage critère doit être en ligne.
Sauf à utiliser TRANSPOSE.

A+
OOodidacte
LibreOffice 4.1.3 sous Windows vista SP2
pour télécharger LibreOffice
Avatar de l’utilisateur
gerard24
ManitOOu
ManitOOu
 
Message(s) : 2599
Inscrit le : 06 Juil 2008 18:08
Localisation : dans le Périgord

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar Fredox » 16 Nov 2011 18:53

Superbe !!! :super:
Mes critères étant en colonne, je suis ravi ! :aie:

Merciiii
Open Office 3.3.0 sous Windows 7
Continu de bricoler sous Calc (mais en net progrès)
Avatar de l’utilisateur
Fredox
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 83
Inscrit le : 28 Oct 2006 14:55

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar Fredox » 16 Nov 2011 19:24

Arfff !
Problème, mon PC du boulot étant sous OpenOffice 3.0.0, la formule ne fonctionne pas - Mon premier critere est bien pris en compte, les autres non.

Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(A1:F1=S22:S29)

Seul S22 est comptabilisé (alors que sur OOO v3.3.0 cela fonctionne parfaitement).

De plus impossible pour moi de la faire fonctionnée ainsi:
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(A1:F1=S22;S23;S24;S25;S26;S27;S28;S29)
Même en version 3.3.0

Simplement problème de compatibilité pour la première solution ?
Je me suis tromper de formule pour la seconde ?


Je peu mettre mon PC du boulot à jour, mais je vais partager ce document et tout mes colègues ne seront pas à jour.
Merci
Open Office 3.3.0 sous Windows 7
Continu de bricoler sous Calc (mais en net progrès)
Avatar de l’utilisateur
Fredox
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 83
Inscrit le : 28 Oct 2006 14:55

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar Jeff » 16 Nov 2011 19:39

Bonjour,

Tu as bien pris en compte le message de Gérard au sujet de la transposition ?

Je pense que tu devrai nous joindre un fichier-test pour les tests :)
À lire avant tout !

Pour télécharger Apache OpenOffice 4.0.1

AOO 4.0.1 sur Ubuntu 12.04 x64 et Win7proSP1
Avatar de l’utilisateur
Jeff
GourOOu
GourOOu
 
Message(s) : 5479
Inscrit le : 18 Sep 2006 10:40
Localisation : Hautes-Alpes, France

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar Fredox » 16 Nov 2011 19:47

J'ai mis ce que j'ai testé.
Dans la case jaune, pas de soucis sous OOO v3.3.0 mais ne fonstionne pas sous OOO v3.0.0
Dans la rose ce que j'ai cru comprendre mais ne fonctionne pas du tout

Pour TRANSPOSE je ne l'ai pas utiliser car la plage est en ligne et les critères en colonne.

Merci
Pièces jointes
Zsais.ods
Fichier joint
(7.51 Kio) Téléchargé 51 fois
Open Office 3.3.0 sous Windows 7
Continu de bricoler sous Calc (mais en net progrès)
Avatar de l’utilisateur
Fredox
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 83
Inscrit le : 28 Oct 2006 14:55

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar Jean-Louis Cadeillan » 16 Nov 2011 19:48

Fredox a écrit:Simplement problème de compatibilité pour la première solution ?
Oui
Fredox a écrit:Je me suis trompé de formule pour la seconde ?
Oui
Une solution avec une somme matricielle qui marche sous OOo 3.0.0 :
Code : Tout sélectionner   AgrandirRéduire
=SOMME(A1:F1=S22;A1:F1=S23;A1:F1=S24;A1:F1=S25;A1:F1=S26;A1:F1=S27;A1:F1=S28;A1:F1=S29)
...c'est plus lourd...
 Ajout : Pour ton fichier (je ne l'avais pas ouvert), ce serait :
Code : Tout sélectionner   AgrandirRéduire
=SOMME(A1:F1=I4;A1:F1=I5;A1:F1=I6;A1:F1=I7;A1:F1=I8;A1:F1=I9)
 

A+
Jean-Louis
LibreOffice 4.1.5.3 et Apache OpenOffice 3.4.1 sous Windows 7 Édition Intégrale 64 SP1 (Domicile)
LibreOffice 3.5.6.2 sous ArchLinux, noyau 3.4.9 - 1
Apache OpenOffice 3.4.0 sous Windows Sept Pro 64 SP1 (Bureau)
Avatar de l’utilisateur
Jean-Louis Cadeillan
ManitOOu
ManitOOu
 
Message(s) : 3377
Inscrit le : 03 Jan 2009 00:56

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar gerard24 » 16 Nov 2011 20:09

Je n'ai plus d'ancienne version mais essayes :

Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(NB.SI(A1:F1;I4:I9))

ou
Code : Tout sélectionner   AgrandirRéduire
=SOMME(NB.SI(A1:F1;I4:I9))
en matricielle.

ou encore :
Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(ESTNUM(EQUIV(A1:F1;I4:I9;0)))
Dernière édition par gerard24 le 16 Nov 2011 20:14, édité 1 fois.
OOodidacte
LibreOffice 4.1.3 sous Windows vista SP2
pour télécharger LibreOffice
Avatar de l’utilisateur
gerard24
ManitOOu
ManitOOu
 
Message(s) : 2599
Inscrit le : 06 Juil 2008 18:08
Localisation : dans le Périgord

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar Fredox » 16 Nov 2011 20:10

Code : Tout sélectionner   AgrandirRéduire
=SOMME(A1:F1=I4;A1:F1=I5;A1:F1=I6;A1:F1=I7;A1:F1=I8;A1:F1=I9)

Aie Aie Aie, désoler Jean-Louis, je te remercie mais cela ne fonctionne pas (il ne compte rien), comme visiblement tu utilise Libre Office, cela viens peut-être de là.

Merci quand même :(
Open Office 3.3.0 sous Windows 7
Continu de bricoler sous Calc (mais en net progrès)
Avatar de l’utilisateur
Fredox
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 83
Inscrit le : 28 Oct 2006 14:55

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar Fredox » 16 Nov 2011 20:16

Merci Gérard,

Code : Tout sélectionner   AgrandirRéduire
=SOMMEPROD(NB.SI(A1:F1;I4:I9))
fonctionne parfaitement sous OOo v3.0.0 :bravo:
Superbe, voila ma vie simplifiée (si si)

Merci Gérard, Merci Jean-Louis.
Open Office 3.3.0 sous Windows 7
Continu de bricoler sous Calc (mais en net progrès)
Avatar de l’utilisateur
Fredox
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 83
Inscrit le : 28 Oct 2006 14:55

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar gerard24 » 16 Nov 2011 20:17

Fredox a écrit:
Code : Tout sélectionner   AgrandirRéduire
=SOMME(A1:F1=I4;A1:F1=I5;A1:F1=I6;A1:F1=I7;A1:F1=I8;A1:F1=I9)

Aie Aie Aie, désoler Jean-Louis, je te remercie mais cela ne fonctionne pas (il ne compte rien), comme visiblement tu utilise Libre Office, cela viens peut-être de là.

Comme l'a souligné Jean-Louis, cette formule est matricielle. Elle doit donc être validée par Ctrl+Maj+Entrée.
OOodidacte
LibreOffice 4.1.3 sous Windows vista SP2
pour télécharger LibreOffice
Avatar de l’utilisateur
gerard24
ManitOOu
ManitOOu
 
Message(s) : 2599
Inscrit le : 06 Juil 2008 18:08
Localisation : dans le Périgord

Re: [Résolu] NB.SI / Recherche de plusieurs critères sur une

Messagepar Fredox » 16 Nov 2011 20:26

OK.
Merci.
Open Office 3.3.0 sous Windows 7
Continu de bricoler sous Calc (mais en net progrès)
Avatar de l’utilisateur
Fredox
Membre OOrganisé
Membre OOrganisé
 
Message(s) : 83
Inscrit le : 28 Oct 2006 14:55


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Aucun utilisateur inscrit et 7 invité(s)