[Résolu] Expressions régulières dans la fonction SI

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Expressions régulières dans la fonction SI

Messagepar fabrice91 » 15 Nov 2006 14:22

Bonjour,

Puisque l'on a répondu vite et bien à mon premier post, je n'hésite pas à reposter une question !
Je voudrais savoir s'il est possible d'utiliser une expression régulière dans la fonction SI.
Exemple:
A1 contient "mon tonton"
A2 contient "ma tata"
A3 contient "mon papa"

je voudrais faire quelque chose si le contenu de la cellule COMMENCE par "mon"
j'ai essayé ceci mais ca n'a pas l'air de fonctionner :
B1 contient SI(A1="^mon";"x";"") -> affiche "x" dans B1
B2 contient SI(A2="^mon";"x";"") -> affiche rien dans B2
B3 contient SI(A3="^mon";"x";"") -> affiche "x" dans B3

merci !
Dernière édition par fabrice91 le 15 Nov 2006 15:29, édité 1 fois.
oOo 2.4 Ubuntu 2.4 / oOo 2.4 Windows XP2
fabrice91
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 23
Inscrit le : 15 Nov 2006 12:12

Messagepar Jeff » 15 Nov 2006 14:33

Rebonjour,

Tout d'abord, si une de tes questions est solutionnée, clique sur Editer dans le premier message, puis modifie le titre en incluant [Résolu]

Pour cette question je pense que tu va devoir passer par plusieurs fonctions de texte.

Voir, à titre d'inspiration :
- http://user.services.openoffice.org/fr/ ... c2770.html
ou bien :
- http://user.services.openoffice.org/fr/ ... html#14887
ou encore :
- http://christianwtd.free.fr/index.php?r ... s01#FnSTXT (excellent site sur Calc !)
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Debian Stable LXDE i686 10.2 (buster) et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8197
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Messagepar Pierre-Yves Samyn » 15 Nov 2006 14:33

Bonjour

Tu peux toujours faire :

Code : Tout sélectionner   AgrandirRéduire
=SI(GAUCHE(A1;3)="Mon";"x";"")
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11276
Inscrit le : 02 Mai 2006 09:42

Messagepar fabrice91 » 15 Nov 2006 15:25

merci, ca aurait été tellement plus simple de pouvoir inclure les expressions régulières...
cela fonctionne bien pour la fonction rechercher/remplacer !!!
oOo 2.4 Ubuntu 2.4 / oOo 2.4 Windows XP2
fabrice91
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 23
Inscrit le : 15 Nov 2006 12:12


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot], MSN [Bot] et 9 invité(s)