[Résolu] Compter cellules non vides [Concatener une plage]

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] Compter cellules non vides [Concatener une plage]

Messagepar fabrice91 » 15 Nov 2006 12:15

bonjour

Comment faire pour concaténer une plage de cellules lorsqu'elles sont nombreuses ?
Impossible de faire concatener(a1;a2;a3;a4 ...a1000) !!!
Et la formule concatener(a1:a1000) me renvoie une erreur #VALEUR

merci
Dernière édition par fabrice91 le 15 Nov 2006 15:28, édité 2 fois.
oOo 2.4 Ubuntu 2.4 / oOo 2.4 Windows XP2
fabrice91
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 23
Inscrit le : 15 Nov 2006 12:12

Messagepar Jeff » 15 Nov 2006 12:27

Normal que CONCATENER te renvoie une valeur d'erreur, et ce pour 2 raisons :
- fonction limitée à 30 arguments
- fonction non matricielle

Et quand bien même tu la valide en fonction matricielle, elle se contente de te recopier ta plage....

Tout cela pour dire que je n'ai pas l'idée, mais ce n'est pas du côté de cette fonction qu'il faut chercher...

EDIT : idée -> essaye la fusion en sélectionnant déplacer le contenu des cellules cachées
Dernière édition par Jeff le 15 Nov 2006 12:32, édité 1 fois.
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Debian Stable LXDE i686 10.2 (buster) et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8188
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Messagepar jeanmimi » 15 Nov 2006 12:31

Et en confirmation de ce qu'écrit Jeff, un petit coup d'oeil sur le site de Christian :

http://christianwtd.free.fr/index.php?rubrique=DebFonctions01#FnCONCATENER
LibreOffice Version : Version: 6.3.3.2 (x64) (4 novembre 2019)
Java (x64) 1.8.0_xxx, Windows 10, Thunderbird, Firefox
Avatar de l’utilisateur
jeanmimi
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 15063
Inscrit le : 03 Mars 2006 17:02
Localisation : Venise verte

Messagepar Jeff » 15 Nov 2006 12:33

J'ai laissé un EDIT dans le message précédent, ça marche apparemment !
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Debian Stable LXDE i686 10.2 (buster) et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8188
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Messagepar Jeff » 15 Nov 2006 13:30

De retour après un bon repas, je développe :
Mettons que tu veuilles concaténer de A1 jusqu'à A1000 et garder ta plage sans modification :

a) en A1001 taper ta formule :
Code : Tout sélectionner   AgrandirRéduire
=CONCATENER(A1:A1000)

Valide par Ctrl+Maj+Entrer (fonction de matrice)

Calc te crée alors une matrice identique à celle que tu as
Tant que cette matrice est sélectionnée, clique sur l'icône Fusionner puis sélectionne Déplacer le contenu des cellules cachées.
Tu te retrouve avec toutes les données concaténées, il te faut un semblant de mise en forme:
Reclique sur l'icône fusionner, toutes tes données apparaissent sur la ligne en dessous de ta matrice d'origine. Un p'tit coup de formatage pour renvoyer à la ligne au cas où (sur 1000 ligne, ça te fait une pu...naise de cellule à l'arrivée !) et le tour est joué !

EDIT : le fait de fusionner les cellules en déplaçant le contenu des cellules cachées écrase la fonction matricielle créée auparavant. Le contenu de la cellule finale n'est donc plus actualisé !
Dernière édition par Jeff le 20 Nov 2006 11:58, édité 1 fois.
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Debian Stable LXDE i686 10.2 (buster) et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8188
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Messagepar fabrice91 » 15 Nov 2006 14:15

merci pour ces pistes...
en fait ce que je veux "betement" faire c'est comptabiliser sur une colonne les x que j'ai pu mettre dedans...sur certaines cellules y a "x" sur d'autres y en pas...et je voulais faire le total numérique des "x" par colonne...
bon au lieu de mettre un "x" je pourrai mettre un 1 et faire la somme a la fin mais bon... :?
j'ai vu qu'il existait une fonction NB.VIDE pour compter les cellules vides d'une plage, en fait moi il me faut une fonction NB.NONVIDE pour compter les cases non-vides... :roll:
oOo 2.4 Ubuntu 2.4 / oOo 2.4 Windows XP2
fabrice91
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 23
Inscrit le : 15 Nov 2006 12:12

Messagepar Jeff » 15 Nov 2006 14:18

Fallait le dire plus tôt, je ne me serai pas mis mes 2 neurones en contact :D !

As-tu essayé NB.SI ???

Un truc du genre :
Code : Tout sélectionner   AgrandirRéduire
=NB.SI(A1:A1000;"x")
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Debian Stable LXDE i686 10.2 (buster) et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8188
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Messagepar fabrice91 » 15 Nov 2006 15:28

Jeff a écrit:Fallait le dire plus tôt, je ne me serai pas mis mes 2 neurones en contact :D !

As-tu essayé NB.SI ???

Un truc du genre :
Code : Tout sélectionner   AgrandirRéduire
=NB.SI(A1:A1000;"x")

Le "truc du genre" fonctionne très bien !
Résolu !
Merci !
:D
oOo 2.4 Ubuntu 2.4 / oOo 2.4 Windows XP2
fabrice91
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 23
Inscrit le : 15 Nov 2006 12:12


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : MSN [Bot] et 14 invité(s)