[Résolu] formule incorrecte

Discussions à propos du tableur Calc.
Les questions sur les macros doivent être postées dans la section dédiée en dessous.

Modérateur: Vilains modOOs

Règles du forum
Cette section est uniquement dédiée au tableur Calc. Vous ne devez pas poster ici de questions sur les macros mais utiliser la section éponyme.

[Résolu] formule incorrecte

Messagepar bribri » 25 Oct 2006 08:37

Bonjour,

Voilà mon problème : j'ai le tableau ci-dessous avec 4 colonnes :

la colonne "H.T. EUROS" (colonne C) est vide et c'est moi même qui met une valeur
la colonne "H.T. FRs" (colonne D) à la fonction suivante : =SI(C3>0;C3*6,55957;" ")
la colonne "Livré" est vide (colonne F)
la colonne "Facturé" est vide (colonne G)

H.T. EUROS H.T. FRs Livré Facturé
10,00 € 65,60
10,00 € 65,60 oui 65,60

Je voudrai, quand je tape dans la colonne "Livré" le texte "oui" que dans la colonne "Facturé" s'affiche le montant de la colonne D, sinon rien.

Alors, j'ai essayé la formule (à mettre dans la colonne G) : =SI(F3=oui;G3=D3;" ") mais ca marche pas (erreur nom incorrect)

Pouvez-vous m'aider SVP (je m'excuse mais mon tableau de 4 colonnes est mal tapé lors de la visualisation, mais j'espère que vous allez comprendre)

Merci beaucoup
Dernière édition par bribri le 25 Oct 2006 11:11, édité 1 fois.
OpenOffice.org 2.0.3
windows XP familial pack 2
bribri
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 20
Inscrit le : 10 Oct 2006 07:08

Messagepar Jeff » 25 Oct 2006 08:45

Bonjour,

A priori et sans essayer, je dirai qui te manque des guillemets

=SI(F3="oui";G3=D3;" ") serait plus correct.

EDIT : A priori ce post devrai être en Tableur et pas en Macros et API...
À lire avant tout !

Pour télécharger Apache OpenOffice

AOO 4.1.7 sur Debian Stable LXDE i686 10.2 (buster) et sur Win 10 pro x64
Jeff
GourOOu
GourOOu
 
Message(s) : 8188
Inscrit le : 18 Sep 2006 10:40
Localisation : France

Messagepar bribri » 25 Oct 2006 10:45

Bonjour,

Merci Jeff, j'ai mis les guillemets mais rien ne s'affiche dans ma colonne G (mais je n'ai plus de message d'erreur en bas)

Peux-tu me donner une autre solution?

Merci


Le modérateur a écrit:Votre question n'a rien à voir avec les macros. Merci de poster à la bonne place la prochaine fois.
OpenOffice.org 2.0.3
windows XP familial pack 2
bribri
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 20
Inscrit le : 10 Oct 2006 07:08

Re: formule incorrecte

Messagepar Pierre-Yves Samyn » 25 Oct 2006 11:04

Bonjour

bribri a écrit:Je voudrai, quand je tape dans la colonne "Livré" le texte "oui" que dans la colonne "Facturé" s'affiche le montant de la colonne D, sinon rien.


La formule dans la colonne G (facturé) devrait être du type :

=SI(F3="Oui";D3;"")

En effet, OOo capitalise par défaut, donc si on met "oui" le test ne sera pas vérifié.

Par ailleurs, il ne faut pas mettre "G3=D3", qui retourne vrai ou faux selon que G3=D3. Ce n'est pas ce que l'on veut...
Pierre-Yves Samyn
Grand Maître de l'OOffice
Grand Maître de l'OOffice
 
Message(s) : 11276
Inscrit le : 02 Mai 2006 09:42

Messagepar bribri » 25 Oct 2006 11:10

Bonjour

Merci Pierre-Yves Samyn : ca marche

A bientot et encore merci
OpenOffice.org 2.0.3
windows XP familial pack 2
bribri
NOOuvel adepte
NOOuvel adepte
 
Message(s) : 20
Inscrit le : 10 Oct 2006 07:08


Retour vers Tableur

Qui est en ligne ?

Utilisateur(s) parcourant ce forum : Google [Bot] et 18 invité(s)